質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.91%

Rails6でBootstrap4のためにjQueryを動かしたいが、application.jsがないといわれる。

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 182

shisha

score 59

困っていること

Rails 6にjQueryとBootstrapを入れる - Qiita
上記の2番目の「昔ながらのassetsを使う方法」で試しています。
先の最後で、javascript_pack_tag に加えて、 javascript_include_tag を追記すると、ここでエラーがでます。

  <head>

    <%= stylesheet_link_tag 'application', media: 'all', 'data-turbolinks-track': 'reload' %>
    <%= javascript_include_tag 'application', 'data-turbolinks-track': 'reload' %>
    <%= javascript_pack_tag 'application', 'data-turbolinks-track': 'reload' %>
  </head>
Sprockets::Rails::Helper::AssetNotFound in Hellos#hello
Showing C:/Users/<username>/rails/<appname>/app/views/layouts/application.html.erb where line #9 raised:

The asset "application.js" is not present in the asset pipeline.


というように怒られます。

正直、javascript_pack_tag があるのに、 javascript_include_tag を追加する理由がよくわかっていないです。また、app/javascript/packs/application.jsがあるから問題ないのではと思うのですが、application.jsがないと怒られています。

なお、javascript_include_tagを記載しないと、
エラーなどはでないのですが、モーションがつかずjQueryが動いてないみたいです。
(もしかしたら、HTML側のBoostrapのクラス指定などが誤っている可能性もあります。ただ、Railsアプリケーション外では動いたコードなので大丈夫ではないかと思っています)

その他のソースコード

app/javascript/packs/application.js
require("@rails/ujs").start()
require("turbolinks").start()
require("@rails/activestorage").start()
require("channels")
//= require jquery
//= require jquery3
//= require jquery4
//= require popper
//= require bootstrap
//= require_tree .
console.log("javascript/packs/application.jsが読みこまれた");


全然動かないので、jQuery3とあるけど、バージョンが4みたいだからjQuery4と書いたりしてますが、なんというか特に関係なさそうです。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

+1

app/javascript/packs/application.jsがあるから問題ないのではと思うのですが、application.jsがないと怒られています。

app/javascript/packs/application.jsはWebpacker管理のもので、「昔ながらのassets」とは別系統です。

app/assets/javascripts/application.jsを作成してください。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.91%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る