質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.13%

VSCodeでPHPデバッグ時のブレークポイントが止まらない

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 102

shishimaru5

score 0

前提・実現したいこと

下記環境でブレークポイントを貼ってデバッグを実行したいのですが、躓いております。。。
何が悪いのかわかっていないため、問題個所をご指摘いただけますと幸いです。

クライアントOS:Win10Home
エディタ:VSCode
言語:PHP
サーバ:Docker でnginx, php を構築

発生している問題・エラーメッセージ

xdebug のログには

[6] I: Connecting to configured address/port: localhost:9000.
[6] I: Connected to client. :-)
[6] -> <init xmlns="urn:debugger_protocol_v1" xmlns:xdebug="https://xdebug.org/dbgp/xdebug" fileuri="file:///var/www/html/index.php" language="PHP" xdebug:language_version="7.2.31" protocol_version="1.0" appid="6" idekey="www-data"><engine version="2.9.6"><![CDATA[Xdebug]]></engine><author><![CDATA[Derick Rethans]]></author><url><![CDATA[https://xdebug.org]]></url><copyright><![CDATA[Copyright (c) 2002-2020 by Derick Rethans]]></copyright></init>

[6] -> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="https://xdebug.org/dbgp/xdebug" status="stopping" reason="ok"></response>

と表示されるため、接続は成功していると思っております。
エラーではないと思うのですが、このログメッセージで問題ないかどうかも正直分かっておりません。
しかし、VSCode 側でブレークポイントを貼っても止まりません。。。

設定

■php.ini のxdebug の箇所
[xdebug]
xdebug.remote_enable = On
xdebug.remote_host = localhost
xdebug.remote_port = 9000
xdebug.remote_autostart = On
xdebug.remote_log=/var/www/html/xdebug.log
xdebug.remote_connect_back = 0

■VSCode のlaunch.json
"configurations": [

{
"name": "Listen for XDebug",
"type": "php",
"request": "launch",
"port": 9000,
"stopOnEntry": true,
"pathMappings": {
"var/www/html":"${workspaceFolder}" 
}
},
{
"name": "Launch currently open script",
"type": "php",
"request": "launch",
"program": "${file}",
"cwd": "${fileDirname}",
"port": 9000
}
]

■フォルダ構成
www
└html:ここにソース格納

Docker 構築時にDocker 側のvar/www/html と上記www/html を連動

試したこと

launch.json のpathmappings を色々変更してみたのですが解決できず、となると他にどの設定が悪いのかもわかっていない状況です。

どこに問題があるか、ご指摘いただけないでしょうか?

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

check解決した方法

0

自己解決しました。
xdebug.remote_host の設定とpathMappings がやっぱりおかしかったです。
xdebug.remote_host はホストのプライベートIPでOKでした。(VMWare管理のVNet系ではない)
pathMappings はローカル側を
"${workspaceFolder}\\www\\html"
とすることで解決しました。
その他nginx の設定もNG ではありませんが見直す必要がありました。
デバッグ中のタイムアウト時間の設定みたいのが必要で、nginx.conf に
fastcgi_read_timeout 3600;
を追加しました。
値は何でも良いみたいですがそれなりに長くとった方が良さそうです。

ご確認・調査いただいた方いらっしゃいましたらありがとうございました。

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.13%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる