質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.38%

  • Node.js

    2466questions

    Node.jsとはGoogleのV8 JavaScriptエンジンを使用しているサーバーサイドのイベント駆動型プログラムです。

  • gulp

    348questions

    gulpは、Node.jsをベースとしたタスク自動化ツールの一つ。ストリームでファイルを処理することが特徴です。CSSプリプロセッサの使用時のコンパイルや、CSS・JavaScriptファイルの圧縮・結合などを自動的に行うことができます。

Gulp インストール時のWARN(lodash)が解消できない

解決済

回答 1

投稿

  • 評価
  • クリップ 1
  • VIEW 4,462

cotton88

score 79

Gulpをglobalにインストールしようと

npm install gulp -g


したんですが、

npm WARN deprecated lodash@1.0.2: lodash@<3.0.0 is no longer maintained. Upgrade to lodash@^4.0.0.


と出てきてしまいました。

とりあえずGulpはインストールできてはいるんですが、

npm lodash -v


では、3.5.3が入っているようです。
lodashのアップデートしようと思って、

npm update lodash


これを実行してもアップデートせず。
どうしたら、npm WARNは解消する事ができるでしょうか。

環境的には以下の通りです。
node -v
v5.5.0
※Homebrew からnode.jsをインストール

npm -v
3.5.3

Gulpのバージョン
CLI version 3.9.1
Local version 3.9.1

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

0

npm listしてみたところgulpの依存パッケージ内で使われているlodashのバージョンが1.0.2なのでメッセージが表示されているようです。依存パッケージでバージョンが指定されているので、それより新しいアップデートできないっぽいです。
/globule/package.json

"dependencies": {
    "glob": "~3.1.21",
    "lodash": "~1.0.1",
    "minimatch": "~0.2.11"
  },


依存パッケージでのアップデートは完了しているようで、gulpでもgulp 4からはそのメッセージは出なくなる予定とありました。現状WARNINGなので特にクリティカルな問題ではない感じなようですのでgulpのバージョンアップを待つしかなさそうなのかなと思いました。

参考
[Notice] lodash deprecation warning · Issue #1485 · gulpjs/gulp
Use lodash v3 by seethemhigh · Pull Request #22 · cowboy/node-globule
Node.jsのpackage.jsonのバージョン指定の"~(チルダ)"と"^(キャレット)"の違い - Qiita

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2016/02/13 14:36

    別の質問でも回答ありがとうございました。
    こちらも仕様(というかバージョンが指定されてる)の問題なんですね。。
    ありがとうございました。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.38%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る

  • Node.js

    2466questions

    Node.jsとはGoogleのV8 JavaScriptエンジンを使用しているサーバーサイドのイベント駆動型プログラムです。

  • gulp

    348questions

    gulpは、Node.jsをベースとしたタスク自動化ツールの一つ。ストリームでファイルを処理することが特徴です。CSSプリプロセッサの使用時のコンパイルや、CSS・JavaScriptファイルの圧縮・結合などを自動的に行うことができます。