質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
85.44%
Gatsby

Gatsbyとは、Reactベースの静的サイトジェネレータ。最新のフロントエンド技術を活かし、機能豊富なWebサイトやアプリケーションを作ることが可能です。GraphQLを用いてあらゆるソースからサイトのデータを取得。指定した設定に基づいて静的サイトを構築することができます。

Node.js

Node.jsとはGoogleのV8 JavaScriptエンジンを使用しているサーバーサイドのイベント駆動型プログラムです。

JavaScript

JavaScriptは、プログラミング言語のひとつです。ネットスケープコミュニケーションズで開発されました。 開発当初はLiveScriptと呼ばれていましたが、業務提携していたサン・マイクロシステムズが開発したJavaが脚光を浴びていたことから、JavaScriptと改名されました。 動きのあるWebページを作ることを目的に開発されたもので、主要なWebブラウザのほとんどに搭載されています。

React.js

Reactは、アプリケーションのインターフェースを構築するためのオープンソースJavaScriptライブラリです。

Q&A

解決済

3回答

4878閲覧

Gatsby.jsを実行しようとしたが、localhostのサーバーが立ち上がらない。

hukurou82

総合スコア1

Gatsby

Gatsbyとは、Reactベースの静的サイトジェネレータ。最新のフロントエンド技術を活かし、機能豊富なWebサイトやアプリケーションを作ることが可能です。GraphQLを用いてあらゆるソースからサイトのデータを取得。指定した設定に基づいて静的サイトを構築することができます。

Node.js

Node.jsとはGoogleのV8 JavaScriptエンジンを使用しているサーバーサイドのイベント駆動型プログラムです。

JavaScript

JavaScriptは、プログラミング言語のひとつです。ネットスケープコミュニケーションズで開発されました。 開発当初はLiveScriptと呼ばれていましたが、業務提携していたサン・マイクロシステムズが開発したJavaが脚光を浴びていたことから、JavaScriptと改名されました。 動きのあるWebページを作ることを目的に開発されたもので、主要なWebブラウザのほとんどに搭載されています。

React.js

Reactは、アプリケーションのインターフェースを構築するためのオープンソースJavaScriptライブラリです。

0グッド

0クリップ

投稿2020/06/17 10:14

前提・実現したいこと

Gatsby.jsを使い、開発サーバの起動(gatsby develop)をして初期の画面を立ち上げたい。
何かファイルを弄ったわけではないので、原因がわかりません。

発生している問題・エラーメッセージ

child_process.js:120 p.open(fd); ^ Error: EBADF: bad file descriptor, uv_pipe_open at Object._forkChild (child_process.js:120:5) at setupChildProcessIpcChannel (internal/bootstrap/pre_execution.js:227:30) at prepareMainThreadExecution (internal/bootstrap/pre_execution.js:46:3) at internal/main/run_main_module.js:11:1

該当のソースコード

エラーに書かれている、child_process.jsというjsファイルは見つからず

試したこと

Node.jsのバージョンが古いのかと思い新しくダウンロードしインストール。
node -v  v11.13.0

gitのバージョンもチェック
git --version   git version 2.24.1.windows.2

手順は、https://reffect.co.jp/react/gatsby-basic-tutorial-for-beginnersの手順と全く同じ方法を行っています。

デスクトップのGatsbyというフォルダにcdして、
npm install -g gatsby-cli
を実行。
gatsby –helpを実行してメッセージが表示されることを確認。

gatsby new gatsby-site https://github.com/gatsbyjs/gatsby-starter-hello-world
実行し、名前はgatsby-site、Hello-worldのスターターを利用。

インストールが終わり、
info
Your new Gatsby site has been successfully bootstrapped. Start developing it by running:

cd gatsby-site
gatsby develop

と表示されたので、
cd gatsby-siteで移動し、
gatsby developを実行したところ、エラーが表示されて止まった。

補足情報(FW/ツールのバージョンなど)

node -v  v11.13.0

git --version   git version 2.24.1.windows.2

気になる質問をクリップする

クリップした質問は、後からいつでもMYページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

guest

回答3

0

もしNodistを使用しているのでしたら、Nodistが悪さをしている可能性があります。
Nodistをアンインストールし、Nodeを再インストールしてみてください。

原因までは分かりませんが、私も同様の現象に悩まされており、上記の通り行ったところ直りました。

投稿2020/08/09 13:16

koowashi

総合スコア10

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

0

同様の状況です。
海外のフォーラムでも明確な回答には行き当たりませんでした。
識者の回答をお待ちしています・・・

node v11.13.0
npm 6.9.0
Gatsby CLI version: 2.12.52
Gatsby version: 2.23.10

投稿2020/07/01 04:36

CCS.Niiseki

総合スコア2

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

0

ベストアンサー

Nodeのパッケージ管理ツールnpm or yarn のバージョンを確認してください
gatsby-cli は内部でnpm or yarn を使用して各種パッケージをインストールします
(自分の環境ではyarnを使用)

Nodeが新しくてもパッケージ管理ツールが古いと失敗する可能性が高いです

下記、環境で確認してみましたが、正常に動作することが確認できました

os: macOs 10.14.6 node: v11.13.0 yarn: 1.22.4 (npm: 6.7.0) Gatsby CLI version: 2.12.49 Gatsby version: 2.23.10

p.s.
nodeの現時点での推奨バージョンはv12.18.1
最新バージョンは14.4.0

gitはソースコードを管理する機能なので影響はないはずです

投稿2020/06/24 02:14

KeitaYoshida

総合スコア18

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

hukurou82

2020/06/24 15:09

KeitaYoshida様 ありがとうございます。 npmのバージョンを確認したところ、 6.14.5 でした。 そして、node.jsを最新にし、 v12.18.1 になっています。 そして改めて npm install -g gatsby-cli をしたところ、下記の表示が出てインストールっぽいことをしているのですが、 npm WARN deprecated core-js@2.6.11: core-js@<3 is no longer maintained and not recommended for usage due to the number of issues. Please, upgrade your dependencies to the actual version of core-js@3. npm WARN deprecated urix@0.1.0: Please see https://github.com/lydell/urix#deprecated npm WARN deprecated resolve-url@0.2.1: https://github.com/lydell/resolve-url#deprecated D:\Nodist\bin\gatsby -> D:\Nodist\bin\node_modules\gatsby-cli\cli.js > gatsby-telemetry@1.3.14 postinstall D:\Nodist\bin\node_modules\gatsby-cli\node_modules\gatsby-telemetry > node src/postinstall.js || true > gatsby-cli@2.12.51 postinstall D:\Nodist\bin\node_modules\gatsby-cli > node scripts/postinstall.js Success! Welcome to the Gatsby CLI! Please visit https://www.gatsbyjs.org/docs/gatsby-cli/ for more information. npm WARN acorn-dynamic-import@4.0.0 requires a peer of acorn@^6.0.0 but none is installed. You must install peer dependencies yourself. + gatsby-cli@2.12.51 updated 5 packages in 26.927s gatsby –helpを打っても、 'gatsby' は、内部コマンドまたは外部コマンド、 操作可能なプログラムまたはバッチ ファイルとして認識されていません。 と返ってきてしまいました。 前回はちゃんとできたのに今回は出来なくなっているので、nodeのバージョンを戻すとか、そもそもパソコンで何か設定?を変えてしまったのかなと考えていて、一度初期化するか悩んでおります。
KeitaYoshida

2020/06/24 23:49

nodeのパスが通ってない可能性が高いので `node path windows` で検索してみてください PCの初期化は必要ないともいますが 前回gatsby コマンドが動いていたのであれば その時のパス情報が残っていると思うので消したほうが吉です
hukurou82

2020/06/27 13:20

返事が遅くなり申し訳ありません。 パスも通して実行可能となり、アドバイスに沿っていろいろ試してみましたが、やはり最初の質問内容と同じエラーが返ってきてしまいました。 KeitaYoshida様と同じような状態にしようとバージョンもちょっと合わせました。 node: v11.13.0 yarn: 1.22.4 npm: 6.9.0 Gatsby CLI version: 2.12.51 またちょっといろいろ調べてみようと思います。。。
guest

あなたの回答

tips

太字

斜体

打ち消し線

見出し

引用テキストの挿入

コードの挿入

リンクの挿入

リストの挿入

番号リストの挿入

表の挿入

水平線の挿入

プレビュー

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
85.44%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問