質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.36%

【XAMP】config.inc.phpファイルがないため、パスワード変更できない。

解決済

回答 3

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 2,482

score 128

解決したい課題

phpMyAdminの設定ファイルに記載されたrootアカウントのパスワードを変更したい。

現状

phpMyAdminの設定ファイルが存在しないため、config.inc.phpの編集ができない。
また、librariesフォルダもないため、config.default.phpの編集もできない。
イメージ説明

参考URL

https://www.adminweb.jp/xampp/mysql/index3.html
http://lovee7.blog.fc2.com/blog-entry-29.html
https://stackoverrun.com/ja/q/6856715

 

config.default.phpもしくはconfig.inc.phpでパスワードの設定を変更したいと思っているのですが、
私の環境ではそのようなファイルが見当たりません。
パソコン内を検索して探しましたが、どこにもありませんでした。
上記、参考URLの情報が古いのでしょうか。上記以外にも検索したサイトには同じことが記載されており、解決できません。
phpMyAdminのrootパスワード変更の方法について、何かご存知の方いらっしゃいましたら、ご教示願います。
よろしくお願いいたします(>_<)

追記

XAMPのコントロールパネルからMySQLのAdminをクリックすると以下の画像が表示されます。
これはphpMyAdminのパスワードを変更していないのが原因だと思っています。
イメージ説明

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 3

+1

インストールしたpmaが仮に「http://localhost/pma」なら
セットアッププログラムが「http://local/pma/setup/」なので
適当に入力してダウンロードするとconfig.inc.phpができあがります

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2020/06/15 21:49

    ご回答ありがとうございます!yambejpさん☺

    私がxampをインストールしたサイトは下記でござます。
    https://www.apachefriends.org/jp/index.html
    ダウンロードサイトから探してみよかと思います。
    因みに、http://localhost/pmaには404エラーでアクセスできなかたです。

    キャンセル

  • 2020/06/15 22:00

    > 404エラーでアクセスできなかた

    そこはご自身の環境にあわせてください

    キャンセル

  • 2020/06/15 22:05

    https://www.phpmyadmin.net/downloads/
    上記サイトからphpMyAdmin 4.9.5をダウンロードフォルダの中に、config.sample.inc.phpがありました。
    こちらのファイルでパスワード変更できそです!

    キャンセル

  • 2020/06/15 22:08

    パスワード変更しましたが、phpMyAdminにはアクセスできませんでした(._.)

    キャンセル

check解決した方法

0

改めて同じバージョンをインストールし直しました。
phpMyAdminフォルダがあることを確認できました。
お騒がせしました。
まあ。なければ別のバージョンでインストールし直せばよい話でしたね。
失礼しました。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

0

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2020/06/15 21:52

    失礼しました。コントロールパネルに記載されているv3.2.4がバージョン情報だと勘違いしました。
    正しくは、7.4.6です。

    キャンセル

  • 2020/06/15 22:04

    https://www.phpmyadmin.net/downloads/
    上記サイトからphpMyAdmin 4.9.5をダウンロードフォルダの中に、config.sample.inc.phpがありました。
    こちらのファイルでパスワード変更できそです!

    キャンセル

  • 2020/06/15 22:08

    パスワード変更しましたが、phpMyAdminにはアクセスできませんでした(._.)

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.36%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る