質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
87.20%

解決済

sh: webpack: command not found

aiai8976
aiai8976

総合スコア112

2回答

0評価

0クリップ

8011閲覧

投稿2020/05/06 05:52

編集2020/05/06 05:59

前提・実現したいこと

ついこの間まで正常にbuildできていたのに急に以下のようなエラーが出ました。
webpackのインストールのやり直しなど試しましたが、効果はないようです。
わかる方がいましたらコメントお願いします。

発生している問題・エラーメッセージ

(base) ~/Documents/react $ npm run watch > @ watch /Users/ユーザ名/Documents/react > webpack --watch sh: webpack: command not found npm ERR! code ELIFECYCLE npm ERR! syscall spawn npm ERR! file sh npm ERR! errno ENOENT npm ERR! @ watch: `webpack --watch` npm ERR! spawn ENOENT npm ERR! npm ERR! Failed at the @ watch script. npm ERR! This is probably not a problem with npm. There is likely additional logging output above. npm ERR! A complete log of this run can be found in: npm ERR! /Users/ユーザ名/.npm/_logs/2020-05-06T05_44_31_025Z-debug.log

該当のソースコード

package.json

{ "private": true, "license": "ISC", "author": "Josh Ruff", "scripts": { "clean": "rm -rf dist", "watch": "webpack --watch", "build": "webpack" }, "dependencies": { "react": "^16.7.0", "react-dom": "^16.7.0", "react-google-login": "^5.1.10", "react-hook-form": "^5.5.1", "react-router": "^5.1.2", "react-router-dom": "^5.1.2", "react-swipeable-views": "^0.13.9", "styled-components": "^5.0.1" }, "devDependencies": { "@babel/core": "^7.4.0", "@babel/plugin-proposal-class-properties": "^7.0.0", "@babel/plugin-proposal-export-namespace-from": "^7.0.0", "@babel/plugin-proposal-throw-expressions": "^7.0.0", "@babel/plugin-syntax-dynamic-import": "^7.0.0", "@babel/preset-env": "^7.0.0-beta.51", "@babel/preset-react": "^7.0.0-beta.51", "babel-eslint": "^10.1.0", "babel-loader": "^8.0.0-beta.0", "css-loader": "^3.0.0", "eslint": "^6.8.0", "eslint-config-airbnb": "^18.1.0", "eslint-config-prettier": "^6.11.0", "eslint-plugin-import": "^2.20.2", "eslint-plugin-jsx-a11y": "^6.2.3", "eslint-plugin-prettier": "^3.1.3", "eslint-plugin-react": "^7.19.0", "eslint-plugin-react-hooks": "^2.5.1", "node-sass": "^4.8.3", "prettier": "^2.0.5", "sass-loader": "^7.0.3", "style-loader": "^0.21.0", "webpack": "^4.12.0", "webpack-cli": "^3.3.0" } }

良い質問の評価を上げる

以下のような質問は評価を上げましょう

  • 質問内容が明確
  • 自分も答えを知りたい
  • 質問者以外のユーザにも役立つ

評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

気になる質問をクリップする

クリップした質問は、後からいつでもマイページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

  • プログラミングに関係のない質問
  • やってほしいことだけを記載した丸投げの質問
  • 問題・課題が含まれていない質問
  • 意図的に内容が抹消された質問
  • 過去に投稿した質問と同じ内容の質問
  • 広告と受け取られるような投稿

評価を下げると、トップページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

rubytomato

2020/05/06 06:18

package.jsonの内容を見ると、バンドルは npm run watch ではないかと思いますが、このコマンドを実行するとどうなりますか? それと、webpack/webpack-cliの再インストールというのはローカルでしょうか?それともグローバルでしょうか?
aiai8976

2020/05/06 06:36

npm run watchの結果をエラーの部分に掲載しているつもりです。 また、webpack-cliはローカルに再インストールしました。
rubytomato

2020/05/06 07:57

> npm run watchの結果をエラーの部分に掲載しているつもりです。 失礼いたしました。 それでは、npxがインストールされていれば npx webpack --version npx webpack-cli --version npxがインストールされていなければ .\node_modules\.bin\webpack --version .\node_modules\.bin\webpack-cli --version でバージョンは確認できますか? バージョンが確認できたら npx webpack --watch もしくは .\node_modules\.bin\webpack --watch の実行結果はどうでしょうか?

まだ回答がついていません

会員登録して回答してみよう

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
87.20%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問

同じタグがついた質問を見る