質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.53%

さくらVPSでNuxt.jsで作成したHPがドメインで表示されない

受付中

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 163

mio503

score 1

Nuxt.jsで作成したHPを公開したところ、IPアドレス+(ポート番号:3000)ではアクセスできるのですが、ドメイン名ではアクセスできずつまっています。
さくらVPSの本登録は済ませ、ドメインのネームサーバーは設定してありますので、
恐らくpackage.jsonの設定かディレクトリの影響かもしれません。

まったくの初心者で困り果てています。
なぜドメイン表示されないのか改善点を
お手数ですが、どなたかご教授頂けますと助かります。
よろしくお願いします。

package.json

{
  "name": "nuxt-kansya",
  "version": "1.0.0",
  "description": "My incredible Nuxt.js project",
  "author": "eiji",
  "private": true,
  "scripts": {
    "dev": "cross-env NODE_ENV=development nodemon server/index.js --watch server",
    "build": "NUXT_HOST=0.0.0.0 NUXT_PORT=3000 NODE_ENV=production nuxt build",
    "start": "NUXT_HOST=0.0.0.0 NUXT_PORT=3000 NODE_ENV=production node server/index.js",
    "generate": "nuxt generate"
  },
  "dependencies": {
    "bootstrap": "^4.1.3",
    "bootstrap-honoka": "^4.3.1",
    "bootstrap-vue": "^2.7.0",
    "cross-env": "^5.2.0",
    "express": "^4.16.4",
    "jquery": "^3.4.1",
    "nuxt": "^2.12.0",
    "popper.js": "^1.16.0",
    "sticky-state": "^2.4.1"
  },
  "devDependencies": {
    "nodemon": "^1.18.9"
  }
}

試してみた事

【Nuxt.jsでサーバーから独自ドメインで公開する方法】を参考にpackage.jsonを書き換えましたが、ドメインの表示されません。

参考にしているページ

ホストとポート番号を変更するには?
Nuxt.jsでサーバーから独自ドメインで公開する方法

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • Takumiboo

    2020/03/19 17:26

    Webが80番なのはさくらのVPSに限ったことではなく、業界標準です。なおHTTPSになると443番です。
    サーバは3000番ポートで動いていて、80番ポートは開いていて、ではその2つをつなぐ操作は行っていますか?

    キャンセル

  • Takumiboo

    2020/03/19 17:29

    ちなみにOSでファイヤーウォールが動いている場合はそちらの開放も必要です。
    さくらのVPSのデフォルトであるCentOSであればこちらが参考になるでしょう。
    https://knowledge.sakura.ad.jp/10583/

    キャンセル

  • mio503

    2020/03/19 17:31

    ご返信ありがとうございます。
    つなぐ操作は行っていないと思います。
    詳しく教えていただけませんか。

    キャンセル

回答 1

0

方法1 サーバ自体を80番ポートで動かす
Nuxt.jsに触れたことはないので詳細は調べていただければと思いますが、ご提示の設定ファイル「package.json」にてポート番号を指定しているようですので、こちらを80に変えれば、「http://ドメイン名」でアクセスできるのではないでしょうか。

方法2 リバースプロキシを動かす
もしかしたらこちらのほうが一般的かもしれません。
Nuxt.js自体は任意のポート番号で動かしておき、nginxやApacheをリバースプロキシとして動かし、外部には80番や443番にて見せることが出来ます。
https://wa3.i-3-i.info/word1755.html
https://itsakura.com/network-proxy#s2
こちらのほうが、nginxやApacheなどのWebサーバ側でSSL(HTTPS化)を行ったり出来るため、Nuxt.js側での追加の対応をせずに公開することが可能です。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2020/03/21 10:48

    Takumiboo様、ご丁寧にアドバイス頂き助かっています。
    ↓のページを参考にリバースプロキシの設定を行いました。
    https://blog.neet-shikakugets.com/construct-reverse-proxy-using-apachehttp
    http://sample.com/でアクセスしたらリダイレクトされ、http://sample.com:3000/にアクセスできたのですが、SSL(https://sample.com/)でアクセスしたところ、
    Proxy Error
    The proxy server received an invalid response from an upstream server.
    The proxy server could not handle the request GET /.

    Reason: Error reading from remote server
    と出てリダイレクトされていないみたいです。
    ↓のページを参考にlet's Encryptのインストールしたのですが、
    https://knowledge.sakura.ad.jp/10534/

    質問のSelect the appropriate number [1-2] then [enter] (press 'c' to cancel):2 (httpアクセスをhttpsにリダイレクトします)ではなく、1としてしまい、多分これが影響しているようです。
    let's Encryptのappropriate number内容の変更はできるのでしょうか?
    ↓こちらのページを参考に試みましたが、
    https://aoboshi.org/?p=904
    ↓実行コマンド
    # sudo certbot –authenticator standalone –installer apache -d ドメイン名
    usage:
    certbot [SUBCOMMAND] [options] [-d DOMAIN] [-d DOMAIN] ...

    Certbot can obtain and install HTTPS/TLS/SSL certificates. By default,
    it will attempt to use a webserver both for obtaining and installing the
    certificate.
    certbot: error: unrecognized arguments: –authenticator standalone –installer apache
    となってしまいました。
    let's Encryptの入れ直しも考えてのですが、方法がわからず行き詰まってしまいました。
    少しでも分かることがあればご助言頂けないでしょうか。

    キャンセル

  • 2020/03/21 14:27

    ssl.confのProxyPassのhttps→httpに内容変更で
    SSL(https://sample.com/)のアクセスに対してProxy Errorはなくなりアクセスできるようになりました。
    あとは、httpでアクセスでリダイレクトできればいいのですが。

    キャンセル

  • 2020/03/21 22:00

    httpでのアクセスをhttpsにリダイレクトさせるのはApache側で可能です。「Apache https 統一」「Apache 常時SSL」などで検索すると出てくるかと思います。なお「.htaccessファイルに設定を書き込む」手順より、「confファイルに設定を書き込む」手順を参考にされると良いと思います。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.53%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る