質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.51%

  • CentOS

    3128questions

    CentOSは、主にRed Hat Enterprise Linux(RHEL)をベースにした、フリーのソフトウェアオペレーティングシステムです。

  • Apache

    2097questions

    Apacheは、Apache HTTP Serverの略で、最も人気の高いWebサーバソフトウェアの一つです。安定性が高いオープンソースソフトウェアとして商用サイトから自宅サーバまで、多くのプラットフォーム向けに開発・配布されています。サーバーソフトウェアの不具合(NCSA httpd)を修正するパッチ(a patch)を集積、一つ独立したソフトウェアとして開発されました。

  • VPS

    458questions

    VPS(バーチャル・プライベート・サーバ)は、仮想化されたサーバをレンタルするサービスで、共有サーバでありながら専門サーバと同等の機能を果たします。物理的な専門サーバより安価で提供できるメリットがあります。

ApacheのLimitExceptが効かない

受付中

回答 1

投稿 編集

  • 評価
  • クリップ 2
  • VIEW 2,974

shutosg

score 15

VPSのApacheでウェブサイトを運営している者です。

セキュリティを高めるために、Apacheの設定のLimitExceptを用いてHTTPリクエストのGETとPOST、OPTIONS以外を拒否するように設定しようとしたのですが、上手くいきません。同じ記述(後述)で自宅のラズパイウェブサーバでは設定が有効になっているので記述にミスは無いように思えます。。。

まずVPSのApacheの設定状況です。VirtualHostを用いて複数のサイトを運営しており、全サイトに適用したいので、/var/www以下に設定します。(/var/www/以下に全てのサイトの公開ディレクトリがあります)

<Directory "/var/www">
    AllowOverride None
    Require all granted
<LimitExcept GET POST OPTIONS>
    Order deny,allow
    Deny from all
</LimitExcept>
</Directory>


これをして、httpdを再起動してから

$ telnet サイトのurl 80
Trying XXX.XXX.XXX.XXX...
Connected to サイトのurl.
Escape character is '^]'.
CONNECT 127.0.0.1:25 HTTP/1.0


とするとウェブサイトのトップページが返されてしまいます。上記設定部分に関して"全く"同じ設定をしたラズパイウェブサーバ(VirtualHost未使用)にtelnetするときちんと403 Forbiddenが返って来ます。設定が有効にならない原因が全く分からないのですが、何か考えられる原因や、見落としている箇所を教えていただきたく思います。よろしくお願いいたします。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

0

「全サイトに適用したいので、/var/www以下に設定します」とありますが、その理論なら"/"でもOKとなりますね。

そんな設定はしたことないのでわからないのですが、
ファイルパスはドキュメントルート以下のパスまで指定しないといけない気がします。
(ゴメンなさい。試してません)

普通はバーチャルホストごとのディレクティブ内で、そのドキュメントルートごとに設定するとおもいます。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2016/01/15 21:46

    ご回答ありがとうございます。確かに"/"でも試しましたし、ドキュメントルート以下のパスまで指定しても試しましたが、ダメでした。
    ラズパイサーバも同じく"/var/www"で指定していますが、公開ドキュメントは/var/www/html/index.htmlとなっており、それでも反映されています。

    キャンセル

  • 2016/01/15 23:05

    ローカルで検証してみました。
    http.conf の一番最後に、8080/8081ポートで2つVirtualHostを立ち上げ、同じようにCONNECTで呼び出したら、403 Forbiddenが返って来ますね。

    http.conf ------------------------------------------
    <Directory "/var/www">
    <LimitExcept GET POST OPTIONS>
    Order deny,allow
    Deny from all
    </LimitExcept>
    </Directory>

    Listen 8080
    <VirtualHost *:8080>
    DocumentRoot "/var/www/test/v1/"
    ServerName v1
    </VirtualHost>
    Listen 8081
    <VirtualHost *:8081>
    DocumentRoot "/var/www/test/v2/"
    ServerName v2
    </VirtualHost>
    end -------------------------------

    検証 ------------------------------------------
    $ telnet localhost 8080
    :
    CONNECT /
    <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
    <html><head>
    <title>403 Forbidden</title>
    :

    $ telnet localhost 8081
    :
    CONNECT /
    <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
    <html><head>
    <title>403 Forbidden</title>
    end -------------------------------


    ちょっと気になったのですが、、、

    VertualHostはポートベースですか?それとも名前ベースでしょうか?

    検証時、ポート80に接続してから
    CONNECTでIPとポートを指定してますが、この検証方法であってますか?

    ポートベースなら、telnet接続する時の ポートを変えなければいけないかと。
    ネームベースなら、"CONNECT 127.0.0.1:25 HTTP/1.0"ではなく、
    ”CONNECT / HTTP/1.0"で呼んでみたらどうなりますか?

    キャンセル

  • 2016/02/08 01:03

    返事が大変遅れてしまい申し訳ありません。
    ローカルサーバーでの検証ありがとうございます。そちらでは適切に動作しているようです。<Directory "/var/www">の行を<Directory "/var/www/v1">にするとおそらく8080ポートにCONNECTリクエストを送った時のみ403が返ってきて、8081ポートへは400 Bad Requestが返ってくるように思えます。

    >VertualHostはポートベースですか?それとも名前ベースでしょうか?
    私の環境では名前ベースのVirtualHostを使用しています。

    >検証時、ポート80に接続してから
    >CONNECTでIPとポートを指定してますが、この検証方法であってますか?
    CONNECTメソッド自体はもともと、プロキシサーバにトンネリング(中継)させるためのリクエストで、今回の例の「CONNECT 127.0.0.1:25 HTTP/1.0」では「127.0.0.1の25番ポートへの通信を中継しろ」という意味です。もちろん127.0.0.1:25は試験的に用いた値であって本来は接続先のドメインなりIPなり、接続先ポートも記述します。その為この記述のしかたが本来正しいのだと認識しております。

    >”CONNECT / HTTP/1.0"で呼んでみたらどうなりますか?
    400 Bad Requestと言われてしまいます。試しに"CONNECT example.net HTTP/1.0"でやってみても同じくBad Requestでした。"CONNECT example.net:25 HTTP/1.0"のようにポート番号も指定してやると127.0.0.1:25と同じようにトップページが返ってきます。

    <LimitExcept GET POST OPTIONS>
    Order deny,allow
    Deny from all
    </LimitExcept>
    という設定を適用した時点でGETとPOSTとOPTIONS以外のメソッド(CONNECTやHEADなど)は403が返ってくるはずなのですが、やはりうまくいきません。。。

    キャンセル

同じタグがついた質問を見る

  • CentOS

    3128questions

    CentOSは、主にRed Hat Enterprise Linux(RHEL)をベースにした、フリーのソフトウェアオペレーティングシステムです。

  • Apache

    2097questions

    Apacheは、Apache HTTP Serverの略で、最も人気の高いWebサーバソフトウェアの一つです。安定性が高いオープンソースソフトウェアとして商用サイトから自宅サーバまで、多くのプラットフォーム向けに開発・配布されています。サーバーソフトウェアの不具合(NCSA httpd)を修正するパッチ(a patch)を集積、一つ独立したソフトウェアとして開発されました。

  • VPS

    458questions

    VPS(バーチャル・プライベート・サーバ)は、仮想化されたサーバをレンタルするサービスで、共有サーバでありながら専門サーバと同等の機能を果たします。物理的な専門サーバより安価で提供できるメリットがあります。