質問するログイン新規登録

Q&A

解決済

1回答

3006閲覧

postgreSQLのインストールについて

akirin062

総合スコア19

CentOS

CentOSは、主にRed Hat Enterprise Linux(RHEL)をベースにした、フリーのソフトウェアオペレーティングシステムです。

Ruby on Rails 6

Ruby on Rails 6は、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

PostgreSQL

PostgreSQLはオープンソースのオブジェクトリレーショナルデータベース管理システムです。 Oracle Databaseで使われるPL/SQLを参考に実装されたビルトイン言語で、Windows、 Mac、Linux、UNIX、MSなどいくつものプラットフォームに対応しています。

Linux

Linuxは、Unixをベースにして開発されたオペレーティングシステムです。日本では「リナックス」と呼ばれています。 主にWebサーバやDNSサーバ、イントラネットなどのサーバ用OSとして利用されています。 上位500のスーパーコンピュータの90%以上はLinuxを使用しています。 携帯端末用のプラットフォームAndroidは、Linuxカーネル上に構築されています。

0グッド

0クリップ

投稿2020/03/15 13:49

編集NaN/aN/aN aN:aN

0

0

CentOSにruby on railsの環境を構築し、PostgreSQLを使用したいと思って環境構築しています。
PostgreSQLをインストールした後、初期化した後、下記のPostgreSQLをサービス起動コマンドを実行したところ、エラーが発生しました。

サービス起動コマンド
sudo service postgresql start

エラー
Job for postgresql.service failed because the control process exited with error code. See "systemctl status postgresql.service" and "journalctl -xe" for details.

エラー文の中にあるsystemctl status postgresql.serviceを実行したところ、以下のメッセージが表示されましたが、
解決方法が分かりません。どうか解決方法をよろしくお願いします。

● postgresql.service - PostgreSQL database server
Loaded: loaded (/usr/lib/systemd/system/postgresql.service; disabled; vendor preset: disabled)
Active: failed (Result: exit-code) since 日 2020-03-15 22:40:57 JST; 9s ago
Process: 30968 ExecStart=/usr/bin/pg_ctl start -D ${PGDATA} -s -o -p ${PGPORT} -w -t 300 (code=exited, status=1/FAILURE)
Process: 30963 ExecStartPre=/usr/bin/postgresql-check-db-dir ${PGDATA} (code=exited, status=0/SUCCESS)

3月 15 22:40:56 tk2-260-39672.vs.sakura.ne.jp systemd[1]: Starting PostgreSQL database server...
3月 15 22:40:56 tk2-260-39672.vs.sakura.ne.jp pg_ctl[30968]: LOG: IPv4ソケットをバインドできませんでした: アドレスは既に使用中です
3月 15 22:40:56 tk2-260-39672.vs.sakura.ne.jp pg_ctl[30968]: ヒント: すでに他にpostmasterがポート5432で稼動していませんか? 稼動していなければ数秒待ってから再実行してください
3月 15 22:40:56 tk2-260-39672.vs.sakura.ne.jp pg_ctl[30968]: WARNING: "localhost"に関する監視用ソケットを作成できませんでした
3月 15 22:40:56 tk2-260-39672.vs.sakura.ne.jp pg_ctl[30968]: FATAL: TCP/IPソケットを作成できませんでした
3月 15 22:40:57 tk2-260-39672.vs.sakura.ne.jp systemd[1]: postgresql.service: control process exited, code=exited status=1
3月 15 22:40:57 tk2-260-39672.vs.sakura.ne.jp systemd[1]: Failed to start PostgreSQL database server.
3月 15 22:40:57 tk2-260-39672.vs.sakura.ne.jp systemd[1]: Unit postgresql.service entered failed state.
3月 15 22:40:57 tk2-260-39672.vs.sakura.ne.jp systemd[1]: postgresql.service failed.

下記のコマンドを実行したところ5432ポートがtcpで使用されていることがわかりました。
これが原因になりますでしょうか?原因ならばどう解決すればよいでしょうか?

sudo firewall-cmd --list-all

public (active)
target: default
icmp-block-inversion: no
interfaces: eth0
sources:
services: dhcpv6-client http ssh
ports: 5432/tcp 3000/tcp
protocols:
masquerade: no
forward-ports:
source-ports:
icmp-blocks:
rich rules:

気になる質問をクリップする

クリップした質問は、後からいつでもMYページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

guest

回答1

0

自己解決

起動しているのでcreate databaseなど行い、作成することができました。
ありがとうございます。

投稿2020/03/22 05:03

akirin062

総合スコア19

あなたの回答

tips

太字

斜体

打ち消し線

見出し

引用テキストの挿入

コードの挿入

リンクの挿入

リストの挿入

番号リストの挿入

表の挿入

水平線の挿入

プレビュー

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
85.25%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問