質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.96%

WindowsServer2016 の 役割と機能の追加ウィザードで、インストールした.NET Framework 4.7ではなく4.6が表示されてしまう。

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 1,702

score 5

WindowsServer2016 の 役割と機能の追加ウィザードで、インストールした.NET Framework 4.7が表示されず、4.6が表示されてしまっています。
4.7の機能を使いたいので、4.7を表示させる方法を知りたいです。

regedit で確認したRelease REG_DWORD の値は461814だったので、
.NET Framework 4.7.2はインストールできていると思います。

よろしくお願いします。

イメージ説明

イメージ説明

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

0

.NET Framework は 4.0 から上のものは、内部的には同じ CLR 4 となり、共存しません。
つまり 4.7.2 が入っている状態であれば、4.6 は入ることはありません。

機能の選択に出てくるのが 4.6 なのは、 Windows Server 2016 リリース当時の最新バージョンが 4.6 だからであって、これは実際には「.NET CLR 4」のインストールを意味しているので、ここの表示が 4.6 だからといって 4.6 しか入らないわけではありません。
実際には、仮に 4.6 が入ったとしても、その後の Windows Update で最新化されます。

ですので気にせず使ってください。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2020/03/10 15:29

    回答ありがとうございます。

    表示されているものは4.6であっても内部的には4.7ということでしょうか?
    それともなにかしらのWindows Updateがくるまで4.7としての機能は使えないですか?

    今使おうとしているアプリケーションが4.7.2以上しか対応しておらず、実際にエラーが発生するためここが原因だと考えていたため教えていただきたいです。

    キャンセル

  • 2020/03/10 15:44

    前者です。現時点で 4.7.2 が入っているとレジストリに記載されているのですから、4.7.2 の機能が使えるはずですよ。

    アプリケーションがエラーを出すと云うことですが、そのアプリは 32bit ではありませんか?
    であればレジストリ HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\NET Framework Setup\NDP\v4\Full の下の Release の値が違っているのではないでしょうか。

    キャンセル

  • 2020/03/10 17:57

    結論としてはこのフレームワークは私の直面していたエラーの原因ではありませんでしたが、問題がないという回答をいただけたことによって別の部分での間違いを探すことに集中でき解決しました。ありがとうございます。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.96%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る

  • トップ
  • Windowsに関する質問
  • WindowsServer2016 の 役割と機能の追加ウィザードで、インストールした.NET Framework 4.7ではなく4.6が表示されてしまう。