質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

91.77%

  • Ruby

    4346questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails 4

    1970questions

    Ruby on Rails4はRubyによって書かれたオープンソースのウェブフレームワークです。 Ruby on Railsは「設定より規約」の原則に従っており、効率的に作業を行うために再開発を行う必要をなくしてくれます。

Cloud9でRuby2.2.2以上にバージョンアップすることはできますか

解決済

回答 2

投稿 2016/01/13 20:58

  • 評価
  • クリップ 0
  • VIEW 1,401

waspman

score 205

Cloud9でRuby2.2.2以上にバージョンアップすることはできますか?

Ruby on Rails 5.0.0 betaを使いたいのですが
Ruby 2.2.2以上が必要で困っております。

ご存知のかたいらっしゃいましたら教えていただけますでしょうか。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

+1

rvmは使えますね。

$ rvm install 2.2.4
Searching for binary rubies, this might take some time.
Found remote file https://rubies.travis-ci.org/ubuntu/14.04/x86_64/ruby-2.2.4.tar.bz2
Checking requirements for ubuntu.
Requirements installation successful.
ruby-2.2.4 - #configure
ruby-2.2.4 - #download
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:--  0:00:01 --:--:--     0
100 22.9M  100 22.9M    0     0  2027k      0  0:00:11  0:00:11 --:--:-- 4438k
No checksum for downloaded archive, recording checksum in user configuration.
ruby-2.2.4 - #validate archive
ruby-2.2.4 - #extract
ruby-2.2.4 - #validate binary
ruby-2.2.4 - #setup
ruby-2.2.4 - #gemset created /usr/local/rvm/gems/ruby-2.2.4@global
ruby-2.2.4 - #importing gemset /usr/local/rvm/gemsets/global.gems...................................
ruby-2.2.4 - #generating global wrappers........
ruby-2.2.4 - #gemset created /usr/local/rvm/gems/ruby-2.2.4
ruby-2.2.4 - #importing gemsetfile /usr/local/rvm/gemsets/default.gems evaluated to empty gem list
ruby-2.2.4 - #generating default wrappers........
$ rvm list

rvm rubies

   ruby-1.9.3-p551 [ x86_64 ]
   ruby-2.1.5 [ x86_64 ]
 * ruby-2.2.1 [ x86_64 ]
   ruby-2.2.2 [ x86_64 ]
=> ruby-2.2.4 [ x86_64 ]

# => - current
# =* - current && default
#  * - default

$ ruby -v
ruby 2.2.4p230 (2015-12-16 revision 53155) [x86_64-linux]

MEMORY,CPUのゲージのところから出るメニューのRestartボタンを押すなどして、再起動してもrvmの設定は残ります。
rvm --default useでデフォルトを指定できます。
bundle云々はわかりません。

$ rvm --default use 2.2.4
Using /usr/local/rvm/gems/ruby-2.2.4

投稿 2016/01/13 21:12

編集 2016/01/13 22:01

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    以下のような回答は評価を下げられます

    • 間違っている回答
    • 質問の回答になっていない投稿
    • 不快な投稿

    評価を下げる際はその理由をコメントに書き込んでください。

  • 2016/01/13 21:36

    ありがとうございます
    バージョンアップできたのですが
    bundle installするとコマンドがありませんと言われたため再起動しました。
    するとまたRubyのバージョンが2.2.1にもどってしまいました。
    これはCloud9の仕様上2.2.1より新しいバージョンが使えないということでしょうか…

    キャンセル

  • 2016/01/14 09:04

    ありがとうございます。
    rubyだけ入ったような感じなのですが、やっぱり
    bundle installのコマンドを受け付けてくれないかんじでした。

    キャンセル

check解決した方法

0

下記サイトを参考にCloud9に
Ruby2.2.3のインストールとRails5Betaのインストール
ができました。

Vagrant + VirtualBoxでつくるRails 5の環境構築

  1. Rubyのセットアップ
rbenvでRubyをセットアップします
$ cd
$ git clone git://github.com/sstephenson/rbenv.git .rbenv
$ git clone git://github.com/sstephenson/ruby-build.git ~/.rbenv/plugins/ruby-build
$ git clone https://github.com/sstephenson/rbenv-gem-rehash.git ~/.rbenv/plugins/rbenv-gem-rehash
$ echo 'export PATH="$HOME/.rbenv/bin:$PATH"' >> ~/.bashrc
$ echo 'eval "$(rbenv init -)"' >> ~/.bashrc
$ echo 'export PATH="$HOME/.rbenv/plugins/ruby-build/bin:$PATH"' >> ~/.bashrc
$ echo 'gem: --no-ri --no-rdoc' > ~/.gemrc
$ exec $SHELL

Rubyとbundlerをインストール

$ rbenv install 2.2.3 # ※結構時間がかかります
$ rbenv global 2.2.3
$ rbenv rehash
$ gem install bundler

ありがとうございます。

投稿 2016/01/14 09:03

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    以下のような回答は評価を下げられます

    • 間違っている回答
    • 質問の回答になっていない投稿
    • 不快な投稿

    評価を下げる際はその理由をコメントに書き込んでください。

15分調べてもわからないことは、teratailで質問しよう!

ただいまの回答率

91.77%

関連した質問

  • 解決済

    RVMとはなんですか?

    プログラミング初心者です。 Rubyを学習している最中なのですが、rvmというコマンドをみかけました。 これはどういったものなのでしょうか? どなたか詳しく教えていただけませんでし

  • 解決済

    nokogiriで、requireに関するエラー(?)が出てしまう。

    nokogiriをダウンロード後、事前にテキストエディタに書いておいたファイルを反映させようとしました。 しかし、以下の様なエラー文が出てきてしまい、分からなくて困っています。

  • 解決済

    Ruby コード修正

    今書いているコードを1つ上の段階へとグレードアップするため色々と質問させていただきました。 質問① 質問② ですがやはりうまくいかず苦戦していました。 あまり答えを聞くような形でよ

  • 受付中

    ruby で配列に入れたら順番が変わってしまいます

    csv 形式に入れてある英単語から、Anemone を使って weblio へクローラーをまわし、翻訳データをもってきています。 しかし実行するたび配列の要素の順番が変わってしま

同じタグがついた質問を見る

  • Ruby

    4346questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails 4

    1970questions

    Ruby on Rails4はRubyによって書かれたオープンソースのウェブフレームワークです。 Ruby on Railsは「設定より規約」の原則に従っており、効率的に作業を行うために再開発を行う必要をなくしてくれます。

閲覧数の多いRubyの質問