質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.55%

Androidのライブラリからクラスが見つからないです、どうやって探したらいいですか。

受付中

回答 2

投稿

  • 評価
  • クリップ 0
  • VIEW 239

rocket

score 30

Android開発と付き合っていると以下のようなエラーに度々遭遇します。

エラー: zzbにアクセスできません com.google.firebase.iid.zzbのクラス・ファイルが見つかりません

それでなんですが、このcom.google.firebase.iid.zzbのクラス、ファイルを含んだライブラリのバージョンを手動で探したいです。

手動で探すにはどうしたらいいですか?

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

+1

必要なライブラリが足りていないのかなと・・
ここにFirebaseのライブラリがリストアップされていますので、エラーになっているものと見比べて探してみると見つかるかもです

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2020/02/06 23:17

    Firebaseのライブラリ確かに拝見しました。
    いま少しわからないのですが、
    「クラス・ファイルが見つからない」というエラー内容から、そのクラス・ファイルが含まれたライブラリを指定してあげれば良いと思っています。

    バージョン毎のライブラリに何が含まれているかを調べる方法は無いものでしょうか?

    例としては
     ライブラリの xxxバージョン の内容が閲覧できるサイトなどが分かれば教えていただきたいです。

    キャンセル

  • 2020/02/07 21:00

    https://github.com/firebase/firebase-android-sdk
    ここがAndroid用のFirebaseライブラリのgithubです。
    この中のリンクを辿っていくと、各ライブラリのリリースノートや、各クラスのソースコードもわかりますので、ここから探すとよいかとおもいます

    キャンセル

-1

GoogleのFirebaseというサービスで使うものと考えるため、Firebaseを導入する必要があると考えます。
Firebase

何かのソースを参考に開発しているものと考えますが、Firebaseを使わないのであれば逆に使わないように改修すべきと考えます。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • この投稿は削除されました

  • 2020/01/22 16:48

    すみません、Firebaseを使おうとしています。
    FirebaseMessagingServiceクラスを継承して実装しています。必要そうなライブラリをimplementationしたんですが、上記のエラーが出ます。

    キャンセル

  • この投稿は削除されました

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.55%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる