質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.33%

npm install socket.ioでエラーが出る

解決済

回答 2

投稿

  • 評価
  • クリップ 3
  • VIEW 1,687

kajirita2002

score 14

$ npm install socket.io

npm WARN ws@7.2.1 requires a peer of bufferutil@^4.0.1 but none is installed. You must install peer dependencies yourself.
npm WARN ws@7.2.1 requires a peer of utf-8-validate@^5.0.2 but none is installed. You must install peer dependencies yourself.

+ socket.io@2.3.0
added 45 packages from 28 contributors and audited 202 packages in 3.703s
found 0 vulnerabilities
このようなエラーメッセージが出てきてしまいます
なぜなのでしょうか
環境は node v10.14.2です

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

checkベストアンサー

+2

※質問者様の回答を受けて編集しています

エラーが出る

WARNですので「警告」ですね。

次の2つの依存モジュールについての警告のようです。

  • bufferutil
  • utf-8-validate

1文だけ読むと、
npm WARN ws@7.2.1 requires a peer of bufferutil@^4.0.1 but none is installed. You must install peer dependencies yourself.
「ws@7.2.1モジュールはbufferutil@^4.0.1が要る のpeer(C++アドオン)が有る けどインストールされてないよ。ご自身で導入してね。(意訳)」

モジュール導入状況を再確認
ご自身の環境において node_modules フォルダ(共用/プロジェクト用)を覗いてみる。
モジュール名に相当するフォルダの有無でインストール状況を知ることができます。

なぜなのでしょうか

警告文からは「何らかの理由があって依存モジュールが導入しなかった」事は読み取れますが、詳細は不明です。

2つのモジュールについて、「npm moduleName@ver」や「git moduleName@ver」で検索し、npm や GitHub で確認すると、共に node-gyp (C++アドオンモジュール)にも対応しているようでした。

警告理由は次の2つが考えられます

  1. javascript版 / gyp版 のいずれも導入されていない。
  2. javascript版 は導入されているが gyp版 は導入されていない。

javascript版 / gyp版 のいずれかを導入する必要がある。
あるいは、よりパフォーマンスの高いgyp版の存在を示した。と言えそう。

とりあえず使えるようにするには、それぞれのモジュールについて
npm install コマンドを叩いてみることになりそうです。

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

0

上記で言う2でした! わかりやすい解説ありがとうございました!

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2020/01/08 12:56

    警告文中の peer の語は gyp版を指すようですね。
    私自身も勉強になりました。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.33%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る