質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.89%

activesupportのGem::ConflictErrorを解決したい

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 134

sanyagi_d_1

score 3

ドットインストールのActiveRecord入門#4にて、ruby main.rbを実行すると、
/home/vagrant/.rbenv/versions/2.6.5/lib/ruby/2.6.0/rubygems/specification.rb:2302:in `raise_if_conflicts': Unable to activate activerecord-5.1.7, because activesupport-6.0.2.1 conflicts with activesupport (= 5.1.7) (Gem::ConflictError)
というエラーが出ます。

この場合.rbenvフォルダ内か他フォルダ内のactivesupportどこを入れなおせば良いのでしょうか?

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • Orlofsky

    2019/12/26 20:07

    エラーメッセージはキャプチャではなく、表示された文字をそのまま質問にコピペしてください。https://teratail.com/help/question-tips#questionTips3-4-2

    キャンセル

  • sanyagi_d_1

    2019/12/26 21:05

    失礼しました。
    /home/vagrant/.rbenv/versions/2.6.5/lib/ruby/2.6.0/rubygems/core_ext/kernel_require.rb:54:in `require': cannot load such file -- active_record (LoadError)
    です。
    主な部分はcannot load such file -- active_record (LoadError)かと。

    あと開発環境を末尾に書くのも忘れていたので追記しておきます。
    Win10
    Vagrant 1.8.6
    PuTTY 0.67
    VirtualBox 5.1.8
    Cyberduck 5.2.0

    キャンセル

  • Orlofsky

    2019/12/26 21:17

    質問を修正してください。
    ここを読んでくれる人は少ないです。

    キャンセル

  • Orlofsky

    2019/12/26 21:56

    画像は削っては?
    私たちの仕事は無駄を省いて簡潔に文章を書ける能力は必須です。

    キャンセル

回答 1

checkベストアンサー

0

なんらかの原因でマシン内のgemの依存関係がおかしくなっているものと思われます。
Bundlerを使って依存関係を適切な状態に保って実行するとうまくいくかもしれません。

以下手順です。

# 下記コマンドを入力してGemfileを作成する
bundle init
# Gemfileを開き、一番下に以下の行を追加する
gem 'activerecord', '5.0.1'
gem 'sqlite3', '1.3.13'
# gemのインストールを実行する
bundle install
# インストールが終わったらbundle execを付けて実行してみる(以後、同じように実行する)
bundle exec main.rb

補足:「プロを目指す人のためのRuby入門」の読者の方へ

もし拙著「プロを目指す人のためのRuby入門」を読んでいて、第3章で同じようにGem::ConflictErrorというエラーに遭遇した場合は、以下のページも読んでみてください。

rubygems - Ruby test raise_if_conflictsのエラーについて - スタック・オーバーフロー

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2020/01/14 09:34

    回答ありがとうございます。
    実は10日程前に解決していて、フォルダをいったん削除したうえで(コードのバックアップは取ってあります)同サイトのSinatra入門に書かれていた

    gem uninstall -I -a -x --user-install --force
    gem install activerecord -v 5.1.3 --no-doc
    gem install sqlite3 -v 1.3.13 --no-doc

    を実行して解決しました。
    方法として正しかったのでしょうか?

    キャンセル

  • 2020/01/15 08:04

    「ドットインストールで勉強している間はそれでOK」というのが僕の認識です。
    もう少し詳しく説明すると次のようになります。

    最初の`gem uninstall -I -a -x --user-install --force`というコマンドはマシンにインストールされているgemをすべてアンインストールするコマンドです。
    参考 https://qiita.com/katoy/items/9bcba54b88c5fc7d9aa6

    「独学でRubyの勉強をする」というレベルであれば、「問題が起きたらとりあえずgemを全部アンインストールして再インストール」でも良いかもしれません。
    ただ、業務レベルになってくるとそういうことを毎回やるわけにはいかないので、Bundlerを使う(=gem同士がケンカしないように、依存関係をプロジェクトごとに閉じた状態にする)ことになると思います。

    キャンセル

  • 2020/01/16 20:31

    なるほど。
    プロジェクトごとにバージョン指定があるかもしれないのでBundler指定が得策ですね。
    わかりやすい解説ありがとうございました。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.89%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る