質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.78%

仮想マシンにphpをインストールできません

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 768

score 9

前提・実現したいこと

ドットインストールを見ながら環境構築中です
https://dotinstall.com/lessons/basic_localdev_win_v2/38608
の段階です

発生している問題・エラーメッセージ

puttyで仮想マシンにログインして./run.shを実行したところ、phpだけがインストールできませんでした
エラーメッセージは出てません

該当のソースコード

TASK [install php] *************************************************************
fatal: [localhost]: FAILED! => {"changed": false, "msg": "There are unfinished transactions remaining. You might consider running yum-complete-transaction first to finish them.\nThe program yum-complete-transaction is found in the yum-utils package.\n\n\nTransaction Check Error:\n  file /usr/lib64/libkadm5clnt_mit.so.8.0 from install of libkadm5-1.10.3-65.el6.x86_64 conflicts with file from package krb5-libs-1.10.3-57.el6.x86_64\n  file /usr/lib64/libkadm5srv_mit.so.8.0 from install of libkadm5-1.10.3-65.el6.x86_64 conflicts with file from package krb5-libs-1.10.3-57.el6.x86_64\n\nError Summary\n-------------\n\n", "rc": 1, "results": ["Loaded plugins: fastestmirror\nSetting up Install Process\nLoading mirror speeds from cached hostfile\n * base: ftp.yz.yamagata-u.ac.jp\n * epel: ftp.yz.yamagata-u.ac.jp\n * extras: ftp.yz.yamagata-u.ac.jp\n * remi-php56: ftp.riken.jp\n * remi-safe: ftp.riken.jp\n * updates: ftp.yz.yamagata-u.ac.jp\nResolving Dependencies\n--> Running transaction check\n---> Package php.x86_64 0:5.6.40-14.el6.remi will be installed\n---> Package php-cli.x86_64 0:5.6.40-14.el6.remi will be installed\n---> Package php-common.x86_64 0:5.6.40-14.el6.remi will be installed\n--> Processing Dependency: php-pecl-jsonc(x86-64) for package: php-common-5.6.40-14.el6.remi.x86_64\n--> Processing Dependency: php-pecl-zip(x86-64) for package: php-common-5.6.40-14.el6.remi.x86_64\n---> Package php-devel.x86_64 0:5.6.40-14.el6.remi will be installed\n--> Processing Dependency: autoconf for package: php-devel-5.6.40-14.el6.remi.x86_64\n--> Processing Dependency: automake for package: php-devel-5.6.40-14.el6.remi.x86_64\n--> Processing Dependency: krb5-devel(x86-64) for package: php-devel-5.6.40-14.el6.remi.x86_64\n--> Processing Dependency: libedit-devel(x86-64) for package: php-devel-5.6.40-14.el6.remi.x86_64\n--> Processing Dependency: libxml2-devel(x86-64) for package: php-devel-5.6.40-14.el6.remi.x86_64\n--> Processing Dependency: openssl-devel(x86-64) for package: php-devel-5.6.40-14.el6.remi.x86_64\n--> Processing Dependency: zlib-devel(x86-64) for package: php-devel-5.6.40-14.el6.remi.x86_64\n--> Processing Dependency: php-pecl-jsonc-devel(x86-64) for package: php-devel-5.6.40-14.el6.remi.x86_64\n---> Package php-gd.x86_64 0:5.6.40-14.el6.remi will be installed\n--> Processing Dependency: libt1.so.5()(64bit) for package: php-gd-5.6.40-14.el6.remi.x86_64\n---> Package php-intl.x86_64 0:5.6.40-14.el6.remi will be installed\n--> Processing Dependency: libicudata.so.50()(64bit) for package: php-intl-5.6.40-14.el6.remi.x86_64\n--> Processing Dependency: libicui18n.so.50()(64bit) for package: php-intl-5.6.40-14.el6.remi.x86_64\n--> Processing Dependency: libicuio.so.50()(64bit) for package: php-intl-5.6.40-14.el6.remi.x86_64\n--> Processing Dependency: libicuuc.so.50()(64bit) for package: php-intl-5.6.40-14.el6.remi.x86_64\n---> Package php-mbstring.x86_64 0:5.6.40-14.el6.remi will be installed\n---> Package php-mysqlnd.x86_64 0:5.6.40-14.el6.remi will be installed\n---> Package php-pdo.x86_64 0:5.6.40-14.el6.remi will be installed\n---> Package php-xml.x86_64 0:5.6.40-14.el6.remi will be installed\n--> Processing Dependency: libxslt.so.1(LIBXML2_1.0.11)(64bit) for package: php-xml-5.6.40-14.el6.remi.x86_64\n--> Processing Dependency: libxslt.so.1(LIBXML2_1.0.13)(64bit) for package: php-xml-5.6.40-14.el6.remi.x86_64\n--> Processing Dependency: libxslt.so.1(LIBXML2_1.0.18)(64bit) for package: php-xml-5.6.40-14.el6.remi.x86_64\n--> Processing Dependency: libxslt.so.1(LIBXML2_1.0.22)(64bit) for package: php-xml-5.6.40-14.el6.remi.x86_64\n--> Processing Dependency: libxslt.so.1(LIBXML2_1.0.24)(64bit) for package: php-xml-5.6.40-14.el6.remi.x86_64\n--> Processing Dependency: libexslt.so.0()(64bit) for package: php-xml-5.6.40-14.el6.remi.x86_64\n--> Processing Dependency: libxslt.so.1()(64bit) for package: php-xml-5.6.40-14.el6.remi.x86_64\n--> Running transaction check\n---> Package autoconf.noarch 0:2.63-5.1.el6 will be installed\n---> Package automake.noarch 0:1.11.1-4.el6 will be installed\n---> Package krb5-devel.x86_64 0:1.10.3-65.el6 will be installed\n--> Processing Dependency: libkadm5(x86-64) = 1.10.3-65.el6 for package: krb5-devel-1.10.3-65.el6.x86_64\n--> Processing Dependency: libselinux-devel for package: krb5-devel-1.10.3-65.el6.x86_64\n--> Processing Dependency: libcom_err-devel for package: krb5-devel-1.10.3-65.el6.x86_64\n--> Processing Dependency: keyutils-libs-devel for package: krb5-devel-1.10.3-65.el6.x86_64\n---> Package libedit-devel.x86_64 0:2.11-4.20080712cvs.1.el6 will be installed\n--> Processing Dependency: ncurses-devel for package: libedit-devel-2.11-4.20080712cvs.1.el6.x86_64\n---> Package libicu-last.x86_64 0:50.1.2-17.el6.remi will be installed\n---> Package libxml2-devel.x86_64 0:2.7.6-21.el6_8.1 will be installed\n---> Package libxslt.x86_64 0:1.1.26-2.el6_3.1 will be installed\n---> Package openssl-devel.x86_64 0:1.0.1e-58.el6_10 will be installed\n---> Package php-pecl-jsonc.x86_64 0:1.3.10-2.el6.remi.5.6 will be installed\n---> Package php-pecl-jsonc-devel.x86_64 0:1.3.10-2.el6.remi.5.6 will be installed\n---> Package php-pecl-zip.x86_64 0:1.15.5-1.el6.remi.5.6 will be installed\n--> Processing Dependency: libzip5(x86-64) >= 1.5.2 for package: php-pecl-zip-1.15.5-1.el6.remi.5.6.x86_64\n--> Processing Dependency: libzip.so.5()(64bit) for package: php-pecl-zip-1.15.5-1.el6.remi.5.6.x86_64\n---> Package t1lib.x86_64 0:5.1.2-6.el6_2.1 will be installed\n---> Package zlib-devel.x86_64 0:1.2.3-29.el6 will be installed\n--> Running transaction check\n---> Package keyutils-libs-devel.x86_64 0:1.4-5.el6 will be installed\n---> Package libcom_err-devel.x86_64 0:1.41.12-24.el6 will be installed\n---> Package libkadm5.x86_64 0:1.10.3-65.el6 will be installed\n---> Package libselinux-devel.x86_64 0:2.0.94-7.el6 will be installed\n--> Processing Dependency: libsepol-devel >= 2.0.32-1 for package: libselinux-devel-2.0.94-7.el6.x86_64\n--> Processing Dependency: pkgconfig(libsepol) for package: libselinux-devel-2.0.94-7.el6.x86_64\n---> Package libzip5.x86_64 0:1.5.2-1.el6.remi will be installed\n---> Package ncurses-devel.x86_64 0:5.7-4.20090207.el6 will be installed\n--> Running transaction check\n---> Package libsepol-devel.x86_64 0:2.0.41-4.el6 will be installed\n--> Finished Dependency Resolution\n\nDependencies Resolved\n\n================================================================================\n Package                Arch     Version                     Repository    Size\n================================================================================\nInstalling:\n php                    x86_64   5.6.40-14.el6.remi          remi-php56   2.7 M\n php-cli                x86_64   5.6.40-14.el6.remi          remi-php56   4.0 M\n php-common             x86_64   5.6.40-14.el6.remi          remi-php56   1.1 M\n php-devel              x86_64   5.6.40-14.el6.remi          remi-php56   1.2 M\n php-gd                 x86_64   5.6.40-14.el6.remi          remi-php56    82 k\n php-intl               x86_64   5.6.40-14.el6.remi          remi-php56   214 k\n php-mbstring           x86_64   5.6.40-14.el6.remi          remi-php56   973 k\n php-mysqlnd            x86_64   5.6.40-14.el6.remi          remi-php56   280 k\n php-pdo                x86_64   5.6.40-14.el6.remi          remi-php56   122 k\n php-xml                x86_64   5.6.40-14.el6.remi          remi-php56   224 k\nInstalling for dependencies:\n autoconf               noarch   2.63-5.1.el6                base         781 k\n automake               noarch   1.11.1-4.el6                base         550 k\n keyutils-libs-devel    x86_64   1.4-5.el6                   base          29 k\n krb5-devel             x86_64   1.10.3-65.el6               base         504 k\n libcom_err-devel       x86_64   1.41.12-24.el6              base          33 k\n libedit-devel          x86_64   2.11-4.20080712cvs.1.el6    base          26 k\n libicu-last            x86_64   50.1.2-17.el6.remi          remi-safe    7.3 M\n libkadm5               x86_64   1.10.3-65.el6               base         143 k\n libselinux-devel       x86_64   2.0.94-7.el6                base         137 k\n libsepol-devel         x86_64   2.0.41-4.el6                base          64 k\n libxml2-devel          x86_64   2.7.6-21.el6_8.1            base         1.1 M\n libxslt                x86_64   1.1.26-2.el6_3.1            base         452 k\n libzip5                x86_64   1.5.2-1.el6.remi            remi-safe     52 k\n ncurses-devel          x86_64   5.7-4.20090207.el6          base         641 k\n openssl-devel          x86_64   1.0.1e-58.el6_10            updates      1.2 M\n php-pecl-jsonc         x86_64   1.3.10-2.el6.remi.5.6       remi-php56    52 k\n php-pecl-jsonc-devel   x86_64   1.3.10-2.el6.remi.5.6       remi-php56    31 k\n php-pecl-zip           x86_64   1.15.5-1.el6.remi.5.6       remi-php56    54 k\n t1lib                  x86_64   5.1.2-6.el6_2.1             base         160 k\n zlib-devel             x86_64   1.2.3-29.el6                base          44 k\n\nTransaction Summary\n================================================================================\nInstall      30 Package(s)\n\nTotal size: 24 M\nInstalled size: 89 M\nDownloading Packages:\nRunning rpm_check_debug\nRunning Transaction Test\n"]}
        to retry, use: --limit @/home/vagrant/centos6/main.retry

試したこと

powershellで一旦マシンを落とし、再び立ち上げてもう一度実行しましたが同じ結果でした

補足情報(FW/ツールのバージョンなど)

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • m.ts10806

    2019/11/27 06:31

    エラーメッセージを提示しておいてエラー出てませんとは…
    ひとまず参考先だけ提示されても本当にその通りしたかはわかりません。
    ご自身が実施した手順をなるべく正確に列挙してください

    キャンセル

  • 退会済みユーザー

    退会済みユーザー

    2019/11/27 09:40

    ドットインストールなら、プレミアム会員になって先生に質問したら解決早いのでは?

    キャンセル

回答 1

checkベストアンサー

+1

エラーメッセージの冒頭に対策が書かれています。

fatal: [localhost]: FAILED! => {"changed": false, "msg": "There are unfinished transactions remaining. You might consider running yum-complete-transaction first to finish them.
The program yum-complete-transaction is found in the yum-utils package.

メッセージに従って、次の操作を行い、そのあとで run.sh を実行してみてください。

$ sudo yum install -y yum-utils
$ sudo yum-complete-transaction --cleanup-only
$ yum update -y

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/12/05 11:44

    解決しました
    ありがとうございます

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.78%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る