質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
85.44%
Ruby on Rails 5

Ruby on Rails 5は、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

Ruby

Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

Q&A

解決済

1回答

990閲覧

ターミナルでRails関連のコマンドが一切使えなくなってしまいました。

r_hara

総合スコア8

Ruby on Rails 5

Ruby on Rails 5は、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

Ruby

Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

0グッド

0クリップ

投稿2019/11/25 13:29

Library not loaded: /usr/local/opt/openssl/lib/libssl.1.0.0.dylib (LoadError) Referenced from: /Users/username/.rbenv/versions/2.5.1/lib/ruby/2.5.0/x86_64-darwin18/digest/md5.bundle Reason: image not found - /Users/username/.rbenv/versions/2.5.1/lib/ruby/2.5.0/x86_64-darwin18/digest/md5.bundle

ターミナルでこちらのエラーが発生していてどのコマンドも使えなくなってしまったのですが解決方法を教えてください。
思い当たる節としては__Homebrew__のアップデートをしたことだとは思います汗

※この質問でコードが必要なのかわからず冗長になると良くないと思いエラー文しか載せていないので必要な箇所があれば載せますのでよろしくお願いします。

気になる質問をクリップする

クリップした質問は、後からいつでもMYページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

guest

回答1

0

ベストアンサー

状況から推測するに

  • 以前rbenv/ruby-buildを用いてインストールした2.5.1がある
  • Homebrewでパッケージをアップグレードしたことにより、OpenSSLのバージョンが上がった
  • rubyが参照していたバージョンのOpenSSLがなくなったことにより、エラー発生

対処としては、rbenvでrubyを再インストールすること、かと思われます。

投稿2019/11/25 22:59

kazto

総合スコア7196

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

r_hara

2019/11/27 11:49

返事が大変遅くなり申し訳ありません。 再インストールすることにより解決できました。 ありがとうございました!
guest

あなたの回答

tips

太字

斜体

打ち消し線

見出し

引用テキストの挿入

コードの挿入

リンクの挿入

リストの挿入

番号リストの挿入

表の挿入

水平線の挿入

プレビュー

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
85.44%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問