質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.35%

cloud9のターミナルでPHPのアップデートをしようとした時のエラーの対処法

解決済

回答 2

投稿

  • 評価
  • クリップ 0
  • VIEW 890

score 29

ドットインストールのLaravel5.5の講座に倣って、AWSのcloud9上でLaravelのプロジェクトを創作しながら、PHPとLaravelの学習を進めようとしています。

cloud9上でPHPのヴァージョンを確認したところ、PHP5.6が実装されていたようですが、講座ではPHPの7以上のヴァージョンが必要ということで、講座で入力されていたコードを打ち込んでみました。

しかし、以下のようなエラーが出てしまいました。
![イメージ説明](a2fd152fc5a4d0cd962c953798f5c70b.png)

「php用のレポジトリが存在しない」という旨のエラーであり、こちらをインストールしてからPHP7のインストールコマンドを再入力する必要があると思うのですが、この場合、どのようにすれば正常にインストールされるでしょうか。

対処法の知識不足で申し訳ございません。どうか、ご回答宜しくお願い致します。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

checkベストアンサー

0

remiのリポジトリでなく、普通にAmazonのリポジトリからphp7をインストールできます。
yum searchで検索してみてください。
先にすでに入っているphpと関連パッケージを全てアンインストールしたほうがいいかもしれません。

ただ、yumでphpのバージョン管理をするのは正直あまりオススメできません。(phpに限った話でなく、リポジトリ側がなかなか最新版を追従してくれないことが多いため)
phpenvなどを使ってバージョンコントロールするといいでしょう。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/10/22 20:48

    ご回答ありがとうございます。

    正直申し上げますと、ドが付く程の素人で、remiリポジトリもyumコマンドも見当もつかないまま進めておりましたが、「cloud9 php バージョンアップ」と検索して見つけたこちらのサイト(https://qiita.com/kidatti/items/2d6a4a24f89dc71eb66e)を参照して、何とかアップデートできました。
    ご指摘のバージョンコントロールについては、今後、学習を深めていくようにします。

    キャンセル

0

「cloud9 php バージョンアップ(候補自動補正)」と検索してヒットした、こちらのサイト(https://qiita.com/kidatti/items/2d6a4a24f89dc71eb66e)に記述されていた一連の方法が、とても役に立ちました。
お陰様で、無事にphpをアップデートすることができました。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.35%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る