質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.12%

PHPでのHTTPリクエスト、curl関数初挑戦も init()部分から進まない

受付中

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 115

saya24

score 45

Eclipse上のPHPコード

HTTPリクエストのPOSTに挑戦しようと、上記のとおり参考にさせて頂いたサイトからコードを貼り付けてデバッグ実行したところ(Eclipse)
ず~っと このステップから先に進む気配がありません。

メッセージボディに指定の引数を送るつもりでしたが、まさかそれ以前の部分で躓くとは...

一体なぜ停まってしまっているのでしょうか?? お分かりになられる方 ご見解を頂けましたら幸いです、よろしくお願いします。

Windows10(x64)
Apach2.4
PHP7.22

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

0

それ以前の問題だとすると、

\[PHP\] EclipseでXdebug起動時78%で止まってしまう | マリンロード

に拠れば、XDebugモジュールがバージョン合ってない可能性も。


この設定はやってあるよね。

xdebug.remote_enable = On
xdebug.remote_host = localhost
xdebug.remote_port = 9000

丁寧な説明記事を見つけました、ご参照あれ:
\[PHP\] Xdebug のリモートデバッグ、理解していますか? - Qiita

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/10/10 21:31

    結局分からない状態が続いております....どなたかご見解頂けたら幸いです!

    キャンセル

  • 2019/10/11 10:05 編集

    リモートデバッグ用にポート番号を別途割り当てる必要があり、php.iniの設定とEclipseのを合わせる必要がありますよ、って話かと。その記事の中では9000番を使っていることを確認しているような。

    キャンセル

  • 2019/10/12 14:23

    一通り自分の開発環境(php.ini)の設定はあっていた感じです。但しxdebug.remote_enableに関してだけ  = On と 当方が = 1 となっている違いがありました。

    お詫び:
    <https://teratail.com/questions/216797>の関係で、本件の問い合わせ発端となっている開発端末がイニシャライズすることになりました。ようは PHP・Eclipse・Xdebug・Apacheを入れなおし。
    問い合わせておきながら、その環境がなくなる羽目に。環境を作り直してから、返答を改めさせてください。(暫く時間を要します)

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.12%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る