質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.34%

CocoaPodsでAlamofireのインストールができない(再投稿)

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 1,556

score 18

同じ質問をしてすみません。
Bundle IdentifierのところをいじってもAlamofureは認識されませんでした。
イメージ説明
Bundle Identifierの設定まちがってますかね?間違ってる場所などわかればご教授ください。よろしくおねがいします。イメージ説明イメージ説明イメージ説明イメージ説明

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • runo101

    2019/09/16 15:55

    すみません、「CocoaPodsの対応を入れていたプロジェクトとは別に用意したほうが良い」というのがいまいちよくわからないです、、

    キャンセル

  • thyda.eiqau

    2019/09/16 23:11

    1つのプロジェクトでCocoaPodsで導入したAlamofireとgit cloneして導入したAlamofireとが混在している状態になると不都合なことになるかもしれないので、現在CocoaPodsで導入しているプロジェクトがすでにある場合は、Xcodeで新規にプロジェクトを作ってそちらでgit cloneでの導入を試したほうがよいという意味です

    キャンセル

  • runo101

    2019/09/16 23:16

    詳しくありがとうございます!

    キャンセル

回答 1

checkベストアンサー

+2

詳しい状況はわかりませんが下記手順で使えると思います。

  1. ターミナルでプロジェクトフォルダに移動
  2. pod init で Podfile 生成
  3. Podfile に pod 'Alamofire' を追加
  4. ターミナルで pod install
  5. Xcode で xcworkspace ファイルを開いて Alamofire を使いたいクラスで import Alamofire

上記手順でも無理なら一度新規プロジェクトを作成して試してみることをおすすめします。
参考
https://qiita.com/ShinokiRyosei/items/3090290cb72434852460

助けになれば幸いです。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/09/16 01:06

    画像のせました!

    キャンセル

  • 2019/09/16 05:36

    Podfileに記載されている内容は問題なさそうですね...
    念の為確認ですが TinyOCR.xcworkspace をXcodeで開いてビルド(cmd+B)をしてもエラーは出たままなのですよね?
    もしまだエラーが出たままなのであれば一度 Xcode で新規のプロジェクトを作成し上記回答の手順でAlamofire を導入してビルドが通るか確認していただけないでしょうか?
    Podfile が小文字になっていることや git clone をしていることから CocoaPods でのライブラリの導入手順が間違っている可能性があります。

    キャンセル

  • 2019/09/16 09:59

    cmd+Bおしても、エラーでした。プロジェクトとは別に用意してだめだったら、新規で作り直します

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.34%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る