Ruby on Rails がインストールできない

解決済

回答 4

投稿

  • 評価
  • クリップ 0
  • VIEW 152

Kgundo

score 1

前提・実現したいこと

プログラミングの勉強をしたく、MacにRuby on Railsをインストールしようとしました。
Rubyについては、最初に入っていたものからバージョンアップし、 ruby -v の結果は、
ruby 2.6.4p104 (2019-08-28 revision 67798) [x86_64-darwin18]
になります。
そして、次に sudo gem install rails とするのですが、2.6.4であるにもかかわらず、
なぜか2.4.4以上でないといけないということで、失敗してしまい、困り果てています。

発生している問題・エラーメッセージ

ERROR:  Error installing rails:
    zeitwerk requires Ruby version >= 2.4.4.

該当のソースコード

sudo gem install rails

試したこと

いろいろググってみましたが、これといったものは今のところ見つからずです。。。

補足情報(FW/ツールのバージョンなど)

1回目失敗したときには、
HEADS UP! のようなエラーで、i18nがどうした(詳細失念しました。)のようなエラーでしたが、
いつの間にか、それは消えて、上のようなエラーになっています。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 4

+2

ruby と gem がちがうversionのものになっている可能性があります。
rubyのversionを上げたとのことですが rbenvとかですか? 素のインストールですか?

which ruby
which gem

として、pathを比べてみて下さい

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/09/11 09:00

    ご回答ありがとうございます。
    rubyはbrewでインストールしました。
    上記コマンドでは、

    usr/bin/ruby
    usr/bin/gem

    と出ています。

    キャンセル

  • 2019/09/11 12:19

    sudo してましたね、
    sudo su
    してから
    which ruby
    which gem
    はどうなりますか

    キャンセル

  • 2019/09/11 23:24

    ご回答ありがとうございます。
    結果同じでした。gemのversionというのも気にしないといけないのですね。
    もう少しもがいてみます。

    キャンセル

checkベストアンサー

+1

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/09/11 08:19

    ご回答ありがとうございます。
    後ほどトライしてみます。

    キャンセル

  • 2019/09/12 00:46

    いただいたリンクを参考に、ruby(同じく2.6.4)を`brew install`でなく`rbenv install`で再インストールしても変わらず、しかし、そこから`rbenv global 2.6.4`としてから、再度トライすると、無事うまくいきました。ありがとうございました。

    キャンセル

+1

システムのRubyのバージョンが古い可能性があります。sudo ruby -vで出るバージョンはいくつでしょうか。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/09/11 08:18

    ご回答ありがとうございます。
    結果は同様に `ruby 2.6.4p104` でした。
    しかし sudo の有無で違うこともあるのですね。勉強になりました。

    キャンセル

0

ruby(同じく2.6.4)をbrew installでなくrbenv installで再インストールしても変わらず、しかし、そこからrbenv global 2.6.4としてから、再度トライすると、無事うまくいきました。
PATHがうまくなかったとかそのような話になるのでしょうか。
理屈はよく分かりませんが、また機会があれば検証してみようと思います。
この度は一旦解決ということで、皆さまありがとうございました。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.22%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる