質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.35%

ローカルでRails サーバーが立たない。

解決済

回答 3

投稿 編集

  • 評価
  • クリップ 1
  • VIEW 1,148

前提・実現したいこと

ローカルで Rails サーバーが立ちません。

発生している問題・エラーメッセージ

コマンドプロンプトで
cd sample_app
上記のディレクトリに移動後
rails s
でサーバーを立ち上げようと試みましたが、
C:Ruby25-x64/lib/ruby/gems/2.5.0/gems/activesupport-6.0.0/lib/active_support/dependencies.rb:325:in`require': cannot load such file -- sqlite3/sqlite3_native(LoadError)  上記メッセージが表示されました。

補足情報

Rails 6.0.0 Ruby 2.5.1 Bundler 2.0.2

rubyをダウングレードすべきなのでしょうか? sqlite3関連の事なのでしょうか。

質問の仕方が稚拙でわかりにくいかと思いますが、よろしくお願いします。

追記 progateの記事を参照にしているのですが、スライドのバージョンがrails5.0.3でしたので、アンインストールをしてから 該当のバージョンを再インストールしてみます。 rails5.0.3にダウングレード後、再度rails sでサーバーの立ち上げを試みましたが Could not find railties-6.0.0 in any of the sources Run bundle install  to install missing gems.
というメッセージが表示されてしまいました。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 3

check解決した方法

0

rubyのバージョンを2.4系に再インストールしましたら、サーバーが立ちました。
sqlite3が2.5系に対応していなかったみたいです。

お騒がせしてすみません。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

0

以下の質問と同じ原因ではないでしょうか。

Ruby on Railsをcdから、rails s をした時にsqlite3_nativeがないため、エラー返します。また、sqlite3_nativeを入れても解決できません。
https://teratail.com/questions/44920

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/08/31 16:04

    こちらの回答にある
    $ gem uninstall -a sqlite3
    $ gem install sqlite3 --platform=ruby
    を試みた後
    サーバーの立ち上げを再度行いましたが

    Could not find railties-6.0.0 in any of the sources
    Run `bundle install` to install missing gems.

    上記のメッセージが表示されます。

    キャンセル

0

https://railsguides.jp/6_0_release_notes.html に
SQLiteの最小バージョンが3.8に上がった 
とあります。Gemfileでのvesion指定どうなってます?

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/09/01 13:49

    Gemfile内では

    gem 'sqlite3', '~> 1.3.6'
    となっております。

    キャンセル

  • 2019/09/01 14:34

    sqliteは詳しくないのですが、gem 'sqlite3', '~> 3.8' で成功します?

    キャンセル

  • 2019/09/04 01:22

    gemFileの中を書き換えまして

    コマンドプロンプトで rails s を実行しましたが

    Could not find gem 'sqlite3 (~> 3.8) x64-mingw32' in any of the gem sources list
    ed in your Gemfile.
    Run `bundle install` to install missing gems.

    このようなメッセージが出てきました。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.35%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る