質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.49%

Rails 6.0.0 にて rails serverがうまく実行できない。

受付中

回答 1

投稿 編集

  • 評価
  • クリップ 2
  • VIEW 2,368

環境(FW/ツールのバージョンなど)

ドットインストールを見て、virtualBox,Vagrantを使い仮想マシンを立ち上げ、puttyにて操作しています。
ruby 2.6.3p62 (2019-04-16 revision 67580) [x86_64-linux]
windows10 64bit

前提・実現したいこと

Rails 6.0.0 を使えるようにしたい。
rails server
をうまく実行させたい。

発生している問題・エラーメッセージ

rails server
と実行すると

=> Booting Puma
=> Rails 6.0.0 application starting in development
=> Run `rails server --help` for more startup options
RAILS_ENV=development environment is not defined in config/webpacker.yml, falling back to production environment
Exiting
Traceback (most recent call last):
        80: from bin/rails:3:in `<main>'
        79: from bin/rails:3:in `load'
        78: from /home/vagrant/ruby_lesson/myapp/bin/spring:15:in `<top (required)>'
.
.
.
         1: from /home/vagrant/.rbenv/versions/2.6.3/lib/ruby/gems/2.6.0/gems/webpacker-4.0.7/lib/webpacker/configuration.rb:87:in `load'
/home/vagrant/.rbenv/versions/2.6.3/lib/ruby/gems/2.6.0/gems/webpacker-4.0.7/lib/webpacker/configuration.rb:91:in `rescue in load': Webpacker configuration file not found /home/vagrant/ruby_lesson/myapp/config/webpacker.yml. Please run rails webpacker:install Error: No such file or directory @ rb_sysopen - /home/vagrant/ruby_lesson/myapp/config/webpacker.yml (RuntimeError)

と表示され、Please run rails webpacker:installとあるので、
rails webpacker:install
を実行すると

Webpacker requires Node.js >= 6.14.4 and you are using 0.10.48
Please upgrade Node.js https://nodejs.org/en/download/

となります。
そこで、node.jsをhttps://nodejs.org/en/download/ にてインストールし、コマンドプロンプトで
node -v
と実行すれば
v10.16.3
と表示されます。
しかし、putty上では
node -v
と実行すると
v0.10.48
と、別のバージョンが表示されてしまいます。

そこで、putty上で

sudo yum remove nodejs npm #古いのが入っていれば削除
curl --silent --location https://rpm.nodesource.com/setup_10.x | sudo bash -
sudo yum install -y nodejs


まで実行しましたが、やはり
node -v
と実行すると
v0.10.48
と出てしまい、結局node.jsのバージョンを変更することができません。

そこで、質問なのですが、仮想マシンでうまくnode.jsのバージョンを更新する方法を教えていただきたいです。
もしくは、rails 6.0.0 の情報はまだ少ないのですが、うまく実行できている方で何か思い当たる点がある方は教えていただきたいです。

■追記

Vagrant 2.2.5 config.vm.box = "bento/centos-6.8" (vagrant init bento/centos-6.8 にてvagrantfileを作成) ボックスは vagrant box list で表示すると bento/centos-6.8 (virtualbox, 2.3.4) と出ます。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • raccy

    2019/08/26 07:10

    そもそもvagrantで実行しているOSはなんですか?パッケージの入れ方やデフォルトバージョンなどがディストリビューションやバージョンによって異なるので一概に方法を示すことは難しいです。お使いのディストリビューションとバージョンまたはvagrantで使っているbox名を質問に追記して下さい。

    キャンセル

  • calonyction_a

    2019/08/26 20:23

    無知で申し訳ありません。
    Vagrant 2.2.5
    config.vm.box = "bento/centos-6.8" (vagrant init bento/centos-6.8 にてvagrantfileを作成)
    ボックスは vagrant box list で表示すると
    bento/centos-6.8 (virtualbox, 2.3.4)
    と出ます。

    キャンセル

  • winterboum

    2019/09/01 17:31

    1)コマンドプロンプト での操作と puttyでの操作が書かれています。
    puttyでの操作というのは 仮想サーバにLoginして、とわかりますが、
    コマンドプロンプトでの操作はどちらのOSですか?

    2)コマンドプロンプトでは 「node.jsをhttps://nodejs.org/en/download/ にてインストール」していますが、puttyでの操作では https://nodejs.org/en/download/ が出てきていません。
    同じ操作をしてみたらどうなりますか?

    キャンセル

回答 1

0

そこで、node.jsをhttps://nodejs.org/en/download/ にてインストールし、コマンドプロンプトで
node -v
と実行すれば
v10.16.3
と表示されます。

ホストのマシンにインストールしてませんか?
Vagrant上のマシンにインストールする必要があるので、

$ curl -sL https://rpm.nodesource.com/setup_10.x | bash -
$ sudo yum install nodejs

等でインストールしてみてください
参考 nodesource/distributions

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.49%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る