質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.35%

package.jsonのバージョン管理のキャレットについて

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 706

KuruK

score 56

"jquery": "^3.3.1"

例えばですが、このようにキャレットを用いてバージョンを記述するということについて、皆さんの意見をおうかがいしたいです。
このような書き方はひょっとして危険なのでしょうか。

というのも、例えば yarn upgrade した時に、jqeuryのバージョンが3.3.1から3.4.1に引き上げられたことによって、アプリケーションでバグが起きたとします。
gitではnode_modulesはignoreしてます。
となると、何が原因でバグが起きたのか分からない...。
っていうことになりませんか。
でもそれは、 yarn lock を見れば良いのかな...。

少し面倒ですが、キャレットは用いずにバージョンは記述して、バージョンを上げてみたいときは、

yarn add jquery@3.4.1

とかで明示的に上げていく方が、状況の管理はしやすいのかなとか思いました。
よろしければ、皆さんの意見をお聞かせください。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

+1

Node.jsの場合、下手にバージョンを固定すると、別な問題を招きます。

node_modulesには同じライブラリの違うバージョンを複数入れられるという特性があるため、たとえば"jquery": "3.3.1"と固定した状態でjQueryに依存する別なライブラリを入れると、そちらの方でjQuery 3.4が追加で入ってしまう、というような事態となることがあります。

特定の演算を行う関数のライブラリであれば、複数あっても容量を食うだけで大した問題にはならないのですが、「ブラウザDOMと絡む」ライブラリや、「ルーティングなどのように、インスタンスが1つでないと困る」ライブラリが複数インストールされてしまうと、正常に動作しないということも考えられます。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/08/20 17:04 編集

    なるほどです!
    理解しました。

    あともう一つ質問なのですが、これって例えば何ですが、

    ^3.3.1



    ^2.0.0

    これらが要求されてるときは、流石に二つのjqueryが入っちゃいますよね

    例えばルートのpackage.jsonでは"^3.3.1"、いずれかのモジュールの中では"^2.0.0"が要求されてる時などです

    キャンセル

  • 2019/08/20 17:09

    そこまでバージョン依存性が違うときは、「2つのjQueryを意識して使い分ける(きちんと動くかは要確認)」もしくは「片方のライブラリを諦める」必要が出てきます。

    キャンセル

  • 2019/08/20 17:16

    なるほどです、とても納得しました。
    あと、これは変な質問かもしれませんが、

    ライブラリのメジャーバージョンが上がった時、そのライブラリを使ったライブラリを公開してる作者たちは一斉に、上がったメジャーバージョンで新たにビルドしたものをプッシュしてくださるものなのでしょうか。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.35%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る