質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.34%

rails 5.2.3 Bootsnap::LoadPathCache::FallbackScanというエラーでrailsが動きません。

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 3,670

score 18

Bootsnap::LoadPathCache::FallbackScan
というエラーが出て全てのrailsの画面が表示できなくなりました。
エラー画面には上記赤文字以外には何も表示されてません。

エラーまでの経緯
画像アップロード機能を実装するためにGemfileに以下を記述
gem 'rmagick'
ターミナルでbundle installを実行
以下のエラーメッセージがターミナルに

Fetching rmagick 4.0.0
Installing rmagick 4.0.0 with native extensions
Gem::Ext::BuildError: ERROR: Failed to build gem native extension.
current directory:
/Users/mizunomasaya/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/rmagick-4.0.0/ext/RMagick
/Users/mizunomasaya/.rbenv/versions/2.5.1/bin/ruby -r
./siteconf20190817-38378-1n49c0p.rb extconf.rb
checking for brew... yes
checking for clang... yes
checking for pkg-config... yes

ERROR: Can't install RMagick 4.0.0. Can't find ImageMagick with
pkg-config

* extconf.rb failed *
Could not create Makefile due to some reason, probably lack of necessary
libraries and/or headers.  Check the mkmf.log file for more details.  You may
need configuration options.

Provided configuration options:
--with-opt-dir
--without-opt-dir
--with-opt-include
--without-opt-include=${opt-dir}/include
--with-opt-lib
--without-opt-lib=${opt-dir}/lib
--with-make-prog
--without-make-prog
--srcdir=.
--curdir
--ruby=/Users/mizunomasaya/.rbenv/versions/2.5.1/bin/$(RUBY_BASE_NAME)

To see why this extension failed to compile, please check the mkmf.log which can
be found here:

/Users/mizunomasaya/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/extensions/x86_64-darwin-16/2.5.0-static/rmagick-4.0.0/mkmf.log

extconf failed, exit code 1

Gem files will remain installed in
/Users/mizunomasaya/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/rmagick-4.0.0
for inspection.
Results logged to
/Users/mizunomasaya/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/extensions/x86_64-darwin-16/2.5.0-static/rmagick-4.0.0/gem_make.out

An error occurred while installing rmagick (4.0.0), and Bundler cannot
continue.
Make sure that gem install rmagick -v '4.0.0' --source 'https://rubygems.org/'
succeeds before bundling.

In Gemfile:
rmagick

bundle installに失敗
そのままrails sで以下のエラーメッセージ
Could not find gem 'rmagick' in any of the gem sources listed in your Gemfile.

Gemfileからgem 'rmagick'の記述消し、再度rails sで
サーバーは起動したものの、冒頭のエラーメッセージでどのviewも見れず。
ターミナルにもBootsnap::LoadPathCache::FallbackScan - :の文字が出てます。

この記事の内容を試してもダメでした。

https://qiita.com/Daniel_Nakano/items/aadeaa7ae4e227b73878

解消法をご教示ください。

Gemfile

source 'https://rubygems.org'
git_source(:github) { |repo| "https://github.com/#{repo}.git" }

ruby '2.5.1'

# Bundle edge Rails instead: gem 'rails', github: 'rails/rails'
gem 'rails', '~> 5.2.3'
# Use postgresql as the database for Active Record
gem 'pg', '>= 0.18', '< 2.0'
# Use Puma as the app server
gem 'puma', '~> 3.11'
# Use SCSS for stylesheets
gem 'sass-rails', '~> 5.0'
# Use Uglifier as compressor for JavaScript assets
gem 'uglifier', '>= 1.3.0'
# See https://github.com/rails/execjs#readme for more supported runtimes
# gem 'mini_racer', platforms: :ruby

# Use CoffeeScript for .coffee assets and views
gem 'coffee-rails', '~> 4.2'
# Turbolinks makes navigating your web application faster. Read more: https://github.com/turbolinks/turbolinks
gem 'turbolinks', '~> 5'
# Build JSON APIs with ease. Read more: https://github.com/rails/jbuilder
gem 'jbuilder', '~> 2.5'
# Use Redis adapter to run Action Cable in production
# gem 'redis', '~> 4.0'
# Use ActiveModel has_secure_password
# gem 'bcrypt', '~> 3.1.7'
gem 'jbuilder', '~> 2.5'
gem 'devise'
gem 'rails_admin'
gem 'cancan'
gem 'pry-rails'
gem 'better_errors'
# Use ActiveStorage variant
# gem 'mini_magick', '~> 4.8'
gem 'rails_admin'

# Use Capistrano for deployment
# gem 'capistrano-rails', group: :development

# Reduces boot times through caching; required in config/boot.rb
gem 'bootsnap', '>= 1.0.0', require: false

group :development, :test do
  # Call 'byebug' anywhere in the code to stop execution and get a debugger console
  gem 'byebug', platforms: [:mri, :mingw, :x64_mingw]
end

group :development do
  # Access an interactive console on exception pages or by calling 'console' anywhere in the code.
  gem 'web-console', '>= 3.3.0'
  gem 'listen', '>= 3.0.5', '< 3.2'
  # Spring speeds up development by keeping your application running in the background. Read more: https://github.com/rails/spring
  gem 'spring'
  gem 'spring-watcher-listen', '~> 2.0.0'
end

group :test do
  # Adds support for Capybara system testing and selenium driver
  gem 'capybara', '>= 2.15'
  gem 'selenium-webdriver'
  # Easy installation and use of chromedriver to run system tests with Chrome
  gem 'chromedriver-helper'
end

# Windows does not include zoneinfo files, so bundle the tzinfo-data gem
gem 'tzinfo-data', platforms: [:mingw, :mswin, :x64_mingw, :jruby]

gem "jquery-rails"

gem 'carrierwave', '~> 1.0'

```

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

+1

こんばんは。
エラーメッセージをちゃんと見れば解決の糸口がつかめると思いますよ。
rmagickは

ERROR: Can't install RMagick 4.0.0. Can't find ImageMagick with


とエラーが出ているので、ImageMagickがインストールされてないことが原因です。
先にImageMagickをインストールしてからGemfileにrmagickを追記してbundle installで入ると思います。

それでもrails sできないなら、こちらの記事のように一回キャッシュ消してみるのがよいですね。
https://qiita.com/cyborg__ninja/items/d15b50500f4ffb069feb

(※エラーメッセージもコードブロックを使ってもらえると読みやすいです)

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/08/18 09:58

    ありがとうございます!解決しました!

    キャンセル

  • 2019/08/18 22:08

    よかったです👍

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.34%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る