質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.31%

javascriptのパッケージaxiosがimportできない

解決済

回答 2

投稿

  • 評価
  • クリップ 0
  • VIEW 977

yk_00

score 15

前提・実現したいこと

djanogrestframeworkのapi呼び出しをjavascriptのパッケージaxiosでできるらしいということがわかり実践したい。
しかし、axiosをimportできない。
どうしたらaxiosが使えるようになるでしょうか?

発生している問題・エラーメッセージ

chromeエラー
cssとjavascriptのファイル自体は読み込まれている。
chromeエラー
エラー文

Uncaught SyntaxError: Unexpected identifier

該当のソースコード

{% load static %}
<!DOCTYPE html>
<html lang="jp" dir="ltr">
  <head>
    <meta charset="utf-8">
    <title></title>
    <script type="text/javascript" src="{% static 'js/index.js' %}"></script>
    <link href="{% static 'css/index.css' %}" rel="stylesheet">
  </head>
  <body>
    <p>test</p>

  </body>
</html>
p {
  color: red;
}
import axios from "axios";

console.log("import completed");
axios
  .get("http://127.0.0.1:8000/api/v1/")
  .then(response => {
    console.log("status:", response.status);
    console.log("axiosGetData:", response.data);
  })
  .catch(err => {
    console.log("axiosGetErr", err);
  });
window.alert("test");
version: '3'

services:
  db:
    image: postgres
  web:
    build: .
    command: python manage.py runserver 0.0.0.0:8000
    volumes:
      - .:/code
    ports:
      - "8000:8000"
    depends_on:
      - db
FROM python:3
ENV PYTHONUNBUFFERED 1
RUN mkdir /code
WORKDIR /code
COPY requirements.txt /code/
RUN pip install -r requirements.txt
RUN apt-get install -y gnupg
RUN curl -sL https://deb.nodesource.com/setup_10.x | bash -
RUN apt-get install -y nodejs
RUN npm install axios --save-dev
COPY . /code/
Django>=2.0,<3.0
psycopg2>=2.7,<3.0
djangorestframework

試したこと

ここに問題に対して試したことを記載してください。
①docker-composeで環境を作る
②axiosを追加することに決める、dockerfileを書き直す。

FROM python:3
ENV PYTHONUNBUFFERED 1
RUN mkdir /code
WORKDIR /code
COPY requirements.txt /code/
RUN pip install -r requirements.txt
RUN apt-get install -y gnupg//追加
RUN curl -sL https://deb.nodesource.com/setup_10.x | bash -//追加
RUN apt-get install -y nodejs//追加
RUN npm install axios --save-dev//追加
COPY . /code/


③ビルドした
正常にビルド完了

➜  djangorestframework git:(master) ✗ sudo docker-compose build
db uses an image, skipping
Building web
Step 1/11 : FROM python:3
 ---> 34a518642c76
Step 2/11 : ENV PYTHONUNBUFFERED 1
 ---> Using cache
 ---> ff4afb48bfa0
Step 3/11 : RUN mkdir /code
 ---> Using cache
 ---> ceec010feebe
Step 4/11 : WORKDIR /code
 ---> Using cache
 ---> e707d1b2e60a
Step 5/11 : COPY requirements.txt /code/
 ---> Using cache
 ---> 1cc11eda6568
Step 6/11 : RUN pip install -r requirements.txt
 ---> Using cache
 ---> bffc88f8924e
Step 7/11 : RUN apt-get install -y gnupg
 ---> Using cache
 ---> 6d54121ce170
Step 8/11 : RUN curl -sL https://deb.nodesource.com/setup_10.x | bash -
 ---> Using cache
 ---> ee3599f7553c
Step 9/11 : RUN apt-get install -y nodejs
 ---> Using cache
 ---> 40a7d3eee167
Step 10/11 : RUN npm install axios --save-dev
 ---> Using cache
 ---> c6dd0853d8b0
Step 11/11 : COPY . /code/
 ---> 1698e7492ca6
Successfully built 1698e7492ca6
Successfully tagged djangorestframework_web:latest

バージョンも表示される

djangorestframework git:(master)sudo docker-compose run web npm info axios version 
Starting djangorestframework_db_1 ... done
0.19.0


④jsファイルでimport、失敗

補足情報(FW/ツールのバージョンなど)

開発環境
Ubuntu18.04.2
docker-compose1.22.0
django2.2.2
djangorestframework3.9.4
aixios0.19.0
言語
python,javascript,html,css

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

check解決した方法

0

axiosをimportするのはnodeの環境でなければならなかったようです。
reactのプロジェクトを立ち上げ、その中でaxiosをimportできます。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

0

パッと見でアレ?と思っただけですけど
RUN npm install axios --save-dev
RUN npm install axios --saveじゃないですか?

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/07/10 15:43

    やってみましたが変わりませんでした。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.31%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る