質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
85.45%
Node.js

Node.jsとはGoogleのV8 JavaScriptエンジンを使用しているサーバーサイドのイベント駆動型プログラムです。

Q&A

解決済

1回答

1393閲覧

Unsupported platform for fsevents@2.0.7、(2)nodist(x64)をインストールしたい、を解決したい

wkbiz

総合スコア153

Node.js

Node.jsとはGoogleのV8 JavaScriptエンジンを使用しているサーバーサイドのイベント駆動型プログラムです。

0グッド

0クリップ

投稿2019/06/20 15:41

よろしくお願いします。

環境: windows10 , nodist 0.9.1

windows10上にnodistを入れ、あるモジュールをビルドしようとしています。
yarn installを行い、lernaを入れようと「npm i -D lerna」を実行したところ以下のエラーになりました
→ ERROR01

この後、npmやmodule、package.json、nucのアップデート、
killall node
npm cache clear を行い、その中で
「npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.9
が多く見受けるようになりました。これが出ないように解決したい。
というのが1つ目です。

2つ目に、nodistをインストーラーで入れるとProgramFiles(x86)に入っています。
x64版というのはないのでしょうか?
fseventsに関するエラーを見ると、
npm ERR! notsup Unsupported platform for fsevents@2.0.7: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"})
のエラーも何度もみかけます。osは32(x86)でモジュールは64って、なんか違和感があるんです。
これで正しい、合ってるというのならそれでもいいのですが、じゃあ何故ちがっててもいいのか?を具体的に捉えたいです。

どんな些細なことでも結構です。情報のご提供、ご教授いただけると幸いです。
よろしくお願いします。

ERROR01

1H:0620\master>npm i -D lerna 2npm WARN deprecated mixin-deep@1.3.1: Critical bug fixed in v2.0.1, please upgrade to the latest version. 3npm WARN deprecated set-value@2.0.0: Critical bug fixed in v3.0.1, please upgrade to the latest version. 4npm WARN deprecated set-value@0.4.3: Critical bug fixed in v3.0.1, please upgrade to the latest version. 5npm WARN deprecated left-pad@1.3.0: use String.prototype.padStart() 6npm WARN deprecated domelementtype@1.3.0: update to domelementtype@1.3.1 7npm WARN rm not removing H:0620\master\node_modules.bin\rimraf.cmd as it wasn't installed by H:0620\master\node_modules\rimraf 8npm WARN rm not removing H:0620\master\node_modules.bin\rimraf as it wasn't installed by H:0620\master\node_modules\rimraf 9npm WARN rm not removing H:0620\master\node_modules.bin\JSONStream.cmd as it wasn't installed by H:0620\master\node_modules\JSONStream 10npm WARN rm not removing H:0620\master\node_modules.bin\JSONStream as it wasn't installed by H:0620\master\node_modules\JSONStream 11npm WARN rm not removing H:0620\master\node_modules.bin\semver.cmd as it wasn't installed by H:0620\master\node_modules\semver 12npm WARN rm not removing H:0620\master\node_modules.bin\semver as it wasn't installed by H:0620\master\node_modules\semver 13npm WARN rm not removing H:0620\master\node_modules.bin\js-yaml.cmd as it wasn't installed by H:0620\master\node_modules\js-yaml 14npm WARN rm not removing H:0620\master\node_modules.bin\js-yaml as it wasn't installed by H:0620\master\node_modules\js-yaml 15npm WARN rm not removing H:0620\master\node_modules.bin\jest.cmd as it wasn't installed by H:0620\master\node_modules\jest-cli 16npm WARN rm not removing H:0620\master\node_modules.bin\jest as it wasn't installed by H:0620\master\node_modules\jest-cli 17npm WARN rm not removing H:0620\master\node_modules.bin\is-ci.cmd as it wasn't installed by H:0620\master\node_modules\is-ci 18npm WARN rm not removing H:0620\master\node_modules.bin\is-ci as it wasn't installed by H:0620\master\node_modules\is-ci 19npm WARN rm not removing H:0620\master\node_modules.bin\esparse.cmd as it wasn't installed by H:0620\master\node_modules\esprima 20npm WARN rm not removing H:0620\master\node_modules.bin\esvalidate.cmd as it wasn't installed by H:0620\master\node_modules\esprima 21npm WARN rm not removing H:0620\master\node_modules.bin\esparse as it wasn't installed by H:0620\master\node_modules\esprima 22npm WARN rm not removing H:0620\master\node_modules.bin\esvalidate as it wasn't installed by H:0620\master\node_modules\esprima 23npm WARN rm not removing H:0620\master\node_modules.bin\parser.cmd as it wasn't installed by H:0620\master\node_modules\@babel\parser 24npm WARN rm not removing H:0620\master\node_modules.bin\parser as it wasn't installed by H:0620\master\node_modules\@babel\parser 25npm notice created a lockfile as package-lock.json. You should commit this file. 26npm WARN acorn-jsx@5.0.1 requires a peer of acorn@^6.0.0 but none is installed. You must install peer dependencies yourself. 27npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.9 (node_modules\fsevents): 28npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.9: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"}) 29 30+ lerna@3.15.0 31added 112 packages from 78 contributors, removed 135 packages, updated 968 packages and audited 912958 packages in 152.492s 32found 3 high severity vulnerabilities 33 run `npm audit fix` to fix them, or `npm audit` for details

気になる質問をクリップする

クリップした質問は、後からいつでもMYページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

guest

回答1

0

ベストアンサー

「npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.9

これをエラーと思ってるなら勘違いです。
WARNって書いてあるとおり警告です。
警告はエラーではありません。(ここ見てると何故が警告をエラーと思う人が多い…)

ここに書いてますが、fseventsはMacOSのネイティブAPIを使うためのライブラリ(つまり今使おうとしているライブラリをMacOS上で使う時に必要になるもの)なので、Windows環境なら無視して良いはずです。

2つ目に、nodistをインストーラーで入れるとProgramFiles(x86)に入っています。

OSが64bitであっても、32bitプロセスは普通に動きます。逆は無理ですが。
公式が64bit版のビルドを提供していないのであれば、より広い環境で動く32bit版のみの提供で十分だと判断しただけの話なので、何もおかしなところはありません。

投稿2019/06/21 03:30

gentaro

総合スコア8949

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

wkbiz

2019/06/21 03:58

ご回答ありがとうございます
guest

あなたの回答

tips

太字

斜体

打ち消し線

見出し

引用テキストの挿入

コードの挿入

リンクの挿入

リストの挿入

番号リストの挿入

表の挿入

水平線の挿入

プレビュー

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
85.45%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問