質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
85.44%
CentOS

CentOSは、主にRed Hat Enterprise Linux(RHEL)をベースにした、フリーのソフトウェアオペレーティングシステムです。

Linux

Linuxは、Unixをベースにして開発されたオペレーティングシステムです。日本では「リナックス」と呼ばれています。 主にWebサーバやDNSサーバ、イントラネットなどのサーバ用OSとして利用されています。 上位500のスーパーコンピュータの90%以上はLinuxを使用しています。 携帯端末用のプラットフォームAndroidは、Linuxカーネル上に構築されています。

Q&A

解決済

1回答

7853閲覧

自作サーバー(CentOS6)でphpizeが実行できない

rmrmnrm

総合スコア139

CentOS

CentOSは、主にRed Hat Enterprise Linux(RHEL)をベースにした、フリーのソフトウェアオペレーティングシステムです。

Linux

Linuxは、Unixをベースにして開発されたオペレーティングシステムです。日本では「リナックス」と呼ばれています。 主にWebサーバやDNSサーバ、イントラネットなどのサーバ用OSとして利用されています。 上位500のスーパーコンピュータの90%以上はLinuxを使用しています。 携帯端末用のプラットフォームAndroidは、Linuxカーネル上に構築されています。

0グッド

1クリップ

投稿2019/06/19 02:51

編集2019/06/19 04:41

前提・実現したいこと

Mecabをサーバーにインストールし、PHP上で形態素解析したい

Mecab公式
http://taku910.github.io/mecab/

発生している問題・エラーメッセージ

以下のURLを参考に作業してます。
https://qiita.com/yusukeito58/items/36aeb7f6376e7b9b9d7e
最後の【php-macabをインストール】でひっかかりました

SSH

1# phpize 2Can't find PHP headers in /usr/include/php 3The php-devel package is required for use of this command. 4

ちなみに/usr/include/内にphpのディレクトリがありませんでした。

####php関連パッケージ一覧
質問いただきましたので追記します。

SSH

1# sudo yum list installed | grep php 2php.x86_64 5.4.45-8.el6.remi @remi 3php-bcmath.x86_64 5.4.45-8.el6.remi @remi 4php-channel-phpseclib.noarch 5php-cli.x86_64 5.4.45-8.el6.remi @remi 6php-common.x86_64 5.4.45-8.el6.remi @remi 7php-gd.x86_64 5.4.45-8.el6.remi @remi 8php-imap.x86_64 5.4.45-8.el6.remi @remi 9php-mbstring.x86_64 5.4.45-8.el6.remi @remi 10php-mcrypt.x86_64 5.4.45-8.el6.remi @remi 11php-mysql.x86_64 5.4.45-8.el6.remi @remi 12php-pdo.x86_64 5.4.45-8.el6.remi @remi 13php-pear.noarch 1:1.9.5-10.el6.remi 14php-php-gettext.noarch 15php-phpseclib-crypt-aes.noarch 16php-phpseclib-crypt-base.noarch 17php-phpseclib-crypt-random.noarch 18php-phpseclib-crypt-rijndael.noarch 19php-process.x86_64 5.4.45-8.el6.remi @remi 20php-recode.x86_64 5.4.45-8.el6.remi @remi 21php-tcpdf.noarch 6.2.8-1.el6.remi @remi 22php-tcpdf-dejavu-sans-fonts.noarch 23php-tidy.x86_64 5.4.45-8.el6.remi @remi 24php-xml.x86_64 5.4.45-8.el6.remi @remi 25phpMyAdmin.noarch 4.0.10.10-1.el6 @epel

試したこと

####①エラー発生(その2)の内容と同じだったので以下を実行しました。

SSH

1# sudo yum install php-devel 2読み込んだプラグイン:fastestmirror, priorities, security, versionlock 3インストール処理の設定をしています 4Loading mirror speeds from cached hostfile 5 * base: mirror.fairway.ne.jp 6 * extras: mirror.fairway.ne.jp 7 * updates: mirror.fairway.ne.jp 8base | 3.7 kB 00:00 9extras | 3.4 kB 00:00 10updates | 3.4 kB 00:00 11updates/primary_db | 4.7 MB 00:11 12依存性の解決をしています 13--> トランザクションの確認を実行しています。 14---> Package php-devel.x86_64 0:5.3.3-49.el6 will be インストール 15--> 依存性の処理をしています: php(x86-64) = 5.3.3-49.el6 のパッケージ: php-devel-5.3.3-49.el6.x86_64 16--> 依存性解決を終了しました。 17エラー: パッケージ: php-devel-5.3.3-49.el6.x86_64 (base) 18 要求: php(x86-64) = 5.3.3-49.el6 19 インストール: php-5.4.45-8.el6.remi.x86_64 (@remi) 20 php(x86-64) = 5.4.45-8.el6.remi 21 利用可能: php-5.3.3-49.el6.x86_64 (base) 22 php(x86-64) = 5.3.3-49.el6 23 問題を回避するために --skip-broken を用いることができません 24 これらを試行できます: rpm -Va --nofiles --nodigest

以下のURLを参考に
https://codeday.me/jp/qa/20190226/282199.html

yum install php-develを実行するのではなく、yum –enablerepo = remi、remi-php54 install php-develを実行する必要がありました。

とあったので試してみましたがよくわかりませんでした。

SSH

1# yum –enablerepo = remi 2読み込んだプラグイン:fastestmirror, priorities, security, versionlock 3# remi-php54 install php-devel 4-bash: remi-php54: コマンドが見つかりません

どのようにしたら良いのでしょうか。よろしくお願いします。

####②コマンドが間違っていたので改めて実行

コマンドが機械翻訳で崩れていたようなので、指摘を参考に再度実行
原文:https://stackoverflow.com/questions/12325109/cant-install-php-devel-on-centos

SSH

1# sudo yum --enablerepo=remi,remi-php54 install php-devel 2読み込んだプラグイン:fastestmirror, priorities, security, versionlock 3インストール処理の設定をしています 4Loading mirror speeds from cached hostfile 5 * base: mirror.fairway.ne.jp 6 * extras: mirror.fairway.ne.jp 7 * remi: ftp.riken.jp 8 * updates: mirror.fairway.ne.jp 9remi | 3.0 kB 00:00 10remi/primary_db | 2.3 MB 00:00 1192 packages excluded due to repository priority protections 12依存性の解決をしています 13--> トランザクションの確認を実行しています。 14---> Package php-devel.x86_64 0:5.3.3-49.el6 will be インストール 15--> 依存性の処理をしています: php(x86-64) = 5.3.3-49.el6 のパッケージ: php-devel -5.3.3-49.el6.x86_64 16--> 依存性解決を終了しました。 17エラー: パッケージ: php-devel-5.3.3-49.el6.x86_64 (base) 18 要求: php(x86-64) = 5.3.3-49.el6 19 インストール: php-5.4.45-8.el6.remi.x86_64 (@remi) 20 php(x86-64) = 5.4.45-8.el6.remi 21 利用可能: php-5.3.3-49.el6.x86_64 (base) 22 php(x86-64) = 5.3.3-49.el6 23 問題を回避するために --skip-broken を用いることができません 24 これらを試行できます: rpm -Va --nofiles --nodigest

####③php54→php53

SSH

1# yum --enablerepo=remi,remi-php53 install php-devel 2読み込んだプラグイン:fastestmirror, priorities, security, versionlock 3インストール処理の設定をしています 4Loading mirror speeds from cached hostfile 5 * base: mirror.fairway.ne.jp 6 * extras: mirror.fairway.ne.jp 7 * remi: ftp.riken.jp 8 * updates: mirror.fairway.ne.jp 992 packages excluded due to repository priority protections 10依存性の解決をしています 11--> トランザクションの確認を実行しています。 12---> Package php-devel.x86_64 0:5.3.3-49.el6 will be インストール 13--> 依存性の処理をしています: php(x86-64) = 5.3.3-49.el6 のパッケージ: php-devel-5.3.3-49.el6.x86_64 14--> 依存性解決を終了しました。 15エラー: パッケージ: php-devel-5.3.3-49.el6.x86_64 (base) 16 要求: php(x86-64) = 5.3.3-49.el6 17 インストール: php-5.4.45-8.el6.remi.x86_64 (@remi) 18 php(x86-64) = 5.4.45-8.el6.remi 19 利用可能: php-5.3.3-49.el6.x86_64 (base) 20 php(x86-64) = 5.3.3-49.el6 21 問題を回避するために --skip-broken を用いることができません 22 これらを試行できます: rpm -Va --nofiles --nodigest

気になる質問をクリップする

クリップした質問は、後からいつでもMYページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

yukky1201

2019/06/19 04:35

「sudo yum list installed | grep php」を実行して、インストール済みのphp関連パッケージを追記してください
rmrmnrm

2019/06/19 04:40

質問ありがとうございます。追記しましたのでご確認ください。
yukky1201

2019/06/19 05:06

remiリポジトリからインストールされているので、他の回答者さんのコマンドでできそうなんですけどねぇ。
guest

回答1

0

ベストアンサー

--> 依存性の処理をしています: php(x86-64) = 5.3.3-49.el6 のパッケージ: php-devel-5.3.3-49.el6.x86_64

--> 依存性解決を終了しました。
エラー: パッケージ: php-devel-5.3.3-49.el6.x86_64 (base)
要求: php(x86-64) = 5.3.3-49.el6
インストール: php-5.4.45-8.el6.remi.x86_64 (@remi)
php(x86-64) = 5.4.45-8.el6.remi
利用可能: php-5.3.3-49.el6.x86_64 (base)
php(x86-64) = 5.3.3-49.el6
問題を回避するために --skip-broken を用いることができません
これらを試行できます: rpm -Va --nofiles --nodigest

@remi ということは、php は remi からインストールしているんですね。

https://codeday.me/jp/qa/20190226/282199.html
yum install php-develを実行するのではなく、yum –enablerepo = remi、remi-php54 install php-develを実行する必要がありました。

惜しい... 機械翻訳のせいでコマンドが変わってる...  ( 原文 : can't install php-devel on centos ) なら正解と思われるコマンドが書かれているんだけどなぁ...

原文にかかれている

sudo yum --enablerepo=remi,remi-php54 install php-devel

で、 php-devel をインストール出来ないでしょうか。

投稿2019/06/19 03:36

CHERRY

総合スコア25201

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

rmrmnrm

2019/06/19 03:51

回答、原文の提供ありがとうございます。 実行しましたがエラーでしたので、本文に内容を追記しました。ご確認ください。
hentaiman

2019/06/19 03:57

php54ではなくphp53ならどうでしょうか?
rmrmnrm

2019/06/19 04:38

ありがとうございます。53で試した結果を追記しました。
CHERRY

2019/06/19 04:55 編集

> # sudo yum list installed | grep php > php.x86_64 5.4.45-8.el6.remi @remi なので、 yum --enablerepo=remi install php-devel だけで、インストールできそうなんだけどなぁ... yum --disablerepo=base --enablerepo=remi install php-devel の様に disablerepo=base を明示して禁止するとどうなりますか?
hentaiman

2019/06/19 05:34

この手のエラー出してる人って知らず知らずのうちにenablerepoやって何かインストールしてて他の何かを入れようとする時にバージョン合わなくてしくってるだけな気がするんだけど、history見て心当たりのあるコマンドでも出てこないかしら?
rmrmnrm

2019/06/19 06:01 編集

yum --disablerepo=base --enablerepo=remi install php-devel でインストールでき、最後までいけました!ありがとうございます。 hentaimanさんのコメントの通り、コピペコマンドばかりしているのでどこかでなにかしでかしているのかもしれません…コメントありがとうございます。
CHERRY

2019/06/19 07:10 編集

解決したようでなりよりです。 ---- 今後も php は、 remi からインストールするのであれば、 /etc/yum.repos.d/CentOS-Base.repo の各リポジトリに `exclude=php*` を追加しておくのが良いかもしれないですね。 /etc/yum.repos.d/CentOS-Base.repo では、 [base] [updates] [extras] あたりが、 enable になっていて、デフォルトで使われていると思うので、それぞれのセクションに exclude を追加すると その exclude が設定されたリポジトリからは、exclude で指定したパッケージは、インストールされなくなります。 例: [base] の場合、 ``` [base] name=CentOS-$releasever - Base mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=os&infra=$infra #baseurl=http://mirror.centos.org/centos/$releasever/os/$basearch/ gpgcheck=1 gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-6 priority=1 ``` のような感じです( もしかすると baseurl と mirrorlist のコメントが逆かもしれませんが... )が exclude を追加すると ``` [base] name=CentOS-$releasever - Base mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=os&infra=$infra #baseurl=http://mirror.centos.org/centos/$releasever/os/$basearch/ gpgcheck=1 gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-6 priority=1 exclude=php* ``` の様な感じになります。 リポジトリに exclude 設定を追加することで、 この例では、 base リポジトリからは、 `php* `の名前に一致するパッケージはインストールされなくなります。 もし、不明点があれば、このコメントに返信を...
guest

あなたの回答

tips

太字

斜体

打ち消し線

見出し

引用テキストの挿入

コードの挿入

リンクの挿入

リストの挿入

番号リストの挿入

表の挿入

水平線の挿入

プレビュー

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
85.44%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問