質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.61%

cakephpを立ち上げようとするとError: SQLSTATE[HY000] [14]

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 3,189

score 86

前提・実現したいこと

ここに質問の内容を詳しく書いてください。
PHP初学者です。
cakephpを使ってアプリを作成しようとしています。
下記の記事を参考に仮想環境に開発環境を構築しようとしています。
(参考記事:https://qiita.com/kenta0629/items/574251c140387779b681)

参考記事の手順8)まで行いローカルサーバーへアクセスすると以下のようなエラーが表示されました。

発生している問題・エラーメッセージ

Error: SQLSTATE[HY000] [14] unable to open database file
If you are using SQL keywords as table column names, you can enable identifier quoting for your database connection in config/app.php.
Warning(2):file_put_contents(/vagrant/test2/logs/error.log) [<a href='https://secure.php.net/function.file-put-contents'>function.file-put-contents</a>]: failed to open stream: Permission denied [CORE/src/Log/Engine/FileLog.php, line 133]

該当のソースコード

ログに表示されたファイルの133行目あたりを確認すると下記のようなコードの記述がありました。

$pathname = $this->_path . $filename;
        $mask = $this->_config['mask'];
        if (!$mask) {
            return file_put_contents($pathname, $output, FILE_APPEND);
        }

試したこと

解決法を探していると下記のリンクに似たような質問事項を見つけました。
(類似質問事項:https://teratail.com/questions/155786

上記URL内のやりとりによると、上記コード(return file_put_contents($pathname, $output, FILE_APPEND);)によるファイルの書き込み?がパーミッションエラーなのかなと判断しています。

また、回答に貼られているリンクを読むとパーミッションの変更にはchmod関数で行うとあり、今回のエラー解消にも
これが使えるのではと考えているのですが、chmod関数を配置する場所がわからず止まっています。

質問内容

・現在自分が解決方法と考えている上記chmod関数の正しい使い方をご教示いただきたいです。
・他に解決方法となるかもしれないという方法があれば記載いただきたいです。

補足情報(FW/ツールのバージョンなど)

mysql  Ver 14.14 Distrib 5.6.44
Apache/2.4.6 (CentOS)
PHP 5.6.40

よろしくお願いいたします。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

+1

まずこのエラーは「二つ」のエラーが並んでいます。

一つ目

Error: SQLSTATE[HY000] [14] unable to open database file
If you are using SQL keywords as table column names, you can enable identifier quoting for your database connection in config/app.php.


二つ目

Warning(2):file_put_contents(/vagrant/test2/logs/error.log) [<a href='https://secure.php.net/function.file-put-contents'>function.file-put-contents</a>]: failed to open stream: Permission denied [CORE/src/Log/Engine/FileLog.php, line 133]

ですので、二つのエラーをそれぞれ別個に対処しなくてはなりません。
一つ目はデータベースファイルがオープンできない、といっているのですが、補足として
「もし SQL キーワードをそのままテーブルのカラム名に使ってたりするなら、クオートで囲むように config/app.php の中にある設定を変更してください」と言っています。
※これは config/app.php 内の Datasources で、quoteIdentifiers に true を設定しろ、ということです。参考

二つ目は、一つ目で出たエラーをエラーログファイルに書こうとしたが書けなかった、という警告です。
※つまり一つ目のエラーが出ていなければそもそも出ない
これは環境の話なので、chmod 関数をソースに書くのではなく、環境をあらかじめ変更しておく必要があります。
具体的には /vagrant/test2/logs/error.log に書き込めるように、/vagrant/test2/logs のディレクトリに対して、実行ユーザーによる書き込みを許可する指定をする必要があります。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/06/03 15:43

    早速ご回答いただきありがとうございます。
    別々のエラーが2つ表示されていたのですね、、、ご丁寧に分けて解説いただき大変助かります。

    ご指摘いただいた通りまず、app.phpファイル内のquoteIdentifiersをtrueに変更しました。

    -app.php内
    'Datasources' => [
    'default' => [
        ・・・
    /**
    * Set identifier quoting to true if you are using reserved words or
    * special characters in your table or column names. Enabling this
    * setting will result in queries built using the Query Builder having
    * identifiers quoted when creating SQL. It should be noted that this
    * decreases performance because each query needs to be traversed and
    * manipulated before being executed.
    */
    'quoteIdentifiers' => true, ←もともとfalseでした。
        ・・・

    さらに/vagrant/test2/logsへの書き込みを許可するためにターミナル上で
    ~$ chmod 777 /vagrant/test2/logs
    を実行しました。

    その状態で再度アクセスし直しましたが、エラー情報が全く変わらずのまま表示されてしまいました。

    DBに関するエラーが解消されていない理由としては何が考えられるでしょうか?

    また、ディレクトリへの書き込み許可を与えるコマンドも実行する前後で「ls -l」を使って確認したのですが
    変化がありませんでした。こちらも設定方法として間違っているのでしょうか?

    恐れ入りますが再度ご確認いただけると大変助かります。
    よろしくお願いいたします。

    キャンセル

  • 2019/06/03 18:47

    クオートを付けても変わらないとすれば、そもそも Datasource が間違っている可能性もあります。
    接続するデータベースは正しく設定されていますか?

    ディレクトリについては、vagrant を使っている状態なので、vagrant のユーザーで書き込み可能かどうか、が問題になります。通常 test2/logs は 0755 (所有ユーザーのみ書き込み可能、他は読み取りのみ可能)としているでしょうが、これで駄目なようであれば 0777(どのユーザでも書き込み可能)にして動かしてみるのも一つの手です。

    キャンセル

  • 2019/06/06 10:22

    日を改めてオフラインで相談できる方に画面を見てもらった結果、質問内容に記載できていなかったエラーメッセージからSQLite周りのエラーと判断いただきました。
    (MySQLに接続させようとしていたのにappのドライバーがSQLiteになってたようです、、、)
    エラーの読み込みが甘く、トンチンカンな質問になってしまいすみませんでした。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.61%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る