質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.78%

Postgresql9.6を使っているのですがpg_ctlコマンドが見つかりません

解決済

回答 2

投稿

  • 評価
  • クリップ 1
  • VIEW 1,701

kalon

score 127

皆様いつもお世話になっております。

利用環境は以下の通りです
CentOS Linux release 7.6.1810 (Core) 
psql (PostgreSQL) 9.6.13

PostgreSQLはこちらの方法でインストールしました。

googleでも検索して分からなかったのですが、pg_ctlコマンドが見つかりませんと表示されてしまいます。
どうしたらpg_ctlコマンドを使えるように出来るでしょうか?

アドバイスとご教授のほどよろしくお願いします。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • m6u

    2019/05/29 11:12 編集

    /usr/pgsql-9.6/bin/ にいませんか? いないんですね?

    キャンセル

回答 2

checkベストアンサー

+1

https://download.postgresql.org/pub/repos/yum/9.6/ のパッケージを使ったのであれば、/usr/pgsql-9.6/bin/pg_ctl に存在しないでしょうか?

/usr/pgsql-9.6/bin/pg_ctl がありましたら、 /usr/pgsql-9.6/bin を PATH に追加してください。


(おまけ)
 yum provides コマンド  で、パッケージ内のコマンドを検索できるので、うちのテスト環境で、パッケージ内の pg_ctl を検索した結果をみて、上記を推測。

# yum provides */pg_ctl
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: ftp.iij.ad.jp
 * epel: mirrors.aliyun.com
 * epel-debuginfo: mirrors.aliyun.com
 * epel-source: mirrors.aliyun.com
 * extras: ftp.iij.ad.jp
 * ius: hkg.mirror.rackspace.com
 * remi-php72: ftp.riken.jp
 * remi-safe: ftp.riken.jp
 * updates: ftp.iij.ad.jp

postgresql-server-9.2.24-1.el7_5.x86_64 : The programs needed to create and run a PostgreSQL server
Repo        : base
Matched from:
Filename    : /usr/bin/pg_ctl


postgresql-upgrade-9.2.24-1.el7_5.x86_64 : Support for upgrading from the previous major release of
                                         : PostgreSQL
Repo        : base
Matched from:
Filename    : /usr/lib64/pgsql/postgresql-8.4/bin/pg_ctl


postgresql92-postgresql-server-9.2.18-1.el7.x86_64 : The programs needed to create and run a PostgreSQL
                                                   : server
Repo        : centos-sclo-rh
Matched from:
Filename    : /opt/rh/postgresql92/root/usr/bin/pg_ctl


postgresql92-postgresql-upgrade-9.2.18-1.el7.x86_64 : Support for upgrading from the previous major release
                                                    : of PostgreSQL
Repo        : centos-sclo-rh
Matched from:
Filename    : /opt/rh/postgresql92/root/usr/lib64/pgsql/postgresql-8.4/bin/pg_ctl


postgresql96-server-9.6.11-1PGDG.rhel7.x86_64 : The programs needed to create and run a PostgreSQL server
Repo        : pgdg96
Matched from:
Filename    : /usr/pgsql-9.6/bin/pg_ctl


postgresql96-server-9.6.12-1PGDG.rhel7.x86_64 : The programs needed to create and run a PostgreSQL server
Repo        : pgdg96
Matched from:
Filename    : /usr/pgsql-9.6/bin/pg_ctl


postgresql96-server-9.6.13-1PGDG.rhel7.x86_64 : The programs needed to create and run a PostgreSQL server
Repo        : pgdg96
Matched from:
Filename    : /usr/pgsql-9.6/bin/pg_ctl


rh-postgresql10-postgresql-server-10.3-2.el7.x86_64 : The programs needed to create and run a PostgreSQL
                                                    : server
Repo        : centos-sclo-rh
Matched from:
Filename    : /opt/rh/rh-postgresql10/root/usr/bin/pg_ctl
Matched from:
Filename    : /opt/rh/rh-postgresql96/root/usr/bin/pg_ctl


rh-postgresql96-postgresql-server-9.6.10-1.el7.x86_64 : The programs needed to create and run a PostgreSQL
                                                      : server
Repo        : centos-sclo-rh
Matched from:
Filename    : /opt/rh/rh-postgresql96/root/usr/bin/pg_ctl


rh-postgresql96-postgresql-server-syspaths-9.6.5-2.el7.x86_64 : Convenient wrappers for the
     ...: rh-postgresql96-postgresql-server package; replaces the postgresql-server package
Repo        : centos-sclo-rh
Matched from:
Filename    : /usr/bin/pg_ctl


rh-postgresql96-postgresql-server-syspaths-9.6.10-1.el7.x86_64 : Convenient wrappers for the
     ...: rh-postgresql96-postgresql-server package; replaces the postgresql-server package
Repo        : centos-sclo-rh
Matched from:
Filename    : /usr/bin/pg_ctl


postgresql96-server-9.6.11-1PGDG.rhel7.x86_64 : The programs needed to create and run a PostgreSQL server
Repo        : @pgdg96
Matched from:
Filename    : /usr/pgsql-9.6/bin/pg_ctl

     

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

+1

そういえばうちのサーバーだと
/opt/rh/rh-postgresql96/root/usr/bin/pg_ctl
にいたりしますね。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/05/29 11:26

    centos-sclo-rh リポジトリからのインストールですかね?

    キャンセル

  • 2019/05/29 11:34

    記録に残してないけど、たぶんそうかも。
    質問者さんの状況と合ってないかもしれない。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.78%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る