質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.51%

rails5.1.7でモデルを作成しようとするとloaderrorがでます

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 33

前提・実現したいこと

ここに質問の内容を詳しく書いてください。
(例)PHP(CakePHP)で●●なシステムを作っています。
■■な機能を実装中に以下のエラーメッセージが発生しました。

発生している問題・エラーメッセージ

/home/ec2-user/.rvm/gems/ruby-2.6.0/gems/ffi-1.10.0/lib/ffi.rb:6:in `require': libffi.so.6: cannot open shared object file: No such file or directory - /home/ec2-user/.rvm/gems/ruby-2.6.0/gems/ffi-1.10.0/lib/ffi_c.so (LoadError)

### 該当のソースコード

rails 5.1.7 ruby 2.6.0 ソースコード `` rails generate model Micropost content:text user:references /home/ec2-user/.rvm/gems/ruby-2.6.0/gems/ffi-1.10.0/lib/ffi.rb:6:in require': libffi.so.6: cannot open shared object file: No such file or directory - /home/ec2-user/.rvm/gems/ruby-2.6.0/gems/ffi-1.10.0/lib/ffi_c.so (LoadError)

from /home/ec2-user/.rvm/gems/ruby-2.6.0/gems/ffi-1.10.0/lib/ffi.rb:6:in `rescue in <top (required)>'

from /home/ec2-user/.rvm/gems/ruby-2.6.0/gems/ffi-1.10.0/lib/ffi.rb:3:in `<top (required)>'

from /home/ec2-user/.rvm/gems/ruby-2.6.0/gems/rb-inotify-0.10.0/lib/rb-inotify/native.rb:1:in `require'

from /home/ec2-user/.rvm/gems/ruby-2.6.0/gems/rb-inotify-0.10.0/lib/rb-inotify/native.rb:1:in `<top (required)>'

from /home/ec2-user/.rvm/gems/ruby-2.6.0/gems/rb-inotify-0.10.0/lib/rb-inotify.rb:2:in `require'

from /home/ec2-user/.rvm/gems/ruby-2.6.0/gems/rb-inotify-0.10.0/lib/rb-inotify.rb:2:in `<top (required)>'

from /home/ec2-user/.rvm/gems/ruby-2.6.0/gems/listen-3.1.5/lib/listen/adapter/linux.rb:30:in `require'

from /home/ec2-user/.rvm/gems/ruby-2.6.0/gems/listen-3.1.5/lib/listen/adapter/linux.rb:30:in `_configure'

from /home/ec2-user/.rvm/gems/ruby-2.6.0/gems/listen-3.1.5/lib/listen/adapter/base.rb:45:in `block in configure'

from /home/ec2-user/.rvm/gems/ruby-2.6.0/gems/listen-3.1.5/lib/listen/adapter/base.rb:40:in `each'

from /home/ec2-user/.rvm/gems/ruby-2.6.0/gems/listen-3.1.5/lib/listen/adapter/base.rb:40:in `configure'

from /home/ec2-user/.rvm/gems/ruby-2.6.0/gems/listen-3.1.5/lib/listen/adapter/base.rb:63:in `start'

from /home/linuxbrew/.linuxbrew/Cellar/ruby/2.6.3/lib/ruby/2.6.0/forwardable.rb:230:in `start'

from /home/ec2-user/.rvm/gems/ruby-2.6.0/gems/listen-3.1.5/lib/listen/listener.rb:68:in `block in <class:Listener>'

from /home/ec2-user/.rvm/gems/ruby-2.6.0/gems/listen-3.1.5/lib/listen/fsm.rb:121:in `instance_eval'

from /home/ec2-user/.rvm/gems/ruby-2.6.0/gems/listen-3.1.5/lib/listen/fsm.rb:121:in `call'

from /home/ec2-user/.rvm/gems/ruby-2.6.0/gems/listen-3.1.5/lib/listen/fsm.rb:91:in `transition_with_callbacks!'

from /home/ec2-user/.rvm/gems/ruby-2.6.0/gems/listen-3.1.5/lib/listen/fsm.rb:57:in `transition'

from /home/ec2-user/.rvm/gems/ruby-2.6.0/gems/listen-3.1.5/lib/listen/listener.rb:91:in `start'

from /home/ec2-user/.rvm/gems/ruby-2.6.0/gems/spring-watcher-listen-2.0.1/lib/spring/watcher/listen.rb:27:in `start'

from /home/ec2-user/.rvm/gems/ruby-2.6.0/gems/spring-2.0.2/lib/spring/application.rb:80:in `start_watcher'

from /home/ec2-user/.rvm/gems/ruby-2.6.0/gems/spring-2.0.2/lib/spring/application.rb:89:in `preload'

from /home/ec2-user/.rvm/gems/ruby-2.6.0/gems/spring-2.0.2/lib/spring/application.rb:153:in `serve'

from /home/ec2-user/.rvm/gems/ruby-2.6.0/gems/spring-2.0.2/lib/spring/application.rb:141:in `block in run'

from /home/ec2-user/.rvm/gems/ruby-2.6.0/gems/spring-2.0.2/lib/spring/application.rb:135:in `loop'

from /home/ec2-user/.rvm/gems/ruby-2.6.0/gems/spring-2.0.2/lib/spring/application.rb:135:in `run'

from /home/ec2-user/.rvm/gems/ruby-2.6.0/gems/spring-2.0.2/lib/spring/application/boot.rb:19:in `<top (required)>'

from /home/linuxbrew/.linuxbrew/Cellar/ruby/2.6.3/lib/ruby/2.6.0/rubygems/core_ext/kernel_require.rb:54:in `require'

from /home/linuxbrew/.linuxbrew/Cellar/ruby/2.6.3/lib/ruby/2.6.0/rubygems/core_ext/kernel_require.rb:54:in `require'

from -e:1:in `<main>'

試したこと

rubyのバージョンを2.6.3にしたり2.6.0にしたりした

補足情報(FW/ツールのバージョンなど)

dbでmysqlをデフォルトのdbにしてアプリ作成→rubyの最新バージョンではエラーが出る、なんかターミナルのコマンド全部おかしくなる(エラーメッセージ:You must use Bundler 2 or greater with this lockfile)→rubyのバージョンを変える為rbenv と ruby buildの二つが必要になる→それをインストールするためにhomebrewをcloud9内にインストール→さっきの二つをインストール→モデル作成→作成できず上記のエラーが発生

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

check解決した方法

0

rvnのバージョンを更新したら普通にできました。使用したコマンドは
$ rvm get stable
rvnってなんだろう...?ルビーのバージョン管理?
→Ruby Version Managerらしいですね。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

同じタグがついた質問を見る