質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.50%

  • Ruby

    9446questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails

    8869questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

  • Ruby on Rails 5

    3194questions

ruby on rails : bundle update エラー

受付中

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 60

dxo

score 5

bundle updateをすると以下のエラーが発生してしまいます。

Ignoring byebug-9.0.6 because its extensions are not built.  Try: gem pristine byebug --version 9.0.6
Ignoring ffi-1.9.18 because its extensions are not built.  Try: gem pristine ffi --version 1.9.18
Ignoring nio4r-2.1.0 because its extensions are not built.  Try: gem pristine nio4r --version 2.1.0
Ignoring nokogiri-1.8.0 because its extensions are not built.  Try: gem pristine nokogiri --version 1.8.0
Ignoring puma-3.9.1 because its extensions are not built.  Try: gem pristine puma --version 3.9.1
The dependency tzinfo-data (>= 0) will be unused by any of the platforms Bundler is installing for. Bundler is installing for ruby but the dependency is only for x86-mingw32, x86-mswin32, x64-mingw32, java. To add those platforms to the bundle, run `bundle lock --add-platform x86-mingw32 x86-mswin32 x64-mingw32 java`.
Fetching gem metadata from https://rubygems.org/..............
Fetching gem metadata from https://rubygems.org/..
Resolving dependencies..........
Using rake 12.3.2
Using concurrent-ruby 1.1.5 (was 1.0.5)
Using minitest 5.11.3
Using thread_safe 0.3.6
Using builder 3.2.3
Using erubi 1.8.0 (was 1.7.1)
Using mini_portile2 2.4.0 (was 2.3.0)
Using crass 1.0.4 (was 1.0.3)
Using rack 2.0.7 (was 2.0.5)
Using nio4r 2.3.1 (was 2.3.0)
Using websocket-extensions 0.1.3
Using mini_mime 1.0.1 (was 1.0.0)
Using arel 8.0.0
Using public_suffix 3.0.3 (was 3.0.2)
Using execjs 2.7.0
Using aws-eventstream 1.0.3
Using jmespath 1.4.0
Using bcrypt 3.1.12 (was 3.1.11)
Using bindex 0.7.0 (was 0.5.0)
Using rb-fsevent 0.10.3
Using ffi 1.10.0 (was 1.9.23)
Using bundler 1.16.1
Fetching byebug 11.0.1 (was 10.0.2)
Using climate_control 0.2.0
Using coffee-script-source 1.12.2
Using method_source 0.9.2 (was 0.9.0)
Using thor 0.20.3 (was 0.20.0)
Using connection_pool 2.2.2
Using orm_adapter 0.5.0
Using unf_ext 0.0.7.6 (was 0.0.7.5)
Using multipart-post 2.1.1 (was 2.0.0)
Using google-analytics-rails 1.1.1
Using hash-deep-merge 0.1.1
Using hashie 3.6.0 (was 3.5.7)
Using jwt 2.1.0 (was 1.5.6)
Using ruby_dep 1.5.0
Using mime-types-data 3.2019.0331 (was 3.2016.0521)
Using mimemagic 0.3.3 (was 0.3.2)
Using multi_json 1.13.1
Using multi_xml 0.6.0
Using netrc 0.11.0
Using puma 3.12.1 (was 3.11.3)
Using rinku 2.0.6 (was 2.0.4)
Using rubyzip 1.2.2 (was 1.2.1)
Using tilt 2.0.9 (was 2.0.8)
Using sqlite3 1.4.1 (was 1.3.13)
Using turbolinks-source 5.2.0 (was 5.1.0)
Using childprocess 1.0.1 (was 0.9.0)
Fetching i18n 1.6.0 (was 1.0.0)
Using tzinfo 1.2.5
Fetching nokogiri 1.10.3 (was 1.8.2)
Installing i18n 1.6.0 (was 1.0.0)
Installing byebug 11.0.1 (was 10.0.2) with native extensions
Using rack-test 1.1.0 (was 1.0.0)
Using websocket-driver 0.6.5
Using mail 2.7.1 (was 2.7.0)
Using addressable 2.6.0 (was 2.5.2)
Using aws-sigv4 1.1.0 (was 1.0.2)
Using warden 1.2.8 (was 1.2.7)
Using sprockets 3.7.2
Using uglifier 4.1.20 (was 4.1.8)
Using rb-inotify 0.10.0 (was 0.9.10)
Using autoprefixer-rails 9.5.1.1 (was 8.2.0)
Fetching sassc 2.0.1
Using cocaine 0.5.8
Using coffee-script 2.4.1
Using figaro 1.1.1
Using net-http-persistent 3.0.1
Using unf 0.1.4
Using faraday 0.15.4 (was 0.12.2)
Using lazy_high_charts 1.5.8
Using omniauth 1.9.0 (was 1.8.1)
Using mime-types 3.2.2 (was 3.1)
Fetching selenium-webdriver 3.142.2 (was 3.11.0)
Installing sassc 2.0.1 with native extensions
Installing selenium-webdriver 3.142.2 (was 3.11.0)
Using turbolinks 5.2.0 (was 5.1.0)
Installing nokogiri 1.10.3 (was 1.8.2) with native extensions
Gem::InstallError: i18n requires Ruby version >= 2.3.0.
An error occurred while installing i18n (1.6.0), and Bundler cannot continue.
Make sure that `gem install i18n -v '1.6.0'` succeeds before bundling.

In Gemfile:
  dropzonejs-rails was resolved to 0.8.4, which depends on
    rails was resolved to 5.1.7, which depends on
      actioncable was resolved to 5.1.7, which depends on
        actionpack was resolved to 5.1.7, which depends on
          actionview was resolved to 5.1.7, which depends on
            rails-dom-testing was resolved to 2.0.3, which depends on
              activesupport was resolved to 5.1.7, which depends on
                i18n

環境

・Rails 5.1.6
・ruby 2.2.5
・Mac OS

どうすれば解決するのか分からない状況です。ご教授の方よろしくお願い致します。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

0

i18n 1.6.0は、Ruby 2.3.0以上を必要とするとエラーメッセージに書いてありますね。Rubyのバージョンを上げるか、i18n(あるいはi18nに依存しているライブラリ)のバージョンを上げすぎないように明示するか、いずれかで対応する形になるんじゃないかと思います。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

同じタグがついた質問を見る

  • Ruby

    9446questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails

    8869questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

  • Ruby on Rails 5

    3194questions