質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
85.44%

Q&A

解決済

3回答

33241閲覧

Visual Studio Code でHTMLの終了タグ自動生成が邪魔

tatataro

総合スコア23

3グッド

3クリップ

投稿2019/05/13 07:21

最近、sublime textからvscodeへ乗り換えたのですが、HTMLで開始タグを入力すると自動で書かれる終了タグにストレスを感じることが多々ありました。

例えば、元々文章が書かれているところにタグをつけようとした場合、
<h1></h1>何かしらの文章のようになってしまいます。
sublime textでは開始タグがあると </ まで書くと自動で終了タグを書いてくれます。

もちろん自動で終了タグが生成されて便利なことも多いので、できれば入力の際に切り替えできればいいのですが、自分の検索力ではたどり着けませんでした。

自分はwin10, vscode:1.33.1を使用しています。

もし良い方法やオススメの設定等があればご教授ください。
よろしくお願いします。

ypp, RikuS3n, Pine👍を押しています

気になる質問をクリップする

クリップした質問は、後からいつでもMYページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

guest

回答3

0

ベストアンサー

別の方もお書きになっていますが、VS Codeに標準で組み込まれているHTML拡張機能が邪魔をしています。また、Auto Close Tagもそれを考慮して、HTMLが対象外になる初期設定になっています。

まずは、設定画面で「HTML: Auto Closing Tags」を検索し、デフォルトでチェックされているのを外してください。

あとは、Auto Close Tagを導入して、設定画面で「Auto-close-tag: Sublime Text3 Mode」をチェックし、「Auto-close-tag: Activation On Language」の「settings.jsonで編集」をクリックして、設定の中に「"html",」を追加すれば、「自分で</まで入力したときだけ、残りをVS Codeが補完する」という動作になります。

投稿2020/05/15 03:14

編集2020/05/15 06:57
Daregada

総合スコア11990

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

tatataro

2020/05/26 08:50

ありがとうございます! 無事希望通りの動作を確認できました!
guest

0

セッティング→拡張機能→HTML→auto closing tag の印を外せば出来ました。
僕も同じ状況で、勉強中の身では邪魔です。仕事をするには非常に助かりますねw

投稿2020/01/15 01:08

nagashi

総合スコア8

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

0

VSCの設定で「テキストエディター」の項目に
Auto Closing Brackets」という項目があるのでこれが原因かもしれません。

自分はタグを自動で閉じてくれる拡張機能を使っています↓

投稿2019/05/13 07:37

sola-msr

総合スコア876

バッドをするには、ログインかつ

こちらの条件を満たす必要があります。

tatataro

2019/05/13 12:07

sublime text mode があるということで,こちらのパッケージをインストールしてみたのですが, setting.jsonでautoClosingBracketsをnever,SublimeText3Modeをtrueにしても自動で終了タグが生成されてしまいました. 再起動もしてみたのですが効果がない状況です. 何か他に設定などされましたか?
sola-msr

2019/05/13 16:54

んー自分は特にVSC標準の設定を変更していない状態でプラグインをたくさん入れているので、あまり参考にならないかなと。 一旦すべてのプラグインをアンインストールして、素の状態から設定を調整していくのが早いかもしれません。 (VSCの標準の設定を上書きしているプラグインが悪さをしている可能性もあるかもしれないので)
tatataro

2019/05/14 02:06

色々とありがとうございます。 自分はまだjapanese language packとvscode-iconsしか入れてなかったのですが、とりあえずアンインストールしてauto close tag しかない状態でsetting.jsonにsublimetextmodeをtrueのみで試しましたが、やはり変化はないみたいです・・・ もう少し調べてみたいと思います。 他に何か気づいたことがありましたら、よろしくお願いします。
guest

あなたの回答

tips

太字

斜体

打ち消し線

見出し

引用テキストの挿入

コードの挿入

リンクの挿入

リストの挿入

番号リストの挿入

表の挿入

水平線の挿入

プレビュー

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
85.44%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問