質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.53%

  • Ruby

    9214questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails

    8638questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

rails で bundler: failed to load command: rails エラーが出る

解決済

回答 2

投稿

  • 評価
  • クリップ 0
  • VIEW 106

solve0919

score 0

前提・実現したいこと

ここに質問の内容を詳しく書いてください。
ruby(ruby on rails)の環境構築で以下のエラーメッセージが発生しました。
進まなくて困っています。

発生している問題・エラーメッセージ

ターミナル
PC名:ファイル名$ bundle exec rails _5.2.0_ new .
bundler: failed to load command: rails
(/Users/ユーザー名/ファイル名/vendor/bundle/ruby/2.5.0/bin/rails)
LoadError: cannot load such file -- concurrent/map

別のエラー
PC名:ファイル名$ rails -v
Traceback (most recent call last):
        1: from /Users/ユーザー名/.rbenv/versions/2.5.0/bin/rails:23:in
 `<main>'
/Users/ユーザー名/.rbenv/versions/2.5.0/bin/rails:23:in 
`load': cannot load such file --
 /Users/ユーザー名/.rbenv/versions/2.5.0/lib/ruby/gems/2.5.0/gems/railties-5.2.3/
exe/rails (LoadError)

試したこと

gem install rails
rbenv global 2.5.0

上記コマンドを試しましたが、インストール済み等で変化はありませんでした。

補足情報(FW/ツールのバージョンなど)

ruby2.5.0

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

回答 2

check解決した方法

0

解決しました。
https://github.com/mperham/sidekiq/issues/3816

に記載の通りrubyを再インストールしたところ解決しました。

再インストール参考URL
https://qiita.com/hiromo_chi/items/39052dc4d4c3cebfb1ee

その後
bundlerをインストールしました。 

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

0

  • echo $PATH の結果
  • which gem の結果
  • which bundle の結果

を、それぞれ確認して、追記をお願いします。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/04/15 18:42 編集

    ・`echo $PATH`

    ```/Users/ユーザー名/.rbenv/shims:/Users/ユーザー名/.rbenv/shims:/Users/ユーザー名/.rbenv/shims:/Users/ユーザー名/.rbenv/shims:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin:/opt/ImageMagick/bin:/Users/ユーザー名/.rbenv/shims```

    ・which gem
    ```/Users/ユーザー名/.rbenv/shims/gem```

    ・which bundle
    ```/Users/ユーザー名/.rbenv/shims/bundle```
    でした。

    キャンセル

  • 2019/04/15 19:07

    `bundle install` は実施していますでしょうか。

    キャンセル

  • 2019/04/15 19:08

    また、Gemfileの内容を追記お願いします。

    キャンセル

  • 2019/04/15 20:16 編集

    bundle install --path vendor/bundleを実施済みです。

    現状のgemはこちらです。

    # frozen_string_literal: true
    source "https://rubygems.org&quot;
    git_source(:github) {|repo_name| "https://github.com/#{repo_name}" }
    gem "rails" ,"5.2.0"

    キャンセル

  • 2019/04/16 13:12 編集

    bundle exec rails _5.2.0_ new . の際のエラー全文です
    bundler: failed to load command: rails (/Users/ファイル名/vendor/bundle/ruby/2.5.0/bin/rails)
    LoadError: cannot load such file -- concurrent/map
    /Users/ファイル名/vendor/bundle/ruby/2.5.0/gems/activesupport-5.2.0/lib/active_support/inflector/inflections.rb:3:in `require'
    /Users/ファイル名/vendor/bundle/ruby/2.5.0/gems/activesupport-5.2.0/lib/active_support/inflector/inflections.rb:3:in `<top (required)>'
    /Users/ファイル名/vendor/bundle/ruby/2.5.0/gems/activesupport-5.2.0/lib/active_support/inflections.rb:3:in `require'
    /Users/ファイル名/vendor/bundle/ruby/2.5.0/gems/activesupport-5.2.0/lib/active_support/inflections.rb:3:in `<top (required)>'
    /Users/ファイル名/vendor/bundle/ruby/2.5.0/gems/activesupport-5.2.0/lib/active_support/inflector/methods.rb:3:in `require'
    /Users/ファイル名/vendor/bundle/ruby/2.5.0/gems/activesupport-5.2.0/lib/active_support/inflector/methods.rb:3:in `<top (required)>'
    /Users/ファイル名/vendor/bundle/ruby/2.5.0/gems/activesupport-5.2.0/lib/active_support/dependencies/autoload.rb:3:in `require'
    /Users/ファイル名/vendor/bundle/ruby/2.5.0/gems/activesupport-5.2.0/lib/active_support/dependencies/autoload.rb:3:in `<top (required)>'
    /Users/ファイル名/vendor/bundle/ruby/2.5.0/gems/activesupport-5.2.0/lib/active_support.rb:27:in `require'
    /Users/ファイル名/vendor/bundle/ruby/2.5.0/gems/activesupport-5.2.0/lib/active_support.rb:27:in `<top (required)>'
    /Users/ファイル名/vendor/bundle/ruby/2.5.0/gems/railties-5.2.0/lib/rails/command.rb:3:in `require'
    /Users/ファイル名/vendor/bundle/ruby/2.5.0/gems/railties-5.2.0/lib/rails/command.rb:3:in `<top (required)>'
    /Users/ファイル名/vendor/bundle/ruby/2.5.0/gems/railties-5.2.0/lib/rails/cli.rb:12:in `require'
    /Users/ファイル名/vendor/bundle/ruby/2.5.0/gems/railties-5.2.0/lib/rails/cli.rb:12:in `<top (required)>'
    /Users/ファイル名/vendor/bundle/ruby/2.5.0/gems/railties-5.2.0/exe/rails:10:in `require'
    /Users/ファイル名/vendor/bundle/ruby/2.5.0/gems/railties-5.2.0/exe/rails:10:in `<top (required)>'
    /Users/ファイル名/vendor/bundle/ruby/2.5.0/bin/rails:23:in `load'
    /Users/ファイル名/vendor/bundle/ruby/2.5.0/bin/rails:23:in `<top (required)>'

    キャンセル

同じタグがついた質問を見る

  • Ruby

    9214questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails

    8638questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。