質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.36%

AWSのEC2にTomcatをインストールしたい

受付中

回答 3

投稿

  • 評価
  • クリップ 0
  • VIEW 2,173

RikuShimoida

score 16

前提・実現したいこと

AWSのEC2にtomcatをインストールしたいのですが、
sudo yum install tomcat
のコマンドを打つと
oaded plugins: priorities, update-motd, upgrade-helper
amzn-main | 2.1 kB 00:00:00
amzn-updates | 2.5 kB 00:00:00
No package tomcat available.
というエラーメッセージが出ます。
原因分かる方いらっしゃいますか?

■目的
EC2環境にWebサーバーとDBを構築し、JSPで動くWebシステムを作ってみたいと思い、勉強中です。

発生している問題・エラーメッセージ

No package tomcat available.

ここに言語名を入力
Java
Linux
AWS

試したこと

EC2サーバーの/home/ec2-user
というディレクトリにapache-tomcat-9.0.17-fulldocs.tar.gzをダウンロードしてみました。
No package tomcat available.
というメッセージから推測して、インストールの実行ファイルなどをまとめたアーカイブファイル自体がサーバーにおかれていない事が原因と考えたためです。
(初心者の考えなので的外れかもしれませんが)
なお、これでも結果は全く一緒でした。

補足情報(FW/ツールのバージョンなど)

ここにより詳細な情報を記載してください。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 3

0

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

0

hichonさんの指摘されているとおり、rpm名を検索する必要があります。
tomcat系でたくさんのrpmがあり、あなたが必要なものを選択、インストールする必要があります。

例えば「yum install apache」とやっても「yum install tomcat」と同じ結果になります。
apacheの場合は「yum install httpd」とやる。
tomcatについては全く詳しくないのでどれが正しいのか分かりませんが、あなたがダウンロードしたのは「tomcat6-docs-webapp」に一番近いのでは。

up-streamから最新パッケージを導入すると他パッケージとの仕様差から動作しない可能性があります。今トラブルがなくても、セキュリティ上、常に最新を使う必要があり、最新パッケージはどんどん非互換が発生します。その場合、芋づる式にどんどんup-steamから導入すべきパッケージが増えていきます。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

-1

自分ダウンロードしたか。
Tomcatのインストール方法はダウンロードしたTomcatのtarファイルを展開して配置する。
yum 必要ではありません。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/05/03 00:59

    distributerの提供するrpmを使うべき。up-streamからパッケージを導入すべきではない。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.36%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る