質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.59%

bundlerのインストールが失敗してしまう

受付中

回答 2

投稿

  • 評価
  • クリップ 0
  • VIEW 3,219

score 142

使用したコマンドはこちらのものです

gem install bundler

このようなエラーが出てインストールが失敗してしまいます

ERROR:  While executing gem ... (Gem::FilePermissionError)
    You don't have write permissions for the /Library/Ruby/Gems/2.3.0 directory.

permissionのエラーということでsudoをつけて実行してみたのですがほぼ同じような下記のエラーが出てしまい先に進めない状況です。どうしたら良いのでしょうか

ERROR:  While executing gem ... (Gem::FilePermissionError)
    You don't have write permissions for the /usr/bin directory.
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

0

Mac標準インストールのRubyですね。
gemには--user-installというオプションがあり、ユーザ領域にインストールする方法もありますが、Rubyのバージョンも古そうだし、バージョンアップも定期的にあるので、rbenvrvm等のバージョン切り替えツールを入れることをお勧めします。(どちらか好きな方を入れればいいです)

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/04/16 23:07

    ありがとうございます!本当に困ってたのですごい助かりました!

    キャンセル

-1

類似の質問がありましたが、こちらは確認されていますでしょうか?

gemをインストールする際にpermission エラーが発生する。
https://teratail.com/questions/74708

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/04/07 19:12

    確認してみましたが解決できませんでした。
    rubyのversionを調べると下記のように表示されます
    ```
    ruby 2.3.7p456 (2018-03-28 revision 63024) [universal.x86_64-darwin18]
    ```
    貼っていただいたリンク先の記事では下記の2つのコマンドを使用し場所が異なっているのが原因のようでした。
    ```
    $ which ruby
    $ which bundle
    ```
    which rubyのコマンドを打つと下記のようにパスが表示されるのですが、bundleはinstallすることができていないため何も表示されません
    ```
    /usr/bin/ruby
    ```

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.59%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る