質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.59%

Amazon Linuxにphp-gdをインストールする

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 4,579

score 12

前提・実現したいこと

(例)Laravel5.8でIntervention Imageを用いて画像処理を行う際に

GD Library extension not available with this PHP installation.

とのエラーメッセージが出ましたので、GDライブラリをインストールしたいです。

発生している問題・エラーメッセージ

調べたところ、

yum install php-gd

を実行すれば良いということでしたので、以下を実行しました。

[hoge@ip-*-**-**-** ~]$ sudo yum install php-gd
読み込んだプラグイン:priorities, update-motd, upgrade-helper
Repository nodesource is listed more than once in the configuration
Repository nodesource-source is listed more than once in the configuration
依存性の解決をしています
--> トランザクションの確認を実行しています。
---> パッケージ php-gd.x86_64 0:5.3.29-1.8.amzn1 を インストール
--> 依存性の処理をしています: php-common(x86-64) = 5.3.29-1.8.amzn1 のパッケージ: php-gd-5.3.29-1.8.amzn1.x86_64
--> 依存性の処理をしています: libXpm.so.4()(64bit) のパッケージ: php-gd-5.3.29-1.8.amzn1.x86_64
--> 依存性の処理をしています: libt1.so.5()(64bit) のパッケージ: php-gd-5.3.29-1.8.amzn1.x86_64
--> トランザクションの確認を実行しています。
---> パッケージ libXpm.x86_64 0:3.5.10-2.9.amzn1 を インストール
---> パッケージ php-common.x86_64 0:5.3.29-1.8.amzn1 を インストール
---> パッケージ t1lib.x86_64 0:5.1.2-6.5.amzn1 を インストール
--> 衝突を処理しています: php72-common-7.2.13-1.7.amzn1.x86_64 は php-common < 5.5.22-1.98 と衝突しています
--> 依存性解決を終了しました。
エラー: php72-common conflicts with php-common-5.3.29-1.8.amzn1.x86_64
 問題を回避するために --skip-broken を用いることができます。
 これらを試行できます: rpm -Va --nofiles --nodigest

すると、php72-commonとphp-common-5.3.29-1.8.amzn1.x86_64が衝突しているということですので、これを解消したいのですが、どのようにすれば良いのでしょうか。

試したこと

yum update
をしましたがエラー状況は何も変わりませんでした。
また、他のサイトでphp-gdをインストールする際にgd-lastなどをインストールする必要があることを知りましたので、そちらも実行しましたが、別のエラーが出て進みませんでした。

[hoge@ip-*-**-**-** ~]$ sudo yum --enablerepo=remi,remi-php56 install php-last
読み込んだプラグイン:priorities, update-motd, upgrade-helper
Repository nodesource is listed more than once in the configuration
Repository nodesource-source is listed more than once in the configuration
パッケージ php-last は利用できません。
エラー: 何もしません

補足情報(FW/ツールのバージョンなど)

Amazon Linux
PHP 7.2.13
Laravel 5.8

[ec2-user@ip-172-31-45-81 ~]$ yum list | grep gd
Repository nodesource is listed more than once in the configuration
Repository nodesource-source is listed more than once in the configuration
gdbm.x86_64                          1.8.0-36.6.amzn1              installed    
gdisk.x86_64                         0.8.10-1.5.amzn1              installed    
rubygem20-bigdecimal.x86_64          1.2.0-1.31.amzn1              installed    
gcc64-gdb-plugin.i686                6.4.1-1.45.amzn1              amzn-main    
gcc64-gdb-plugin.x86_64              6.4.1-1.45.amzn1              amzn-main    
gcc72-gdb-plugin.x86_64              7.2.1-2.59.amzn1              amzn-main    
gd.i686                              2.0.35-11.10.amzn1            amzn-main    
gd.x86_64                            2.0.35-11.10.amzn1            amzn-main    
gd-devel.x86_64                      2.0.35-11.10.amzn1            amzn-main    
gd-progs.x86_64                      2.0.35-11.10.amzn1            amzn-main    
gdb.x86_64                           7.6.1-64.33.amzn1             amzn-main    
gdb-doc.noarch                       7.6.1-64.33.amzn1             amzn-main    
gdb-gdbserver.x86_64                 7.6.1-64.33.amzn1             amzn-main    
gdbm.i686                            1.8.0-36.6.amzn1              amzn-main    
gdbm-devel.x86_64                    1.8.0-36.6.amzn1              amzn-main    
graphviz-gd.x86_64                   2.38.0-18.50.amzn1            amzn-main    
hunspell-gd.noarch                   1.0.0-0.3.rc.2.2.amzn1        amzn-main    
php-gd.x86_64                        5.3.29-1.8.amzn1              amzn-main    
php54-gd.x86_64                      5.4.45-1.75.amzn1             amzn-main    
php55-gd.x86_64                      5.5.38-2.119.amzn1            amzn-main    
php56-gd.x86_64                      5.6.39-1.141.amzn1            amzn-updates 
php70-gd.x86_64                      7.0.33-1.32.amzn1             amzn-updates 
php71-gd.x86_64                      7.1.25-1.35.amzn1             amzn-updates 
php72-gd.x86_64                      7.2.13-1.7.amzn1              amzn-updates 
php73-gd.x86_64                      7.3.2-1.13.amzn1              amzn-updates 
rubygem-bigdecimal.noarch            1:2.0-0.3.amzn1               amzn-main    
rubygem19-bigdecimal.x86_64          1.1.0-32.70.amzn1             amzn-main    
rubygem21-bigdecimal.x86_64          1.2.4-1.20.amzn1              amzn-updates 
rubygem22-bigdecimal.x86_64          1.2.6-1.11.amzn1              amzn-main    
rubygem23-bigdecimal.x86_64          1.2.8-1.20.amzn1              amzn-updates 
rubygem24-bigdecimal.x86_64          1.3.2-1.30.7.amzn1            amzn-updates 
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

+2

エラーメッセージは
php72がremiのリポジトリでインストールされているのに、baseのphp5.6のgdを入れようとしているのでコンフリクトしている
という意味です。

よって、
sudo yum --enablerepo=remi,remi-php72 install php72-gd
という感じで指定してあげればインストールされるはずです。

sudo yum list installed|grep phpみたいな感じで現在インストールされているPHPとPHPエクステンションのパッケージ名とリポジトリ名を確認してみると上記コマンドの意味が分かると思います。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/03/23 11:45 編集

    そのように指定する必要がありましたね。。。すっかり失念しておりました。
    早急のご回答で大変助かりました。ありがとうございました。

    (PS)Laravelで同様のエラーに遭遇している方
    私は、上記のご回答によってphp72-gdを入れたのちにもエラー文が変わりませんでした。そこで
    php.iniに `extension=gd.so` を記述しましたところ無事にLaravelでIntervention/Imageを使用することができました。ご参考になれば幸いです。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.59%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る