質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.62%

npm MODULE_NOT_FOUNDに困らされています。

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 3,020

uk_63

score 23

はじめに

macOS
npm 6.8.0

下記コマンドの結果
npm root -g 
=> /usr/local/lib/node_modules

エラーに至った経緯

React Nativeを使ってみようと思い、環境構築のために公式ドキュメントを見ながらコマンドを実行していました。
npm install -g react-native-cli
このコマンドを実行した際にエラーがでて、npmをアップデートしろとエラーメッセージに出ていたので実行しました。
アップデートした結果、バージョンは6.8.0に変わり、ようやくnpmインストールができると思ってコマンドを実行しました。
すると今度は、こんなエラーがでました。

$ npm install -g expo-cli
npm ERR! code MODULE_NOT_FOUND
npm ERR! Cannot find module './access-error.js'

npm ERR! A complete log of this run can be found in:
npm ERR!     /Users/home/.npm/_logs/2019-03-04T01_53_48_771Z-debug.log

npm ERR! code MODULE_NOT_FOUND

この文章で検索すると下記コマンドを実行するとエラーが解決されたという記事を見つけたので、実行しました。

export NODE_PATH=`npm root -g`

# 結果
/usr/local/lib/node_modules
echo $NODE_PATH

# 結果
/usr/local/lib/node_modules

これでモジュールが見つからないという問題は解決したと思いきや、変わらずモジュールが見つからないとのエラーがでました。更に検索して解決方法を探していると、Node.jsの再インストールが提案されていました。これはまだ実行していません。

なぜなら、Node.jsを削除して、再インストールすることは、さらに別のエラーにつながってしまうのではないかと考えているからです。

エラーがでる行動

npm install XXX
これを実行するとモジュールが見つからないというエラーがでます。

アドバイスを頂きたいです。

なぜパスをとおしたはずなのに、モジュールが見つからないとエラーがでるのか?
解決方法は、Node.jsの再インストールの他にはないのか?

以上、よろしくお願い致します。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • kazto

    2019/03/04 11:22

    ご提示のエラー文では、なんのモジュールに対してMODULE_NOT_FOUNDと言われているのかが不明です。エラー文は省略せず、全文をそのまま貼り付けるようにしてください。

    キャンセル

  • uk_63

    2019/03/04 11:29

    コメントありがとうございます。
    エラーに至った経緯のエラー分を省略せずに全文のせました。
    npm install XXX をすると質問本文にのせているエラーがでます。

    キャンセル

回答 1

checkベストアンサー

0

外していたらすみません。
ひょっとして、rootで実行したら解決する、と言う話ではないでしょうか。

誤)
$ npm install -g expo-cli

正)
$ sudo npm install -g expo-cli

追記:

手元で試してみました。

$ npm i expo-cli

> node-pty-prebuilt@0.7.6 install /Users/kazto/Documents/node_modules/node-pty-prebuilt
> prebuild-install || node scripts/install.js

prebuild-install WARN install No prebuilt binaries found (target=11.6.0 runtime=node arch=x64 libc= platform=darwin)
gyp ERR! configure error
gyp ERR! stack Error: Command failed: /Users/kazto/.pyenv/shims/python -c import sys; print "%s.%s.%s" % sys.version_info[:3];
gyp ERR! stack   File "<string>", line 1
gyp ERR! stack     import sys; print "%s.%s.%s" % sys.version_info[:3];
gyp ERR! stack                                ^
gyp ERR! stack SyntaxError: invalid syntax
gyp ERR! stack
gyp ERR! stack     at ChildProcess.exithandler (child_process.js:294:12)
gyp ERR! stack     at ChildProcess.emit (events.js:188:13)
gyp ERR! stack     at maybeClose (internal/child_process.js:978:16)
gyp ERR! stack     at Socket.stream.socket.on (internal/child_process.js:395:11)
gyp ERR! stack     at Socket.emit (events.js:188:13)
gyp ERR! stack     at Pipe._handle.close (net.js:610:12)
gyp ERR! System Darwin 18.2.0
gyp ERR! command "/usr/local/Cellar/node/11.6.0/bin/node" "/usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild" "--build_v8_with_gn=false"
gyp ERR! cwd /Users/kazto/Documents/node_modules/node-pty-prebuilt
gyp ERR! node -v v11.6.0
gyp ERR! node-gyp -v v3.8.0
gyp ERR! not ok
npm WARN saveError ENOENT: no such file or directory, open '/Users/kazto/Documents/package.json'
npm WARN enoent ENOENT: no such file or directory, open '/Users/kazto/Documents/package.json'
npm WARN gatsby-source-filesystem@2.0.3 requires a peer of gatsby@>2.0.0-alpha but none is installed. You must install peer dependencies yourself.
npm WARN gatsby-transformer-yaml@2.1.3 requires a peer of gatsby@>2.0.15 but none is installed. You must install peer dependencies yourself.
npm WARN Documents No description
npm WARN Documents No repository field.
npm WARN Documents No README data
npm WARN Documents No license field.
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: @expo/ngrok-bin-darwin-ia32@2.2.8 (node_modules/@expo/ngrok-bin-darwin-ia32):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for @expo/ngrok-bin-darwin-ia32@2.2.8: wanted {"os":"darwin","arch":"ia32"} (current: {"os":"darwin","arch":"x64"})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: @expo/ngrok-bin-freebsd-ia32@2.2.8 (node_modules/@expo/ngrok-bin-freebsd-ia32):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for @expo/ngrok-bin-freebsd-ia32@2.2.8: wanted {"os":"freebsd","arch":"ia32"} (current: {"os":"darwin","arch":"x64"})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: @expo/ngrok-bin-linux-arm64@2.2.8 (node_modules/@expo/ngrok-bin-linux-arm64):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for @expo/ngrok-bin-linux-arm64@2.2.8: wanted {"os":"linux","arch":"arm64"} (current: {"os":"darwin","arch":"x64"})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: @expo/ngrok-bin-linux-ia32@2.2.8 (node_modules/@expo/ngrok-bin-linux-ia32):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for @expo/ngrok-bin-linux-ia32@2.2.8: wanted {"os":"linux","arch":"ia32"} (current: {"os":"darwin","arch":"x64"})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: @expo/ngrok-bin-linux-arm@2.2.8 (node_modules/@expo/ngrok-bin-linux-arm):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for @expo/ngrok-bin-linux-arm@2.2.8: wanted {"os":"linux","arch":"arm"} (current: {"os":"darwin","arch":"x64"})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: @expo/ngrok-bin-freebsd-x64@2.2.8 (node_modules/@expo/ngrok-bin-freebsd-x64):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for @expo/ngrok-bin-freebsd-x64@2.2.8: wanted {"os":"freebsd","arch":"x64"} (current: {"os":"darwin","arch":"x64"})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: @expo/ngrok-bin-sunos-x64@2.2.8 (node_modules/@expo/ngrok-bin-sunos-x64):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for @expo/ngrok-bin-sunos-x64@2.2.8: wanted {"os":"sunos","arch":"x64"} (current: {"os":"darwin","arch":"x64"})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: @expo/ngrok-bin-win32-x64@2.2.8-beta.1 (node_modules/@expo/ngrok-bin-win32-x64):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for @expo/ngrok-bin-win32-x64@2.2.8-beta.1: wanted {"os":"win32","arch":"x64"} (current: {"os":"darwin","arch":"x64"})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: @expo/ngrok-bin-win32-ia32@2.2.8-beta.1 (node_modules/@expo/ngrok-bin-win32-ia32):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for @expo/ngrok-bin-win32-ia32@2.2.8-beta.1: wanted {"os":"win32","arch":"ia32"} (current: {"os":"darwin","arch":"x64"})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: @expo/ngrok-bin-linux-x64@2.2.8 (node_modules/@expo/ngrok-bin-linux-x64):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for @expo/ngrok-bin-linux-x64@2.2.8: wanted {"os":"linux","arch":"x64"} (current: {"os":"darwin","arch":"x64"})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: @expo/traveling-fastlane-linux@1.8.0 (node_modules/@expo/traveling-fastlane-linux):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for @expo/traveling-fastlane-linux@1.8.0: wanted {"os":"win32,linux","arch":"any"} (current: {"os":"darwin","arch":"x64"})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: node-pty-prebuilt@0.7.6 (node_modules/node-pty-prebuilt):
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: node-pty-prebuilt@0.7.6 install: `prebuild-install || node scripts/install.js`
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: Exit status 1

+ expo-cli@2.11.6
updated 1 package and audited 14838 packages in 17.071s
found 10 vulnerabilities (5 low, 5 moderate)
  run `npm audit fix` to fix them, or `npm audit` for details

私の環境では、これだけの量のログが出ています。 質問者様には、再度お願いいたしますが、ログを全文貼り付けるよう、お願いします。


「npm ERR! code MODULE_NOT_FOUND」で検索したところ、下記に当たりました。

https://github.com/tj/n/issues/453

一度、node_modulesフォルダを全削除してNode.jsをインストールしなおすと上手くいく、とのことです。

$ sudo rm -rf /usr/local/lib/node_modules
$ curl -0 -L https://npmjs.com/install.sh | sudo sh

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/03/04 12:56

    半年前くらいにyarnを使ってreactの環境を構築したことがありました。
    npmのインストールは今回に限らず、エラーが多い印象でしたので、基本的にyarnを使っていた事を忘れていました。
    よく下調べをせずにyarnを使っていませんでした。それは関係していますか?
    そのことは関係していますか?

    キャンセル

  • 2019/03/04 13:48

    npmとyarnがどう干渉するかについては、すみませんが答えを持っておりません。調べてもおそらく出てこなさそうな印象です。
    ひとまず、目の前の問題に注力してみてはいかがでしょうか。
    いったんnode_modulesを削除して構わないのであれば、削除して、yarnでインストールし直すとしてみてはいかがでしょうか。

    キャンセル

  • 2019/03/04 14:29

    やってみます。お付き合いくださりありがとうございました。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.62%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる