質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.59%

Rails s -dだとWebpackのコンパイルに失敗する

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 1
  • VIEW 2,805

score 13

デーモン起動するとWebpackのコンパイルに失敗する

Railsの勉強でRails+VueのアプリをEC2上に作成しているのですが、
rails sしたときはWebpackのコンパイルが上手くいくのですがrails s -dで実行したときはコンパイルに失敗します。

vueファイルやwebpackの設定はrails webpacker:install:vueを実行した直後の状態で何も変えていません。

エラーメッセージ

rails s -d -b 0.0.0.0でhello_vueを表示するページにアクセスしたときのログです。

Started GET "/home" for xxx.xxx.xx.xx at 2019-02-25 04:40:12 +0000
Cannot render console from xxx.xxx.xx.xx! Allowed networks: 127.0.0.1, ::1, 127.0.0.0/127.255.255.255
Processing by HomeController#index as HTML
  Rendering home/index.html.erb within layouts/application
[Webpacker] Compiling…
[Webpacker] Compilation failed:
/home/ec2-user/.rbenv/versions/2.6.0/bin/ruby: No such file or directory -- ./bin/webpack (LoadError)


rails sで実行したときはコンパイルに成功します

Processing by HomeController#index as HTML
  Rendering home/index.html.erb within layouts/application
[Webpacker] Compiling…
[Webpacker] Compiled all packs in /home/ec2-user/webpack_test/public/packs
  Rendered home/index.html.erb within layouts/application (3124.5ms)
Completed 200 OK in 3917ms (Views: 3909.6ms | ActiveRecord: 0.0ms)

試したこと

yarn installやbundle installなどは試しました。

補足情報(FW/ツールのバージョンなど)

Amazon Linux AMI release 2018.03
Rails     5.2.2
Ruby      2.6.0
webpacker 3.5
vue       2.6.7

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

0

調べてみました。
webpacker 3.5系に存在するバグのようですね。

PR作ったのでそのうち取り込まれるかもです。
https://github.com/rails/webpacker/pull/1965

急ぎなら4.0.0rc系に挙げてみるとか、masterを使うか

どうしても3系が必要なのであれば、私のレポジトリをフォークして(※)

gem 'webpacker', github: 'xxxxxxxxxxxx/webpacker', branch: 'fix/compiling-failure-when-rails-server-is-daeamon'

という感じで利用されると良いと思います。

※ 私のレポジトリは消してしまうかもしれませんのでフォークで。

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/02/27 21:25

    hello_vue表示できました!
    1.Gemfileのwebpackの行に, '>=4.0.x'を追加
    2.babelやpostcssの足りてなかったものをインストールしたら表示できました!

    キャンセル

  • 2019/02/27 23:21

    良かったです!

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.59%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る