質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.60%

npm install したパッケージが使えない

解決済

回答 2

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 1,585

score 22

<環境>
OS: macOS Mojave バージョン 10.14.2
ターミナル: iTerm2
node: 10.15.1
npm: 6.8.0
nodebrewを使用しています

<起きている問題・解決したいこと>
npm -g install <パッケージ名>としたとき、一部のパッケージは正常にインストールに成功するのですが、一部のパッケージではインストールは成功しているにも関わらず、バージョンを表示しようとしてもエラーが出てしまいます。
例えば、以下のようにhttp-serverをインストールしたときはちゃんとバージョンが表示されますが、vueをインストールした後、vueのバージョンを表示しようとしたところでエラーが出てしまいます。
そこで、npmでインストールしたパッケージは全て使用できる(=コマンドが見つからない、などのエラーが出ない)状態にしたいです。

~$ npm install -g http-server
/Users/MyUserName/.nodebrew/node/v10.15.1/bin/http-server -> /Users/MyUserName/.nodebrew/node/v10.15.1/lib/node_modules/http-server/bin/http-server
/Users/MyUserName/.nodebrew/node/v10.15.1/bin/hs -> /Users/MyUserName/.nodebrew/node/v10.15.1/lib/node_modules/http-server/bin/http-server
+ http-server@0.11.1
added 26 packages from 28 contributors in 2.009s
~$ http-server -v
Starting up http-server, serving ./public
Available on:
  http://127.0.0.1:8080
  http://192.168.100.104:8080
  http://192.168.33.1:8080
  http://192.168.99.1:8080
Hit CTRL-C to stop the server
^Chttp-server stopped.
~$ npm install -g vue
+ vue@2.6.6
added 1 package from 1 contributor in 0.642s
~$ vue -V
zsh: command not found: vue

<今回の問題に関係があるかもしれない思ったところ>
npmでインストールされたパッケージの保存先として、http-serverは
~/.nodebrew/current/bin

~/.nodebrew/current/lib/node_modules
の2箇所に記述がある(前者のディレクトリから後者のディレクトリにシンボリックリンクが貼られている)のですが、
vueの場合は
~/.nodebrew/current/lib/node_modules
の方にしか保存されていません。(以下のコードのようになっています)

~$ ls -la ~/.nodebrew/current/bin
total 78024
drwxr-xr-x  8 MyUserName  staff       256  2 16 14:54 .
drwxr-xr-x  9 MyUserName  staff       288  2 14 23:12 ..
lrwxr-xr-x  1 MyUserName  staff        47  2 16 14:54 hs -> ../lib/node_modules/http-server/bin/http-server
lrwxr-xr-x  1 MyUserName  staff        47  2 16 14:54 http-server -> ../lib/node_modules/http-server/bin/http-server
-rwxr-xr-x  1 MyUserName  staff  39945984  1 29 16:18 node
lrwxr-xr-x  1 MyUserName  staff        39  2 14 23:13 nodebrew -> /Users/MyUserName/.nodebrew/nodebrew
lrwxr-xr-x  1 MyUserName  staff        38  2 14 23:13 npm -> ../lib/node_modules/npm/bin/npm-cli.js
lrwxr-xr-x  1 MyUserName  staff        38  2 14 23:13 npx -> ../lib/node_modules/npm/bin/npx-cli.js
~$ ls -la ~/.nodebrew/current/lib/node_modules
total 0
drwxr-xr-x   5 MyUserName  staff  160  2 16 14:54 .
drwxr-xr-x   4 MyUserName  staff  128  2 14 23:12 ..
drwxr-xr-x   8 MyUserName  staff  256  2 16 14:54 http-server
drwxr-xr-x  25 MyUserName  staff  800  2 14 23:13 npm
drwxr-xr-x   8 MyUserName  staff  256  2 16 14:28 vue


また、この後npm install -gによってexpressとyarnをインストールしてみました。すると、どちらもインストール自体は問題なく完了したのですが、バージョン表示をしようとすると、expressの方は「zsh: command not found: express」とエラーになりましたが、yarnの方は「1.13.0」と、バージョンが表示されました。
なぜ同じインストール方法をしているにも関わらずパッケージごとに挙動が異なるのか意味がわからないです。
ご回答、よろしくお願いします。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

+2

vueパッケージはコア部分だけで、コマンドラインツールを使うには「vue-cli」という別なパッケージが必要となります。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/02/16 15:38

    expressのコマンドラインツールは「express-generator」という名前だそうです。

    キャンセル

  • 2019/02/16 16:08

    ありがとうございます!!

    キャンセル

checkベストアンサー

+1

Node.jsのコマンドライン拡張というのは、
あくまでNode.jsが持つ機能のオプション的な存在です。
マストじゃないのよ。

コマンドライン拡張していないモジュールの方が大多数で、
何でもかんでもコマンドラインで使えるわけではありません。
製作者が頑張ってそれ用の機能を実装してくださってるのよ。

ちゃんと公式サイトやREADMEファイルなどの説明書きを読めば、
コマンドライン拡張されてますよなモジュールはそれ用の紹介がされています。

まずはNode.js流儀の使い方を学習していきましょう。


Node.jsでプロジェクトを作った場合、
自作のコマンドラインツールを作る事が可能ですが、それには条件が必要です。

プロジェクトルートのpackage.jsonにbinというキーを指定し、
"bin": {"コマンド名": "コマンド内容"}という形でフォーマットを指定したものだけが、
npm install -gオプションを使ってインストールされたときにコマンドラインツールとして実行出来る対応となります。


それを踏まえてnpmでVueを探してみましょう。
https://www.npmjs.com/package/vue

npmのモジュールには右側のカラムにGitHubのリポジトリとのヒモ付があり、プロジェクトの実ファイルも閲覧可能です。
https://github.com/vuejs/vue

そのpackage.jsonを開いてもbin: コマンド設定というキーはどこにもありませんね。
プロジェクトの説明書きにvue-cliがひっついており、
ちょっと特殊な箇所をデプロイしているようですがネストされたディレクトリ内にあるpackage.jsonにbinの記述があり使えるようになります。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/02/16 16:08

    モジュールはコマンドラインから使えるのが普通だと思ってましたがそうじゃないんですね!
    質問したことよりずっと多くのことが学べて嬉しいです。
    詳しい説明をしていただきありがとうございます!!

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.60%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る