質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.60%

VScodeでFailed to start Solargraph(macOS)

受付中

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 5,729

score 57

お世話になっております。
VScodeでRuby Solargraphをインストールしたのですが、再リロード時にFailed to start Solargraphのエラーと、
Couldn't start client Ruby Language Serverのエラーが発生します。

gem install solargraphはすでに実行しており、ターミナルだとsolargraphのhelpが見れるのは確認済みです。

イメージ説明

一応この状態で、rubyのファイルに文字を入力してみても動作していないのが確認できます。

イメージ説明

どのように修正すべきでしょうか。ご教授お願いします。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

+1

Solargraphのpathは設定しましたでしょうか。

File-Preferences-Settingsから、ExtensionsのSolergraphを選んで、「Command Path」にSolargraphのファイルがある位置を指定してみましょう。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/02/14 16:28

    自分はWindowsで、rbenvもない環境なので、こちらで調べられる範囲を超えています。申し訳ありません…

    キャンセル

  • 2019/02/14 16:46

    ご協力いただきありがとうございます!

    キャンセル

  • 2021/07/28 14:59

    こちらでも昨日同じような問題が発生しました。
    徹夜で色々試してやっと解決したので参考までにシェアします。

    まず、ターミナルにエラー情報を出力してみましょう。
    -------------------------------------
    Could not find 'bundler' (1.17.2) required by your c:/Users/your_account/source/repos/perfect/Gemfile.lock. (Gem::MissingSpecVersionError)
    To update to the latest version installed on your system, run 'bundle update --bundler'.
    To install the missing version, run 'gem install bundler:1.17.2'
    Checked in 'GEM_PATH=C:/Users/your_account/.gem/ruby/2.7.0;C:/Ruby27-x64/lib/ruby/gems/2.7.0', execute 'gem env' for more information

    必要な「バンドル」(1.17.2)が見つかりませんでした。
    システムにインストールされている最新バージョンに更新するには、'bundle update--bundler'を実行します。
    不足しているバージョンをインストールするには、'gem install bundler:1.17.2'を実行します。
    -------------------------------------

    上記の部分から、存在確認のためターミナルで`bundler -v`を実行。
    結果、見つからないということでしたので`gem install bundler -v 1.17.2`をコマンドしました。
    見事にSolargraphを問題なく使えています。(コマンド後にVSCodeは再起動して下さい)
    原因は不明ですが、gemのインストールが何らかの理由で上手くできてなかったのかもしれません。

    もし、上記でも解決しない場合は別の拡張機能を使ってみてはどうでしょうか。
    最近はTabnineというオートコンプリートツールも存在するようです。
    https://www.tabnine.com/


    【検証環境】
    Version: 1.58.2 (user setup)
    OS: Windows_NT x64 10.0.19042

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.60%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る