質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.61%

cabal install cabal-install ができない

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 1,339

score 312

前提・実現したいこと

cabal install cabal-installを行い、最新版にしたい。

発生している問題・エラーメッセージ

[apo@ringo-apo bin]$ cabal install cabal-install
Resolving dependencies...
cabal: cannot configure cabal-install-2.4.1.0. It requires base >=4.8 && <4.13
For the dependency on base >=4.8 && <4.13 there are these packages:
base-4.8.0.0, base-4.8.1.0, base-4.8.2.0, base-4.9.0.0, base-4.9.1.0 and
base-4.10.0.0. However none of them are available.
base-4.8.0.0 was excluded because of the top level dependency base -any
base-4.8.1.0 was excluded because of the top level dependency base -any
base-4.8.2.0 was excluded because of the top level dependency base -any
base-4.9.0.0 was excluded because of the top level dependency base -any
base-4.9.1.0 was excluded because of the top level dependency base -any
base-4.10.0.0 was excluded because of the top level dependency base -any

試したこと

cabalをアンインストールして、再インストールしましたが変わらず。
Githubから直接クローンして実行もしてみましたが、結果は変わりませんでした。

補足情報(FW/ツールのバージョンなど)

OS:CentOS6.1
cabal:

[apo@ringo-apo bin]$ cabal --version
cabal-install version 0.10.2
using version 1.10.2.0 of the Cabal library

cabal install cabal-installの前にcabal updateを行っています。
その際のメッセージは下記のとおりです。

[apo@ringo-apo bin]$ cabal update
Downloading the latest package list from hackage.haskell.org
Note: there is a new version of cabal-install available.
To upgrade, run: cabal install cabal-install

よろしくお願いします。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

+1

エラーメッセージを読む限り、baseパッケージが古いのが原因のようです。
そのbaseパッケージは、基本的にGHCに密結合したものなので、GHCのバージョンを上げない限り新しいバージョンをインストールすることはできません。

なので、まずはGHCをアップグレードするところから始めましょう。
ただ、 GHC最新版のダウンロードページ を見る限り、CentOS 6向けのバイナリパッケージはないので、先にCent OSを7に上げない限りインストールするのは困難かと思いますが...

投稿

コミュニティ
  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/02/14 12:28

    なんですと!!

    ご教示ありがとうございました。。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.61%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る