質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.45%

  • Node.js

    2428questions

    Node.jsとはGoogleのV8 JavaScriptエンジンを使用しているサーバーサイドのイベント駆動型プログラムです。

  • Heroku

    1255questions

    HerokuはHeroku社が開発と運営を行っているPaaSの名称です。RubyやNode.js、Python、そしてJVMベース(Java、Scala、Clojureなど)の複数のプログラミング言語をサポートしている。

  • Cloud9

    579questions

    Cloud9は、クラウドからのプログラミングが可能になるWebサービス。IDEとしての機能が搭載されており、GitHubやHerokuなど他ツールとの連携も可能です。ブラウザ上で動くため、デバイスに関係なく開発環境を準備できます。

cloud9からherokuにデプロイできない

解決済

回答 1

投稿

  • 評価
  • クリップ 2
  • VIEW 319

awa

score 21

AWSのcloud9でHerokuにデプロイするために、まずheroku infoをコンソールで叩いたところ、
以下のようなログが吐かれます。
nodeのバージョンが原因なのかと考えましたが、どうすれば解決できるかわかりません。
教えていただけないでしょうか。
node -vを叩くとv8.3.0と表示されます。

 $ heroku info
(node:18397) Error Plugin: @oclif/plugin-legacy: files attribute must be specified in /home/ec2-user/.nvm/versions/node/v6.15.0/lib/node_modules/heroku-cli/node_modules/@oclif/plugin-legacy/package.json
module: @oclif/config@1.12.0
plugin: @oclif/plugin-legacy
root: /home/ec2-user/.nvm/versions/node/v6.15.0/lib/node_modules/heroku-cli/node_modules/@oclif/plugin-legacy
See more details with DEBUG=*
(node:18397) Error Plugin: @oclif/plugin-not-found: files attribute must be specified in /home/ec2-user/.nvm/versions/node/v6.15.0/lib/node_modules/heroku-cli/node_modules/@oclif/plugin-not-found/package.json
module: @oclif/config@1.12.0
plugin: @oclif/plugin-not-found
root: /home/ec2-user/.nvm/versions/node/v6.15.0/lib/node_modules/heroku-cli/node_modules/@oclif/plugin-not-found
See more details with DEBUG=*
(node:18397) Error Plugin: @oclif/plugin-plugins: files attribute must be specified in /home/ec2-user/.nvm/versions/node/v6.15.0/lib/node_modules/heroku-cli/node_modules/@oclif/plugin-plugins/package.json
module: @oclif/config@1.12.0
plugin: @oclif/plugin-plugins
root: /home/ec2-user/.nvm/versions/node/v6.15.0/lib/node_modules/heroku-cli/node_modules/@oclif/plugin-plugins
See more details with DEBUG=*
(node:18397) Error Plugin: @oclif/plugin-update: files attribute must be specified in /home/ec2-user/.nvm/versions/node/v6.15.0/lib/node_modules/heroku-cli/node_modules/@oclif/plugin-update/package.json
module: @oclif/config@1.12.0
plugin: @oclif/plugin-update
root: /home/ec2-user/.nvm/versions/node/v6.15.0/lib/node_modules/heroku-cli/node_modules/@oclif/plugin-update
See more details with DEBUG=*
(node:18397) Error Plugin: @oclif/plugin-warn-if-update-available: files attribute must be specified in /home/ec2-user/.nvm/versions/node/v6.15.0/lib/node_modules/heroku-cli/node_modules/@oclif/plugin-warn-if-update-available/package.json
module: @oclif/config@1.12.0
plugin: @oclif/plugin-warn-if-update-available
root: /home/ec2-user/.nvm/versions/node/v6.15.0/lib/node_modules/heroku-cli/node_modules/@oclif/plugin-warn-if-update-available
See more details with DEBUG=*
 ›   Warning: heroku-cli update available from 7.0.9 to 7.19.4
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

+1

自分も同じように、
Warning: heroku-cli update available from 7.0.9 to 7.19.4
が出たことがあります。

確かherokuをアップデートするか、herokuをインストールし直せば治ります。

Herokuをアップデートするコマンド
heroku update

クラウドIDE上でHerokuをインストールするコマンド
source <(curl -sL https://cdn.learnenough.com/heroku_install)

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/02/06 01:07

    ありがとうございます、助かりました。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.45%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る

  • Node.js

    2428questions

    Node.jsとはGoogleのV8 JavaScriptエンジンを使用しているサーバーサイドのイベント駆動型プログラムです。

  • Heroku

    1255questions

    HerokuはHeroku社が開発と運営を行っているPaaSの名称です。RubyやNode.js、Python、そしてJVMベース(Java、Scala、Clojureなど)の複数のプログラミング言語をサポートしている。

  • Cloud9

    579questions

    Cloud9は、クラウドからのプログラミングが可能になるWebサービス。IDEとしての機能が搭載されており、GitHubやHerokuなど他ツールとの連携も可能です。ブラウザ上で動くため、デバイスに関係なく開発環境を準備できます。