質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.51%

  • Ruby

    9441questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

(至急)imagemagickをcloud9で扱いたい

解決済

回答 2

投稿

  • 評価
  • クリップ 0
  • VIEW 1,641

cheeeeeeese

score 149

皆様、質問がございます、よろしくお願い申し上げます。

質問

Cloud9に"linuxbrew"を用いて"imageclip"をインストールする方法をお教えください。

下記コードまではできたのですが、このあとにどうすれば良いのかわからないため、ご指示いただければ幸いです。


コード

rudiments@pin-board:~/workspace/music_note (master) $ ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/linuxbrew/go/install)"
==> This script will install:
/home/ubuntu/.linuxbrew/bin/brew
/home/ubuntu/.linuxbrew/Library/...
/home/ubuntu/.linuxbrew/share/man/man1/brew.1

Press RETURN to continue or any other key to abort
==> Downloading and installing Homebrew...
remote: Counting objects: 283062, done.
remote: Total 283062 (delta 0), reused 0 (delta 0), pack-reused 283062
Receiving objects: 100% (283062/283062), 53.93 MiB | 11.88 MiB/s, done.
Resolving deltas: 100% (212933/212933), done.
From https://github.com/Homebrew/linuxbrew
 * [new branch]      master     -> origin/master
HEAD is now at 4e9b33a openssl: use a versioned certificate file
Warning: /home/ubuntu/.linuxbrew/bin is not in your PATH.
==> Installation successful!
==> Next steps
Install the Linuxbrew dependencies:

Debian, Ubuntu, etc.:
  `sudo apt-get install build-essential`

Fedora, Red Hat, CentOS, etc.:
  `sudo yum groupinstall 'Development Tools'`

See http://brew.sh/linuxbrew/#dependencies for more information.

Run `brew doctor` before you install anything

よろしくお願い申し上げます。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

checkベストアンサー

+1

Cloud9にimagemagickをインストールするのであれば、

$ sudo apt-get install ImageMagick

で良いようです。linuxbrewを利用しないといけない理由はなにかありますか?

参考: Installing ImageMagick

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2015/09/14 23:46

    ご回答ありがとうございます。

    キャンセル

+1

前提 linuxbrew は使用していません。Homebrewのlinux版という認識でコマンドはほぼ同じだと思って回答しています。
申し訳ありませんが、imageclipというライブラリを存じ上げませんので、ライブラリ独自のインストール時のオプションは解りませんのでご了承ください。
(質問にライブラリのGitHubなどのリンクを貼られるのが良いでしょう)

Linuxbrew
What Packages Are Available?
1. Type brew search for a list.
2. Or visit braumeister.org to browse packages online.
3. Or use brew desc to browse packages from the command line.

Installation
brew install $WHATEVER_YOU_WANT

検索してあればinstallコマンドを実行すればインストールされるかと思います。linuxbrewで管理されていないパッケージなら検索結果に出てこないのでbrewではインストールできないとおもいます。
$ brew search PACKAGE_NAME
$ brew install PACKAGE_NAME


後、これは個人的に思うところなので本題とは関係ありませんが、[至急]と付けられるのは辞めた方が良いかと思います。このワードがあると、こういった無料のフォーラムだと回答したくなくなる方が多いのではないかと思います。かつてこういったプログラミングのフォーラムでよく貼られていたリンクを参考までに載せておきます。
【至急お願いします】 番外編 - 質問NGワード集 - テクニカルノート

本当に急ぎで解決しなければならない問題であれば、フォラーム的なサイトより下記サービスなどを利用して依頼を出される方が献身的に解決策を貰えるかと思いますので、宜しいかと思います。
CrowdWorks
Lancers

偉そうに書いてスミマセンm_ _m

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

同じタグがついた質問を見る

  • Ruby

    9441questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。