質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.49%

  • Node.js

    1934questions

    Node.jsとはGoogleのV8 JavaScriptエンジンを使用しているサーバーサイドのイベント駆動型プログラムです。

"nodist update"の実行に失敗し、Node.jsがインストールできません

解決済

回答 2

投稿

  • 評価
  • クリップ 1
  • VIEW 9,668

sounisi5011

score 699

node.js インストール備忘録(windows7) - Qiita

上記の投稿を参考にし、Node.jsのインストールを行おうとした所、nodist update及びnodist stableが正常に実行できず、先へ進めなくなってしまいました。

エラー内容は以下になります。

>nodist update
Installing latest stable version...
Couldn't fetch nodev4.0.0: HTTP 404.
Sorry.
Sorry, there's a problem with nodist. Couldn't decide which node version to use.
 Please set a version.
Update dependencies...
Sorry, there's a problem with nodist. Couldn't decide which node version to use.
 Please set a version.

>nodist stable
Couldn't fetch nodev4.0.0: HTTP 404.
Sorry.

これについて、いろいろな検索キーワードを駆使し調べたのですが、これに該当するエラーメッセージについて書かれているページすら見つからず、八方塞がりの状態です。

現在まで行ったことは以下になります:

  1. GitHubのページからzipファイルをダウンロードし、Cドライブ直下に中身を展開
  2. 展開したディレクトリへのパスを通すため、「システムのプロパティ」にある「環境変数」の項目からPATHとNODIST_PREFIXを設定
  3. 質問のエラーが発生
  4. もしやと思い、NODE_PATHとNODIST_X64をコマンドプロンプト上で指定
  5. エラーは改善せず

環境はこちらです:

Windows 7 Home Premium SP1 64bit

nodistのバージョンは以下になります:

>nodist -v
0.6.0

質問は、このエラーを解決し、Node.jsを利用できるようにするにはどうすれば良いのか? について。
よろしくお願いします。
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

checkベストアンサー

+1

私もハマってしまって、困っていました。
すると、nodistのGitHubに、v0.6.1がアップされていました。
https://github.com/marcelklehr/nodist
そしてnodistを1からインストールしなおしました。(私の場合、git経由ではなく、zipでまるごとダウンロードしました)
で、
>nodist selfupdate
しましたら、問題なくnodev4.0.0がインストールされました。
ちなみにOSはWindows8.1です。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2015/09/14 19:46

    nodist側の問題だったっぽいですね…
    早速アップデートしてみます!

    キャンセル

  • 2015/09/15 22:21 編集

    v0.6.1は2015年9月12日0時14分の更新ですね。
    質問した次の日に解決していたなんて…

    ともかく、以下の手順により解決しました!

    1. GitHubのページからv0.6.1のzipファイルをダウンロード
    2. nodistを展開したディレクトリの中身をv0.6.1のものに置き換え
    3. PATHとNODIST_PREFIXはnodistのディレクトリを変更していないため修正無し
    4. NODE_PATHとNODIST_X64はコマンドプロンプトのsetコマンド(オプション無し)により指定したため保存されておらず、対処は不要
    5. 「nodist -v」によりnodistのバージョンが0.6.1であることを確認
    6. Qiitaの投稿の「nodist update」以降の操作を実行
    7. 成功!

    キャンセル

0

私もこれハマりました…
とりあえずなのですが、Node.jsのバージョンを指定してインストールしてみるといいかもしれません。

nodist + v0.12.7 //バージョン0.12.7をインストールする場合

バージョンは任意のものに変えてください。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2015/09/11 13:08

    Node.jsの公式サイトに記載されている最新バージョンv4.0.0のインストールを試みましたが、失敗します…

    >nodist + v4.0.0
    Couldn't fetch nodev4.0.0: HTTP 404.
    Sorry.

    キャンセル

  • 2015/09/14 19:47

    お力になれず申しわけございません。
    kaizumakiさんの回答からこの問題は解決できると思われます。

    キャンセル

関連した質問

同じタグがついた質問を見る

  • Node.js

    1934questions

    Node.jsとはGoogleのV8 JavaScriptエンジンを使用しているサーバーサイドのイベント駆動型プログラムです。