質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.59%

rails: rails s 解決方法 起動しない

解決済

回答 2

投稿 編集

  • 評価
  • クリップ 1
  • VIEW 2,133

 前提・実現したいこと

rails を勉強中の学生です。rails s をすると以下のようなエラーが出ます。
かなりの時間を使って解決を試みましたがどれも失敗してしまい、お手上げ状態です。どなたかご教授のほどよろしくお願いします。
rails -p 3000 などでとりあえずは実行できるのですが、デプロイ時エラーが出て、ここら辺が関わっているのではないかと思い質問しました。普通は、Listening on tcp://0.0.0.0:3000 が一回しか出ないはずなのですが...

 発生している問題・エラーメッセージ

=> Booting Puma
=> Rails 5.2.1 application starting in development 
=> Run `rails server -h` for more startup options
[1167] Puma starting in cluster mode...
[1167] * Version 3.12.0 (ruby 2.5.1-p57), codename: Llamas in Pajamas
[1167] * Min threads: 5, max threads: 5
[1167] * Environment: development
[1167] * Process workers: 2
[1167] * Preloading application
[1167] * Listening on tcp://0.0.0.0:3000
[1167] * Listening on tcp://0.0.0.0:3000
Exiting
Traceback (most recent call last):
    40: from bin/rails:3:in `<main>'
    39: from bin/rails:3:in `load'
    38: from /Users/yuki/rails/git_tech/tec_board/bin/spring:15:in `<top (required)>'
    37: from /Users/yuki/rails/git_tech/tec_board/bin/spring:15:in `require'
    36: from /Users/yuki/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/spring-2.0.2/lib/spring/binstub.rb:31:in `<top (required)>'
    35: from /Users/yuki/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/spring-2.0.2/lib/spring/binstub.rb:31:in `load'
    34: from /Users/yuki/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/spring-2.0.2/bin/spring:49:in `<top (required)>'
    33: from /Users/yuki/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/spring-2.0.2/lib/spring/client.rb:30:in `run'
    32: from /Users/yuki/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/spring-2.0.2/lib/spring/client/command.rb:7:in `call'
    31: from /Users/yuki/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/spring-2.0.2/lib/spring/client/rails.rb:28:in `call'
    30: from /Users/yuki/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/spring-2.0.2/lib/spring/client/rails.rb:28:in `load'
    29: from /Users/yuki/rails/git_tech/tec_board/bin/rails:9:in `<top (required)>'
    28: from /Users/yuki/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/activesupport-5.2.1/lib/active_support/dependencies.rb:287:in `require'
    27: from /Users/yuki/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/activesupport-5.2.1/lib/active_support/dependencies.rb:253:in `load_dependency'
    26: from /Users/yuki/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/activesupport-5.2.1/lib/active_support/dependencies.rb:287:in `block in require'
    25: from /Users/yuki/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:29:in `require'
    24: from /Users/yuki/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:20:in `require_with_bootsnap_lfi'
    23: from /Users/yuki/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/loaded_features_index.rb:65:in `register'
    22: from /Users/yuki/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:21:in `block in require_with_bootsnap_lfi'
    21: from /Users/yuki/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:21:in `require'
    20: from /Users/yuki/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/railties-5.2.1/lib/rails/commands.rb:18:in `<main>'
    19: from /Users/yuki/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/railties-5.2.1/lib/rails/command.rb:46:in `invoke'
    18: from /Users/yuki/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/railties-5.2.1/lib/rails/command/base.rb:65:in `perform'
    17: from /Users/yuki/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/thor-0.20.3/lib/thor.rb:387:in `dispatch'
    16: from /Users/yuki/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/thor-0.20.3/lib/thor/invocation.rb:126:in `invoke_command'
    15: from /Users/yuki/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/thor-0.20.3/lib/thor/command.rb:27:in `run'
    14: from /Users/yuki/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/railties-5.2.1/lib/rails/commands/server/server_command.rb:142:in `perform'
    13: from /Users/yuki/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/railties-5.2.1/lib/rails/commands/server/server_command.rb:142:in `tap'
    12: from /Users/yuki/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/railties-5.2.1/lib/rails/commands/server/server_command.rb:147:in `block in perform'
    11: from /Users/yuki/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/railties-5.2.1/lib/rails/commands/server/server_command.rb:53:in `start'
    10: from /Users/yuki/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/rack-2.0.6/lib/rack/server.rb:297:in `start'
     9: from /Users/yuki/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/puma-3.12.0/lib/rack/handler/puma.rb:70:in `run'
     8: from /Users/yuki/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/puma-3.12.0/lib/puma/launcher.rb:184:in `run'
     7: from /Users/yuki/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/puma-3.12.0/lib/puma/cluster.rb:410:in `run'
     6: from /Users/yuki/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/puma-3.12.0/lib/puma/runner.rb:151:in `load_and_bind'
     5: from /Users/yuki/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/puma-3.12.0/lib/puma/binder.rb:88:in `parse'
     4: from /Users/yuki/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/puma-3.12.0/lib/puma/binder.rb:88:in `each'
     3: from /Users/yuki/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/puma-3.12.0/lib/puma/binder.rb:105:in `block in parse'
     2: from /Users/yuki/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/puma-3.12.0/lib/puma/binder.rb:272:in `add_tcp_listener'
     1: from /Users/yuki/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/puma-3.12.0/lib/puma/binder.rb:272:in `new'
/Users/yuki/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/puma-3.12.0/lib/puma/binder.rb:272:in `initialize': Address already in use - bind(2) for "0.0.0.0" port 3000 (Errno::EADDRINUSE)

 試したこと

rails s  -p 3000 は実行可能です。
ps で見ても他に起動しているサーバーはないです。
エラー内容では「port 3000がすでに使われている」となっていますがps で確認しています。
予想としては rails s で一気に二つ起動しているのではないかと思うのですが、どうしたらよいかわからないです。

###########追記################
sudo lsof -i -P | grep "LISTEN"


をしたところ

iCoreServ   64           root   11u  IPv4 0x5b64cd14a1797b3f      0t0  TCP localhost:37848 (LISTEN)
VisualStu  334           yuki   41u  IPv4 0x5b64cd14a9489b3f      0t0  TCP localhost:49215 (LISTEN)
rapportd  1813           yuki    3u  IPv4 0x5b64cd14ad8f20bf      0t0  TCP *:53638 (LISTEN)
rapportd  1813           yuki    4u  IPv6 0x5b64cd14a6beefd7      0t0  TCP *:53638 (LISTEN)


が表示されました。

また

rails s -p 3000


をおこなってから

sudo lsof -i -P | grep "LISTEN"


したところ

iCoreServ   64           root   11u  IPv4 0x5b64cd14a1797b3f      0t0  TCP localhost:37848 (LISTEN)
VisualStu  334           yuki   41u  IPv4 0x5b64cd14a9489b3f      0t0  TCP localhost:49215 (LISTEN)
rapportd  1813           yuki    3u  IPv4 0x5b64cd14ad8f20bf      0t0  TCP *:53638 (LISTEN)
rapportd  1813           yuki    4u  IPv6 0x5b64cd14a6beefd7      0t0  TCP *:53638 (LISTEN)
ruby      1846           yuki   10u  IPv4 0x5b64cd14aa7ff0bf      0t0  TCP localhost:3000 (LISTEN)
ruby      1846           yuki   11u  IPv6 0x5b64cd14a6bef597      0t0  TCP localhost:3000 (LISTEN)
ruby      1860           yuki   10u  IPv4 0x5b64cd14aa7ff0bf      0t0  TCP localhost:3000 (LISTEN)
ruby      1860           yuki   11u  IPv6 0x5b64cd14a6bef597      0t0  TCP localhost:3000 (LISTEN)
ruby      1861           yuki   10u  IPv4 0x5b64cd14aa7ff0bf      0t0  TCP localhost:3000 (LISTEN)
ruby      1861           yuki   11u  IPv6 0x5b64cd14a6bef597      0t0  TCP localhost:3000 (LISTEN)


となりました。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

check解決した方法

0

解決しました。puma.rb 内で二度ポートを開くというプログラムになっていたので、片方をコメントアウトしました。
前編集した時の消し忘れでした、、、

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

0

予想通りのことが起きています。terminalで、

sudo lsof -i -P | grep "LISTEN"


とすると

postgres    863 UserName   5u  IPv6 0xfae32e951366411f      0t0  TCP localhost:5432 (LISTEN)
postgres    863 UserName   6u  IPv4 0xfae32e9518d1df9f      0t0  TCP localhost:5432 (LISTEN)
ruby      14876 UserName   19u  IPv4 0xfae32e95253d129f     0t0  TCP *:3000 (LISTEN)

のようなログが出てくるかと思いますので、*:3000を占領している行のUserNameの前の数字(今回は14876)で

$ kill -9 14876


としてやるとプロセスを終了できます。その後rails sを再度試してみてください。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/11/24 18:30

    再起動しても状況は変わらずです...

    キャンセル

  • 2018/11/24 18:36

    $ rm tmp/pids/server.pid
    とするとどうでしょうか。(すみません。これ以上思いつきません...)

    キャンセル

  • 2018/11/24 18:43

    これもダメでした。丁寧に教えてくださり、ありがとうございました。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.59%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る