質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.45%

  • WordPress

    9158questions

    WordPressは、PHPで開発されているオープンソースのブログソフトウェアです。データベース管理システムにはMySQLを用いています。フリーのブログソフトウェアの中では最も人気が高く、PHPとHTMLを使って簡単にテンプレートをカスタマイズすることができます。

  • SSL

    608questions

    SSL(Secure Sockets Layer)とは、暗号化されたプロトコルで、インターネット上での通信セキュリティを提供しています。

独自ドメインでSSL化したwordpressがエラーで表示されない

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 781

yon0313

score 1

 前提・実現したいこと

初心者です。さくらのサーバーを用いてwordpressのサイトを作ろうとしているのですが、お名前.comで取得したドメインに変更して常時SSL化しようとしたところ、サイトが表示されなくなってしまいました。
管理画面は変更後のドメインで問題なく利用できます。サイトは403か500のエラーが表示されます。
.htaccessと.index.phpはドメイン直下のフォルダに移動して、SAKURA RS SSLのプラグインにてSSLを追加しました。

 発生している問題・エラーメッセージ

さくらからエラーログを確かめると、以下二つが表示されています。
[Sat Nov 17 15:20:27.902829 2018] [core:error] AH00124: Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace.
[Sat Nov 17 15:20:35.743495 2018] [autoindex:error]AH01276: Cannot serve directory /home/ドメイン名/www/フォルダ名/: No matching DirectoryIndex (index.html,index.htm,index.shtml,index.shtm,index.cgi,index.php,index.hdml) found, and server-generated directory index forbidden by Options directive

 該当のソースコード

.htaccessの記述内容が問題かな?と思いますが、何がおかしいか分かりません。記述は以下の通りです

# BEGIN SAKURA Internet Inc.
<IfModule mod_deflate.c>
    SetOutputFilter DEFLATE
    AddOutputFilterByType DEFLATE text/css
    AddOutputFilterByType DEFLATE application/x-javascript application/javascript application/ecmascript
</IfModule>
<IfModule mod_expires.c>
    ExpiresActive On
    <FilesMatch "\.(css|js)$">
        ExpiresDefault "access plus 1 week"
    </FilesMatch>
    <FilesMatch "\.(gif|jpe?g|png)$">
        ExpiresDefault "access plus 1 month"
    </FilesMatch>
</IfModule>
# END SAKURA Internet Inc.

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress
# BEGIN Force SSL for SAKURA
# RewriteしてもHTTPS環境変数を有効にする
SetEnvIf REDIRECT_HTTPS (.*) HTTPS=$1

# 常時HTTPS化(HTTPSが無効な場合リダイレクト)
<IfModule mod_rewrite.c>
RewriteEngine on
RewriteCond %{ENV:HTTPS} !on
RewriteCond %{REQUEST_URI} !/wp-cron\.php$
RewriteRule .* https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]
</IfModule>
# END Force SSL for SAKURA


いろいろ試しているのですが、全然うまくいきません><もし何か分かったらお教えいただけると幸いです。
よろしくお願いいたします。

追記
cookieを削除したら管理画面も開けなくなりました。正しいパスワードを入力してもログインできません。
もう完全にどうしたらいいかわかりません。。。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

+4

(質問がいくつかあるのでこれは本来「追記・修正依頼」に書くべき内容な気がしますが、インラインだと読みづらいので回答欄に書かせていただきます)

「さくらのサーバー」というのは、さくらインターネットさんのレンタルサーバーのこと、ですよね?さくらインターネットさんの公式ページにトラブルシューティングのためのガイドがありますが、そちらはお試しになりましたでしょうか。

  • https://help.sakura.ad.jp/hc/ja/articles/115000047641
  • https://help.sakura.ad.jp/hc/ja/articles/115000051662

まだご覧になっていない場合は一度ご確認してみてください。

途中いろいろやってわけがわからなくなってしまった場合は、まずいったん元の状態に戻して(プラグインを無効化・削除して)、リダイレクトの無い形でサイトが問題なく動くことを確認されるのがよいかと思います。その上で改めて、公式のガイドに沿って、プラグインで設定を施しリダイレクトを有効化されるとよいのではないかと思います(方法が上のページに載っています)。

ただ、

.htaccessと.index.phpはドメイン直下のフォルダに移動して

のところが、何のためにどういうことをやっていらっしゃるかわからなかったのでここが少し怪しい気がしました。次のエラーが出るということは WordPress を適切に設置できていないようにも見受けられます。

No matching DirectoryIndex (index.html,index.htm,index.shtml,index.shtm,index.cgi,index.php,index.hdml) found, and server-generated directory index forbidden by Options directive

「ドメイン直下のフォルダに移動して」というのは具体的に、何を目的に、どういうことをされたのでしょうか。それを(フルパスで具体的に)説明されると、有益な回答をもらえやすいのではないかと思います。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/11/17 21:18 編集

    コメントありがとうございます。
    さくらインターネットのレンタルサーバーで間違いありません。しばらくさくらのアドレスを利用しサイトを作成し、後から独自ドメインを設定しようとしたのですが、お名前.comとwordpressのアドレスの設定を変更しただけでは適用されなかったので調べたところ「.htaccess」と「index.php」をひとつ上層のフォルダに移す、というのが出てきたのでそれを実行しました。同時にSSL化も行ったので、どちらが原因なのかさっぱりわからなくなってしまったところです。
    これまで(独自ドメインを設定・SSL化後)も管理画面にはログインできていたのですが、cookieを削除したら正しいパスワードを入力してもログインできなくなってしまいました。
    ひとまず、普通にサイトが使えていたさくらのアドレス「ドメイン名.sakura.ne.jp」に戻すのがよいかなと思いました。SSLの無効化といろいろ変更した「.htaccess」「index.php」の初期化を試してみる予定です。

    キャンセル

  • 2018/11/17 21:33

    ご返信いただきありがとうございます。

    なるほど。「「.htaccess」と「index.php」をひとつ上層のフォルダに移す」は独自ドメインへの移行の流れの中で実施されたのですね。さまざまな方法があるかと思いますが、個人的に私がさくらさんのレンタルサーバーで PHP で動くサイトを SSL 化したときにはそのようなことは必要無かったので、やはりそのあたりが怪しい可能性はあるものと思います(的外れであればすみません)。

    そうですね。何も問題がなければ「独自ドメインへの移行」と「 SSL 化」は同時にやってしまってよいと思うのですが、問題が出てきた場合は「独自ドメインへの移行」を完全に終わらせてから「 SSL 化」を進められた方が確実かと思います。

    このあたりのトピックを扱った記事は古くなっているもの・間違っているものも中にはありますので、基本的に公式のものを参考にし、公式の情報がどうしても得られない場合はその他の記事を参考にするのがよいかと思います。

    独自ドメイン化については次の記事が参考になります。

    - https://help.sakura.ad.jp/hc/ja/articles/206053782

    WordPress.org のものは英語のページしか見つかりませんでしたが、次のページもご参考になるものと思います。

    - https://codex.wordpress.org/Changing_The_Site_URL

    直接問題解決につながるお答えではありませんが、ご参考になればと思います。

    キャンセル

  • 2018/11/18 14:07 編集

    ご丁寧にありがとうございます。
    SSLをキャンセルしてURLを「ドメイン名.sakura.ne.jp/フォルダ名」に戻し、フォルダの場所も元に戻しましたが、サイトがエラー500で開けません。
    管理画面を開こうとしたら、
    Warning: Header may not contain more than a single header, new line detected in /home/ドグイン名/www/フォルダ名/wp-includes/pluggable.php on line 963
    といった警告がいくつか出るのですが、wp-includesのフォルダの中にpluggable.phpが見つかりません。
    どうしたらいいでしょう、、

    キャンセル

  • 2018/11/18 15:15

    そうですか。状況ご共有いただきありがとうございます。

    もし `www/フォルダ名` が WordPress のルートになっているのであれば(そのはずだと思います)、その下の `wp-includes/` には本来 `pluggable.php` ファイルが入っている(↓)はずだと思うのですが、入っていないのですね。。

    - https://github.com/WordPress/WordPress/blob/master/wp-includes/pluggable.php

    ファイルを移動された途中でどこか別の場所に行ってしまったのでしょうか。。

    500 エラーだけだと問題の特定がしづらいかと思いますので、ご質問の際にされたようにコントロールパネルのエラーを確認されてみてください。

    私が思うには、 1) レンタルサーバーのコントロールパネルで独自ドメインを解除する、 2) ファイルをすべて元に戻す、 3) WordPress の「一般設定」の「 WordPress アドレス (URL) 」と「 サイトアドレス (URL) 」の 2 つを元に戻す、の 3 つの手順で元に戻るのではないかと思うのですが、現状はどのような状態でしょう?

    ちなみに、 3) については管理画面にアクセスできなくなってどうしようも無い場合は、データベースの値を( phpMyAdmin 等で)直接書き換える必要があるかもしれません。ただ、データベースの操作を間違うとサイトが完全に壊れてしまう可能性もありますので、まずバックアップを必ず取っていただいて、ご不安な場合は直接見てくれる詳しい人にお願いする等された方がよいかもしれません。いまいちのサポートになってしまい申し訳ありません :(

    まずはファイルを元に戻すところからだと思いますが、もしまだバックアップを取られていない場合は、今の時点でも全然遅くはありませんので、ファイルとデータベースの一式のバックアップを取ってから進めていただければと思います。

    というのと、お使いの WordPress のバージョンをこちらに追記いただくとより正確な状況が共有できますので、ぜひ追記してください :)

    キャンセル

  • 2018/11/18 15:43

    たびたび素人の質問にお付き合いいただき本当にありがとうございます、本当に助かります・・・
    一度さくらのドメイン設定から独自ドメインを消去しましたところ、「Warning: Header may not contain more than a single header, new line detected in /home/ドメイン名/www/フォルダ名/wp-login.php on line 438」と表示されます。438はcookieに関する記述のようですが、いじった記憶がないのでどうしたらいいか分かりません。
    if ( SITECOOKIEPATH != COOKIEPATH )
    setcookie( TEST_COOKIE, 'WP Cookie check', 0, SITECOOKIEPATH, COOKIE_DOMAIN, $secure );
    そしてこれまでさくらのファイルマネージャーからいじってたのですが、FFFTPで開いたところpluggable.phpも見つかりました・・!!!バージョンは4.9.8です。よろしくお願いします。

    キャンセル

  • 2018/11/18 16:23

    `pluggable.php` が見つかったのですね。よかったです。バージョンも 4.9.8 とのことですね。

    wp-login.php の LINE 438 は cookie に関する記述ですが、そのあたりには上の 3) の「 WordPress の「一般設定」の「 WordPress アドレス (URL) 」と「 サイトアドレス (URL) 」」あたりの設定が影響してくるものと思います。ですので、そのあたりの設定値を元に戻す必要がある気がします。

    管理画面にどうしても入れない場合は、他の方法でこれらの設定値を変更する必要があります。次のページの `functions.php の編集` という節の説明等が参考になるものと思います。

    - https://wpdocs.osdn.jp/%E3%82%B5%E3%82%A4%E3%83%88_URL_%E3%81%AE%E5%A4%89%E6%9B%B4

    ここを元のドメイン( `ドメイン名.sakura.ne.jp` )にあわせて適切に変更してください。

    これで元に戻ると思うのですが、いかがでしょう。

    (繰り返しになりますが、ぜひファイルとデータベースのバックアップを取ってからお進めください)

    キャンセル

  • 2018/12/01 02:47

    結局作り直して、はじめにドメイン設定をすることで克服しました。
    結局どうにもできなかったですが(笑)、相談に乗っていただけたおかげで何とか乗り越えられました。今はちゃんとバックアップとってます!ありがとうございました!

    キャンセル

  • 2018/12/01 22:25

    ご丁寧に状況をお知らせくださりありがとうございます。そうでしたか!そのように言っていただけてうれしいです :)

    今回はご苦労をされたかと思いますが必ず今後につながると思います!

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.45%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る

  • WordPress

    9158questions

    WordPressは、PHPで開発されているオープンソースのブログソフトウェアです。データベース管理システムにはMySQLを用いています。フリーのブログソフトウェアの中では最も人気が高く、PHPとHTMLを使って簡単にテンプレートをカスタマイズすることができます。

  • SSL

    608questions

    SSL(Secure Sockets Layer)とは、暗号化されたプロトコルで、インターネット上での通信セキュリティを提供しています。