質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.97%

npmでインストールしてもcommand not foundになる

解決済

回答 2

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 2,214

kuniatsu

score 130

npmのインストールができなくなっています。
原因追求の方法がわからないため、ご存知の方は情報よろしくお願いします。

$ npm -v
6.4.1

$ node -v
v8.11.3


$ ls /Users/(ユーザ名)/.npm-global/lib/node_modules
@google-cloud   firebase-tools  hoek            jshint          yarn

$ ls /Users/(ユーザ名)/.npm-global/bin
functions               jshint                  yarn
firebase                functions-emulator      yarnpkg

$ sudo npm i -g vue
+ vue@2.5.20
added 1 package from 1 contributor in 3.374s

$ vue --version
bash: vue: command not found

$ ls /Users/(ユーザ名)/.npm-global/lib/node_modules
@google-cloud   firebase-tools  hoek            jshint          vue             yarn

$ ls /Users/(ユーザ名)/.npm-global/bin
functions               jshint                  yarn
firebase                functions-emulator      yarnpkg


インストールの処理は正常に走っているのですが、

bash: vue: command not found


が表示されます。
これはなぜでしょうか?

何か確認することなどあればご連絡おねがいします。

追記
解答でアドバイスいただいたコマンド結果を記載いたします。

$ npm install -g @vue/cli
npm WARN deprecated hoek@5.0.4: This version is no longer maintained. Please upgrade to the latest version.
npm WARN deprecated cross-spawn-async@2.2.5: cross-spawn no longer requires a build toolchain, use it instead
/Users/(ユーザ名)/.npm-global/bin/vue -> /Users/(ユーザ名)/.npm-global/lib/node_modules/@vue/cli/bin/vue.js

> fsevents@1.2.4 install /Users/(ユーザ名)/.npm-global/lib/node_modules/@vue/cli/node_modules/fsevents
> node install

[fsevents] Success: "/Users/(ユーザ名)/.npm-global/lib/node_modules/@vue/cli/node_modules/fsevents/lib/binding/Release/node-v57-darwin-
x64/fse.node" already installed
Pass --update-binary to reinstall or --build-from-source to recompile

> protobufjs@6.8.8 postinstall /Users/(ユーザ名)/.npm-global/lib/node_modules/@vue/cli/node_modules/protobufjs
> node scripts/postinstall


> nodemon@1.18.8 postinstall /Users/(ユーザ名)/.npm-global/lib/node_modules/@vue/cli/node_modules/nodemon
> node bin/postinstall || exit 0

npm WARN @apollographql/apollo-upload-server@5.0.3 requires a peer of graphql@^0.13.1 but none is installed. You must install peer de
pendencies yourself.

+ @vue/cli@3.2.1
added 738 packages from 515 contributors in 65.971s

$ vue --version
bash: vue: command not found

$ ls /Users/(ユーザ名)/.npm-global/lib/node_modules
@google-cloud   @vue            firebase-tools  hoek            jshint          mocha           vue             yarn

$ ls  /Users/(ユーザ名)/.npm-global/bin
functions               jshint                  vue                     yarnpkg
firebase                functions-emulator      yarn

コメント欄で教えていただいた、参考URLをみてPATHコマンドを打った結果

$ echo $PATH
/Library/Frameworks/Python.framework/Versions/3.6/bin:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin:/Library/Frameworks/Mono.framework
/Versions/Current/Commands:/Library/Frameworks/Python.framework/Versions/3.6/bin:/Users/denis/.npm-global/bin

$ vue --version
bash: vue: command not found
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

check解決した方法

0

PATHの通し方が間違っているため、
bash: vue: command not found
となっていました。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

0

タイトルと内容が一致していない様ですが、vueの場合は下記インストールで解決するかと思います。

npm install -g @vue/cli

これでvue --versionでバージョンが出てくるかと思います。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/12/11 11:48

    ご連絡ありがとうございます。
    教えていただいたコマンド試しましたが、
    bash: vue: command not found
    となります。
    どのようにこの後調査していけばいいかわからず、困っておりますので、アドバイスいただけると助かります。

    今回はvueを使っておりますが、他のnpmコマンドでも同様の現象がみられております。mochaで同様の現象が発生致します。

    本文側に、教えていただいたコマンドの結果を記載しておきます。
    よろしくおねがいします。

    キャンセル

  • 2018/12/11 16:59 編集

    OSはMacでしょうか?
    Macはちょっと分からないのですが、環境変数がおかしいのかもしれません。

    でも、npm は通ってるんですよね

    下記の質問と回答が参考になるのかもしれません
    [参考](https://teratail.com/questions/67263)

    キャンセル

  • 2018/12/11 17:41

    ありがとうございます。
    Macです。
    教えていただいたURLを参考に調べてみます。

    キャンセル

  • 2018/12/12 14:20

    解決できたようで良かったです。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.97%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる