質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.60%

rails s時のエラー解決方法について

解決済

回答 1

投稿

  • 評価
  • クリップ 1
  • VIEW 2,680

nobuhironz

score 13

 前提・実現したいこと

rubyとrailsのアップグレード後rails -v
Could not find nokogiri-1.8.5 in any of the sources
Run bundle install to install missing gems.
と言ったエラー表示が出ます。初心者なりにgemについて調べて他のですが、上手く解決が出来なかかった為こちらで質問します。

 発生している問題・エラーメッセージ

エラーメッセージ
rails s
Could not find nokogiri-1.8.5 in any of the sources
Run `bundle install` to install missing gems.

 該当のソースコード

ソースコード 

 試したこと

ruby 2.5.1 rails 5.2.1 へアップグレード直後の最初のエラーメッセージ
.rbenv/versions/2.5.1/lib/ruby/2.5.0/rubygems/dependency.rb:310:in to_specs': Could not find 'nokogiri' (>= 1.5.9) among 73 total gem(s) (Gem::MissingSpecError) Checked in 'GEM_PATH=/Users/sugawaranobuhiro/.gem/ruby/2.5.0:/Users/sugawaranobuhiro/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0', execute gem env` for more information

ネットで色々調べた結果、再インストールするとこの類のエラーは解決出来るという情報があったので再インストール
bundle install

Fetching gem metadata from https://rubygems.org/..........
Fetching rake 12.3.1
Installing rake 12.3.1
Fetching concurrent-ruby 1.0.5
Installing concurrent-ruby 1.0.5
Fetching i18n 0.9.5
Installing i18n 0.9.5
Fetching json 1.8.6
Installing json 1.8.6 with native extensions
Fetching minitest 5.11.3
Installing minitest 5.11.3
Fetching thread_safe 0.3.6
Installing thread_safe 0.3.6
Fetching tzinfo 1.2.5
Installing tzinfo 1.2.5
Fetching activesupport 4.2.6
Installing activesupport 4.2.6
Fetching builder 3.2.3
Installing builder 3.2.3
Fetching erubis 2.7.0
Installing erubis 2.7.0
Fetching mini_portile2 2.3.0
Installing mini_portile2 2.3.0
Fetching nokogiri 1.8.5
Installing nokogiri 1.8.5 with native extensions
Gem::Ext::BuildError: ERROR: Failed to build gem native extension.

current directory:
そしてrbenv rehash

結果今回の条件では解決ができず新たなエラーメッセージが
gem install rails
Building native extensions. This could take a while...
Successfully installed nokogiri-1.8.5
Successfully installed rails-5.2.1
Parsing documentation for nokogiri-1.8.5
Parsing documentation for rails-5.2.1
Done installing documentation for nokogiri, rails after 1 seconds
2 gems installed

ここに問題に対して試したことを記載してください。

 補足情報(FW/ツールのバージョンなど)

Ruby 2.5.1
Rails-5.2.1
Bundler version 1.17.1

<%=補足情報がありましたら、伝えてください。お願いします。%>
ここにより詳細な情報を記載してください。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

0

結果今回の条件では解決ができず新たなエラーメッセージが
gem install rails
Building native extensions. This could take a while...
Successfully installed nokogiri-1.8.5
Successfully installed rails-5.2.1
Parsing documentation for nokogiri-1.8.5
Parsing documentation for rails-5.2.1
Done installing documentation for nokogiri, rails after 1 seconds
2 gems installed

→これはエラーではなく、nokogiri-1.8.5, rails-5.2.1のinstallが成功したよ。 っていうメッセージじゃないですかね? rails sコマンド起動で何かまだ問題が出ますでしょうか?

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/11/15 20:35

    返信ありがとうございます。
    今回rubyの再インストールをした結果rails sをすると、
    rails s
    .rbenv/versions/2.5.1/lib/ruby/site_ruby/2.5.0/rubygems.rb:289:in `find_spec_for_exe': can't find gem railties (>= 0.a) with executable rails (Gem::GemNotFoundException)今度はこう言った内容のメッセージが出るんですが、どのような設定をしたらよいでしょうか?

    ちなみにgem fileの内容はGemfile:
    2
    3
    4: # Bundle edge Rails instead: gem 'rails', github: 'rails/rails'
    5: gem 'rails', '4.2.6'
    です。
    環境構築等一人でやるのは初めてなので大変です。

    キャンセル

  • 2018/11/16 18:22

    http://casa-jpn.hatenablog.com/entry/2018/03/03/001819
    こちらでどうでしょうか? bundler 再インストールでできそうな気がします

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.60%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る