質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.58%

railsのバージョンの変え方

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 356

Railsのバージョンを変えたいのですが調べてもよく分かりませんでした。

$ rails -v
Rails 5.0.7    #現在のバージョンです。


これをRails 5.0.1にしたいです。

$ gem install rails --version="5.0.1"
Successfully installed rails-5.0.1
Parsing documentation for rails-5.0.1
Done installing documentation for rails after 0 seconds
1 gem installed
 $ rbenv rehash

と実行したためRails 5.0.1は入っているはずだと思うのですがどのように切り替えればよろしいですか?

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

+3

Gemで入れたものについては、バージョンを特殊な形の引数として指定することができます。

rails _5.0.1_ -v

もっとも、実際にRailsアプリを作る場合にはBundlerを使いますし、bundle installしたあとにはrailsのバージョンも、Gemfileに書かれたものとなりますので、一時的に別バージョンでも気にしない、という選択肢もありです。

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/11/08 14:43

    なるほど。。。そもそもbundle installでバージョン指定するので、Rails 5.0.1にこだわる必要もなく最新バージョンを入れて置くのが普通なんですかね?

    キャンセル

  • 2018/11/08 14:48

    Railsのプロジェクト内なら「bin/rails」から実行できますし、「システムレベルでrailsを入れない」という選択肢すらあります。

    Rails 5以上なら、どれを入れておいても問題ないでしょう(Railsプロジェクト内でrailsコマンドを実行した場合は、プロジェクトで使われるRailsに中継されるので、バージョンも無関係です)。

    キャンセル

  • 2018/11/08 14:50

    そうなのですね。理解いたしました!
    詳しい回答ありがとうございます!

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.58%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る