質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.59%

jQueryでテーブルに行追加 Safariだけエラー

受付中

回答 2

投稿

  • 評価
  • クリップ 0
  • VIEW 1,275

RitaAme

score 10

 前提・実現したいこと

jQueryを用いてHTMLのテーブルに行を追加しようとしています。

 発生している問題・エラーメッセージ

Safariのみ、以下エラーが発生し行追加が行えません。
TypeError: 'undefined' is not a function (evaluating 'e.getAttribute("type")')

 該当のソースコード

<html>
    <head>
        <title>テーブルに行を追加する</title>
        <meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
        <script src="https://ajax.googleapis.com/ajax/libs/jquery/3.3.1/jquery.min.js"></script>
    </head>

    <body>
        <table id = "sample_table">
            <tbody>
                <!-- ここに行を追加する -->
            </tbody>
        </table>
        <script>
            $(function() {
                $('#sample_table tbody').append('<tr><td>列1</td><td>列2</td><td>列3</td></tr>');
            });
        </script>
    </body>
</html>

 試したこと

・append以外のDOM追加メソッドでの試行(prepend、appendTo)
・appendの引数を単純な文字列にすればエラーは出ないが、<tr>要素で挿入できない。

SafariのみjQueryの挙動が怪しくなるのは認識しているつもりですが、DOM追加関連の記事などは
見つけることができませんでした。

 補足情報(FW/ツールのバージョンなど)

正常に動作するブラウザ
・GoogleChrome 70.0.3538.77
・InternetExplorer 11.345
・Microsoft EdgeHTML 17.17134
・FireFox 63.0.1

エラーが出るブラウザ
・Safari 5.1.7

Safariでも正常に動作する行追加の方法はありますでしょうか。
お手数おかけしますが、ご教示のほど宜しくお願いいたします。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • m.ts10806

    2018/11/01 15:25

    あまり関係がないかもしれませんがSafariはMacのSafariですか?WindowsのSafariですか?

    キャンセル

  • m.ts10806

    2018/11/01 15:26

    エラー内容からするとjQuery本体に出てそうですね。バージョンを2系や1系にかえてもダメですか?

    キャンセル

回答 2

0

下記のような記事が参考になるかもしれません。

jQuery 3.x系
Safari:最新バージョンとその一つ前のバージョン

利用されているSafari5.1.7はバージョン履歴からすると
2012年5月9日リリースのもののようですね。6年半前なのでかなり古いです。
jQuery3系のリリースが2016年6月ということからすると、非対応のブラウザである可能性も高いです。
2.x系か1.x系にかえれば動作しそうに思います。

お試しください。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

0

Browser Support - jQuery

If you need to support older browsers like Internet Explorer 6-8, Opera 12.1x or Safari 5.1+, use jQuery 1.12.

とあるので、jQuery 1.12 を使えばいいと思います。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.59%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る